WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP-ADMIN NOT WORKING (20 posts)

  1. celebrii
    Member
    Posted 2 years ago #

    Please help me with this problem! I am trying for a couple of days to resolve the wp-admin X( i don't understand why is not working! ....
    i think the problem is .htaccess . i deleted it whithout knowing, and now i don't know what to put in it.... i've been trying a lot of methods but non of it works....
    i log on, it shows me the navigation bar with Admin, Dashboard, Add new post etc etc... and when i click one of them it shows:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@celebrii.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    PLEASE HELP MEE !!!!

  2. Harry
    Member
    Posted 2 years ago #

    If it helps, here's mine, however I don't think that should necessarily be preventing your wp-admin section from showing. I think you may need to try and download the same version of WordPress as you have, and try replacing the files, as you may have deleted more than just the .htaccess file.

    .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  3. celebrii
    Member
    Posted 2 years ago #

    thank you harmck for responding.
    now when i click, the dashboard, add new post, comments etc, it shows a blank page! X( ....
    can anywone tell me if this could be a problem from my hosting ?
    i am using :
    Apache version 2.2.19
    MySQL version 5.0.92-community
    Perl version 5.8.8
    Operating system linux
    ...help me.... please!

  4. Sabinou
    Member
    Posted 2 years ago #

    I can't explain why, but in the past, I've seen times when an htaccess file change took a long time to be taken in by the server, maybe it's your case.

    Otherwise...

    The usual suspects in such a case would be a faulty plugin/theme or corrupted blog core files (possibly also with wrong file permissions).

    - Assuming you've made a backup of (root)/wp-content/ , you can try and rename by FTP (no need to delete, renaming deactivates them already, for instance add an underscore) the folders of your non-default plugins and themes. See if it helped.

    - For the core files... Just in case, some useful info : REINSTALLING WORDPRESS IS SAFE ! (Assuming you make backups ;) )
    http://codex.wordpress.org/Installing_WordPress
    When there's already a wordpress installed, you can just delete the wordpress files in the root (and only the wordpress files, cf the contents of wordpress.zip as you downloaded it, and don't delete your wp-config.php), and next delete (root)/wp-admin and (root)/wp-includes, and finally reupload by FTP the contents of your wordpress.zip archive (not the "wordpress" internal folder, the contents of that folder).

    My advice may be scary, if you're not used to what I'm suggesting, don't go berserk and risk panic while trying with fear, you'd best wait for other advice, then :)

  5. celebrii
    Member
    Posted 2 years ago #

    it's not working..........X(X(X(X(
    can i trust somebody from wordpress to give him my admin password and try to resolve my problem ???? please can anybody help me???

  6. Sabinou
    Member
    Posted 2 years ago #

    Giving your password to someone you don't know would sound like the worst possible idea of the day. You'd better wait one more day to see if there are other replies to help you...

  7. celebrii
    Member
    Posted 2 years ago #

    man, it seems that nothing is working! i've been trying all the methods and nothing....i don't know what to do else........

  8. Harry
    Member
    Posted 2 years ago #

    sabinou1 is correct, probably not a good idea to give someone you don't know access to your website. Would you give a complete stranger a lend of the keys to your car/house?

    What did you do to your install prior to it not working properly?

    You said you deleted your .htaccess file? any others? have you tried re-installing wordpress?

    Have you checked the error logs on the server, as they may indicate further what the errors are, it might be that more files are missing.

    You may need to contact a web developer who will quote you for fixing this if this is a really important website.

  9. celebrii
    Member
    Posted 2 years ago #

    ok now, i had installed whe wordpress version 2 . and works....but the last version 3.2.1 is not working, it gives me the error 404/500 or it shows a blank page, or the wp-admin is not working....
    the version 3.2.1 is not working, i've tried the 3 version but is not working.
    so the only one that works is the 2 version. i am now trying to install the 1.8.5 version to see if that works... any ideas????

  10. Harry
    Member
    Posted 2 years ago #

    You should only try to install the exact same version as already installed. Do not put a version of WordPress that is less/greater than the WordPress Database you have, as generally there have been changes between the versions. The longer you tinker like this you could end up making the problem a whole lot worse.

    Any luck with those logs? As 404/500 errors won't lead us to the root of the problem.

    To be honest, it's very hard to help you fix the problems when don't know what state the website is in, apart from telling us it's not working.

  11. Sabinou
    Member
    Posted 2 years ago #

    Celebrii, otherwise, if it were me, I would

    - backup everything (files by FTP, everything starting from the root folder, and also the database), cf this : http://codex.wordpress.org/WordPress_Backups

    - and then, simply delete everything (deleting files by FTP, emptying the database with phpmyadmin)

    - and finally, do a clean reinstallation, to see if it works now, downloading the wordpress archive from wordpress.org and uploading its contents to your hosting account by FTP.
    . If it does work, you can import again your database in phpmyadmin (settings : crush the previous version of the DB, if you're unfamiliar, empty it again and then reimport your backup), and see if nothing got broken
    . if nothing got broken, next, reimport to wp-content/themes your blog template from your local hard disk backup,and activate this previous theme
    . if nothing got broken, next, reimport your blog plugins to wp-content/plugins, activate them, and see if everything still works
    . if nothing got broken, reimport the wp-content/uploads from your local backup, same deal, see if everything still works

    Chances are that,
    - either you'll have now cornered what is responsible for your problem,
    - or you'll have failed to find what the problem is, but in exchange you'll have ended with a fully working blog once again.

    (Key idea : if you do a backup of both the files and the database, it's allowed to screw up, since you can restore everything in a few minutes)

  12. celebrii
    Member
    Posted 2 years ago #

    celebrii.com is the first site i have... so i`m new in this...
    in the first day i've uploaded a website done by me with microsoft office frontpage 2002....
    then i realised that i don't like what i've done, so the next step was to DELETE ALL THE CONTENT OF PUBLIC HTML with the freezila ftp.
    i logged into my CPANAL of the site -> SITE SOFTWARE -> BLOGS -> ISTALLED WORDPRESS . i accessed my site, i logged in and this error occured:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@celebrii.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    then i started googeling.... i've found that my .htaccess would be the reason that my blog is not working. so i've put in my .htaccess this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    WHAT DO YOU THINK ? NOTHING! .....
    then i uninstalled the wordpress from my CPANEL - > SITE SOFTWARE
    my public html, was empty....i deleted the database created so evrything cleared.
    ok, now i've downloaded the lastest version 3.2.1 on my pc. extracted it, and uploaded directly in my public html ....i've created a new database.
    i accessed the site, i started the configuration, it said to me: ALL RIGHT SPARKY or something like that....ok then.
    i logged in in the celebrii.com/wp-login.php when i added my admin name and password.
    what do you think ? NOTHING ! up in the browser where it shows the adress you curently are(adress bar) was writing: celebrii.com/wp-admin/
    and the page was blank !! !X(
    then i've maked a new .htaccess with that code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase / ETC
    ETC ETC....
    NOTHING !
    now.... i installed the wordpress version 2. and works!!!
    i deleted it.
    i installed the 2.5 version.
    it works !
    but...when i install the, 2.8 verion or the 3 or the 3.2.1 version... i can't access the wp-admin ! It simply gives me the erorr with 404 not found, or 500 internal server error, or a blank page...
    how it's possible, that i know how to install the 2 version , or the 2.5 version and the 3.2.1 not ?? so i don't think ME is the problem... can somebody tell me what... is happening?

  13. Sabinou
    Member
    Posted 2 years ago #

    Hm, maybe your host runs an old version of the php engine (Apache version and SQL version are another matter), I think there has been an update in the recent wordpress versions to discard too old PHP engines.

    Cf http://kb.mediatemple.net/questions/764/How+can+I+create+a+phpinfo.php+page%3F#gs
    to know what's your php version

    And to know the wordpress php requirement :
    http://wordpress.org/about/requirements/

    How about it ?
    (BTW, who's your host ?)

  14. celebrii
    Member
    Posted 2 years ago #

    my php version PHP Version 5.2.9
    wordpress requirments 5.2.4 or greater
    my host is storeweb.ro
    NEW ! : I UPDATED FROM 2.5 to 3.2.1 and again the eror 404 / 500 internal server but i've put again the .htaccess file into the /public html and now
    when i click dashboard/edit my profile/ appearance/add new post etc loads the index page...i fell i`m close ... can you tell me what to do next?...

  15. Harry
    Member
    Posted 2 years ago #

    If you have the error logs, they would offer more insight to the problems with the errors.

    As I said, it's hardly just .htaccess related.

    As 2.X versions were working, and as sabinou1 quite rightly said, WP dropped support for PHP4 in version 3.X.

  16. Sabinou
    Member
    Posted 2 years ago #

    Frankly, me, I'm at a loss.

    Maybe trying to add this in the beginning of your htaccess file,
    SetEnv PHP_VER 5
    (I doubt it will help)

    Else, since it all started with an auto-installation by your host, contact them too, they might have particular rules working only with them ?

  17. celebrii
    Member
    Posted 2 years ago #

    sorry...i cannot make it work. so i will stay at the 2.5 version :( ... thank you for help.......

  18. mochonty
    Member
    Posted 2 years ago #

    Hello,
    maybe it´s a plugin error. Go with your FTP to your account, wp-content, plugins, and rename the plugins folder to "pluginsold", then upload an empty folder with the name "plugins". Try to log in your wp-admin, and when it works, under the plugins secction you will have a message "all plugins were desactivated during an error".
    Then you go again to your FTP, delete the empty plugins folder and rename again the "pluginsold" to "plugins".
    Then you have to activate the plugins again in your wp-admin.
    This helps for many errors, I hope this time to. Not updated plugins many times generate errors.

  19. celebrii
    Member
    Posted 2 years ago #

    i finally resolved the problem !!!!!
    i've created a php.ini pasted in my public_html folder and in the wp-admin folder.
    with this containig:

    max_execution_time = 90
    max_input_time = 300
    memory_limit = 32M
    post_max_size = 8M
    upload_max_filesize = 8Mp

    thank you all for helping !

  20. Sabinou
    Member
    Posted 2 years ago #

    Interesting... Was it suggested by your web host ?

    Anyway, I'm glad it worked out eventually :)

Topic Closed

This topic has been closed to new replies.

About this Topic