WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin not found error (7 posts)

  1. Te Calleja
    Member
    Posted 3 years ago #

    hi everyone,

    a few days ago, i was getting a 404 (not found) error when i go to my wp-admin. after searching the forum and google, i came across so many posts and suggestions, but none of them worked for me. i am enumerating them here, as it may work for some people searching for help on that error. here are the things i tried:

    1. cleared my cache
    2. re-uploaded wp-admin
    3. re-uploaded wp-includes
    4. disabled plugins (via ftp by renaming plugins folder, since i can't log in)
    5. added code

    /** wp-admin login fix */
    @define('ADMIN_COOKIE_PATH', '/');

    to my wp-config.php file as suggested here http://www.kinocreative.co.uk/hints-and-tips/wordpress-cant-login-to-wp-admin/
    6. changed folder permissions as suggested here http://www.techzoomin.com/wordpress-login-issueswp-admin-showing-404-error-page/
    7. checked my login file (among others) as suggested here http://codex.wordpress.org/Login_Trouble

    i then discovered that i was able to log in using one of my other usernames that has editor role... but none of my admin usernames can log in. i went into phpmyadmin and replaced the wp_capabilities of my admin to make it the same as the editor -- and i was able to log in!

    not sure if this is a bug... around that time, i had already sought the help of my hosting provider, and they replied that there was a symbol lookup error of suhosin. they had resolved the issue on their side, and i was able to log in to wp-admin again.

    anyway i hope this post helps others looking for a solution to that problem, and i hope someone can also look into that issue i encountered (able to login as editor, but not as admin) -- if its really a bug, or just a hosting issue on my side.

    thanks!

  2. Gilligan
    Member
    Posted 3 years ago #

    Same problem here, occurred after installing W3 Total Cache, using disk caching.

    Front End Website and W3 Total Cache are functioning properly, but Admin login is causing error below, which results in display of the WordPress 404 page (not actually a 404 error)
    Site is hosted on a CentOS 5 Cpanel server.

    /usr/bin/php: symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so: undefined symbol: zend_atol, referer: http://mywebsitehere.tld/wp-login.php
     Premature end of script headers: index.php, referer: http://mywebsitehere.tld/wp-login.php
  3. Gilligan
    Member
    Posted 3 years ago #

    Temporary fix:

    To get this issue fixed, you can do the below steps:

    It seems that Suhosin breaks the application. So need to disable the Suhosin for this domain. You can disable the suhosin by creating a php.ini file at /home/username/public_html/php.ini with the following code.

    suhosin.simulation = On

    If you are still getting same error then you need to create same php.ini file with same code (suhosin.simulation = On) at each directories. In this case at these paths also /home/username/public_html/php.ini, /home/username/public_html/forum/php.ini and /home/username/public_html/install/php.ini

    I added the one-liner mini ini (be sure to add a return after the one line) to /public_html and /public_html/wp-admin

    Source:
    http://supportfacility.com/blog/general/suhosin-error-on-subdomain/
    via:
    http://tinyurl.com/suhosin-cpanel-php-ini

  4. Gilligan
    Member
    Posted 3 years ago #

    Oh, and it's likely you may need to restart apache (or request restart from your hosting provider) for the change to take effect.

  5. Frederick Townes
    Member
    Posted 3 years ago #

    @PlayGod thanks for the tips. Will spend more time testing recent changes against suhosin soon.

  6. Gilligan
    Member
    Posted 3 years ago #

    Frederick, I think this is more of a problem on Cpanel servers than elsewhere. I did not see this issue on my own server, which runs PHP in fcgid, not with suhosin.

    I checked on the Cpanel forum and there are lots of issues with WP 3.0.1 administrator level users having issues with suhosin.

  7. Frederick Townes
    Member
    Posted 3 years ago #

    I see.

Topic Closed

This topic has been closed to new replies.

About this Topic