WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin login page (32 posts)

  1. alex0_1
    Member
    Posted 3 years ago #

    Blog site is : http://alex.velcomweb.ca

    After I try to log in to change things the wp-admin page returns as blank. I have searched this problem and it seems that most of the time it is cause by plugins or wordpress version, but not in this case.
    What could be the reason ?
    I also tried a fresh install, and I encounter the same problem.

  2. Tara
    Member
    Posted 3 years ago #

    I have searched this problem and it seems that most of the time it is cause by plugins or wordpress version, but not in this case.

    Please elaborate

  3. alex0_1
    Member
    Posted 3 years ago #

    I have no plugins installed, except askimet which comes with WP. The people who were having problems had their blogs for a while on the net, and they knew it was a plugin that caused it because it was after they installed it that their login page didn't work. So I guess I'm doing something wrong ?

  4. Tara
    Member
    Posted 3 years ago #

    Have you tried:

    -switching to the default theme to rule out any theme-specific issue?

    If you don't have access to your admin area, then access your server via FTP or SFTP or whatever file management application your host provides.

  5. alex0_1
    Member
    Posted 3 years ago #

    It is the default theme that I'm running.
    Don't know what else to do. Even if I reinstall the blog, it will experience the same problem.
    I suspect that it's the .htaccess file that has something wrong in it..

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  6. Tara
    Member
    Posted 3 years ago #

    and they knew it was a plugin that caused it because it was after they installed it that their login page didn't work.

    which plugin they installed?
    has that plugin been deactivated?

  7. alex0_1
    Member
    Posted 3 years ago #

    I was just giving an example for you to understand that in my case this is not caused by X,Y plugin, because I didn't install any.

  8. Tara
    Member
    Posted 3 years ago #

    Apparently the the troubleshooting steps suggested in previous posts did not resolve the issue.

    -Download WordPress again and replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory.

    Note that some uploaders may not overwrite files reliably, so delete the original files before replacing them.

    -if that does not resolve the issue, try increasing memory available for php.

  9. alex0_1
    Member
    Posted 3 years ago #

    I did as you told me reinstalled everything except wp-config.php and wp-content, no luck at all.

    When I tried to increase memory I get this error:
    Invalid command 'Define('WP_MEMORY_LIMIT',', perhaps mis-spelled or defined by a module not included in the server configuration

    Someone also wrote "apparently it has to do with the way Apache looks at the index.php file. The following is from the post by k.v.ahuja.

    Solution 1
    If allowed by your host, putting this in an .htaccess file will solve the problem:
    DirectoryIndex index.html index.htm index.php

    Solution 2
    Some hosts allow you to make a change, via their hosting control panel, to the DirectoryIndex. It's typically described as Indexes or Index documents, but may also require you to type something like
    DirectoryIndex index.html index.htm index.php
    or specify index.php as an index type file.

    Solution 3
    Instruct Apache to treat index.php as an index file. If you own the server, or have access to the http.conf file, simply modify the DirectoryIndex line in httpd.conf to:
    DirectoryIndex index.html index.htm index.php"

    Solution 1 doesn't work.
    Don't know what else to do..

    P.S Can this problem come from the hosting server/company ?

  10. Tara
    Member
    Posted 3 years ago #

    check with your hosting server. Also check even if they allow .htaccess!

  11. alex0_1
    Member
    Posted 3 years ago #

    They allow .htaccess

    Any more ideas ?
    I installed http headers and firebug they report no errors and the files load fine. I'm about to give up on this one.

  12. Tara
    Member
    Posted 3 years ago #

    temporarily rename / delete your .htaccess and see if that resolves the issue.

  13. alex0_1
    Member
    Posted 3 years ago #

    I tried that, it doesn't.

  14. Tara
    Member
    Posted 3 years ago #

    I am running out of ideas. You may double check your wp-config.php file settings for the database and host names, etc.?

  15. alex0_1
    Member
    Posted 3 years ago #

    Well if I had an error there the whole blog wouldn't show up.

  16. esmi
    Forum Moderator
    Posted 3 years ago #

    Are you running any other WP installs on the same server? Note "server" - not "hosts".

  17. alex0_1
    Member
    Posted 3 years ago #

    No sir. Only one.

  18. esmi
    Forum Moderator
    Posted 3 years ago #

    It could be a server problem - especially since t-p has pretty much covered everything else. Another option is that there's a problem in the database itself. Do you access to any recent backups that were made before the problems started?

  19. alex0_1
    Member
    Posted 3 years ago #

    I contacted the ISP that provides the server and they said " Check your scripts." :/

    Uhm, no I didn't access any backups. This is the first time I'm trying installing WP to the server.

  20. esmi
    Forum Moderator
    Posted 3 years ago #

    Set up a new database and edit wp-config.php to point to it. Then re-run wp-admin/install.php. Do not import the old database. The point of the exercise is to see if the site functions pre-import.

  21. alex0_1
    Member
    Posted 3 years ago #

    It may sound stupid but how do I know if the site functions pre-import.
    BTW, I did what you have asked me.

  22. esmi
    Forum Moderator
    Posted 3 years ago #

    Can you login to wp-admin?

  23. alex0_1
    Member
    Posted 3 years ago #

    No.

  24. esmi
    Forum Moderator
    Posted 3 years ago #

    In that case, it's not a problem with your database backup. If you have any .htaccess files in the root of your domain, can you rename them? Also download a fresh copy of WP and upload all files & folders.

    Do you have access to server error logs?

  25. alex0_1
    Member
    Posted 3 years ago #

    [Thu Nov 04 18:01:31 2010] [error] File does not exist: /usr/home/alex01ca/public_html/favicon.ico
    [Thu Nov 04 18:01:31 2010] [error] File does not exist: /usr/home/alex01ca/public_html/404.shtml
    [Thu Nov 04 18:01:31 2010] [error] File does not exist: /usr/home/alex01ca/public_html/favicon.ico

    These are from the error logs. Renamed .htaccess still no change, uploading new files as we speak.

  26. esmi
    Forum Moderator
    Posted 3 years ago #

    Those error log entries can be safely ignored.

  27. alex0_1
    Member
    Posted 3 years ago #

    Okay so, I've downloaded again WP and put the files to the FTP. I still see a blank page after I login. I've put a php code to see the informations and it seems that I have the rewrite mode, because I thought that it was because maybe of that.

  28. esmi
    Forum Moderator
    Posted 3 years ago #

    Sorry? Do you means that mod_rewrite is running on your server? If so, you need it and it shouldn't create any problems unless you have rewrite rules in your root .htaccess file.

  29. alex0_1
    Member
    Posted 3 years ago #

    Yes it's working that what I meant. I don't have nothing in the .htaccess file

  30. esmi
    Forum Moderator
    Posted 3 years ago #

    This has to be server related. Have you spoken to your hosts about this at all?

Topic Closed

This topic has been closed to new replies.

About this Topic