WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin isnt loading (25 posts)

  1. bcarlson41
    Member
    Posted 4 years ago #

    I have just installed wordpress on my site today. I have two issues happening. 1_ when you go to my URL http://www.carlsondesignco.com where it is installed it does not load the page. If i go to http://www.carlsondesignco.com/index.php it did load up. BUT now when i go there it loads the page as simple text, no CSS is applied. When i try to go to my wp-admin page, it loads the same thing. My dashboard does not come up. I don't know what happened or how to fix it.

    Any help?

  2. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 4 years ago #

    It looks like an additional index.php has somehow crept into the paths referenced by the page.
    can you log in at the following URL?:
    http://www.carlsondesignco.com/wp-login.php?redirect_to=http://www.carlsondesignco.com/wp-admin/

    and check that under settings -> general the
    WordPress address (URL)
    is set to
    http://www.carlsondesignco.com
    & not
    http://www.carlsondesignco.com/index.php

  3. ClaytonJames
    Member
    Posted 4 years ago #

    You may want to start by consulting your hosting information about getting started. Step one would be to delete the default placeholder page that is currently in your site directory, and-or- by configuring your default pages. (index.html or index.php - etc...)

    http://www.carlsondesignco.com/

  4. jswching
    Member
    Posted 4 years ago #

    Urgent help!!!!

    I have installed a new customised theme and not not able to login to wordpress admin.
    It gives this message. How can I solve this? Making it very scary.
    I can still see my blog: http://gourmettraveller88.com

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/j/s/w/jswching/html/wp-content/themes/janet_ching/functions.php:633) in /home/content/j/s/w/jswching/html/wp-login.php on line 290

    Grateful if someone can help!

    Many thanks, Janet

  5. jswching
    Member
    Posted 4 years ago #

    I have found this thread
    http://codex.wordpress.org/Answers-Trouble_Shooting#Headers_already_sent
    and have tried myself but did not work.

  6. kalynna
    Member
    Posted 4 years ago #

    I'm having the exact same problem on a blog I installed Aug. 19th as well.

    The page loads with no CSS applied, just simple text. When you click on Site Admin it just defaults back to the same index page over and over.

    I've removed the database in Fantastico and removed the WP files and tried reinstalling, but the same things happens each time.

    http://healthwealthmatters.com

  7. Zulfikar Nore
    Member
    Posted 4 years ago #

    For those of you who are having blank pages and non-css formating its because not all the files were uploaded correctly or are incomplete. You need to re-upload the wp-admin and wp-includes folders.

    The theme ralated issue means its not compatible with current version of wordpress, if it is then again incomplete upload.

    @jswching - your theme's functions.php is interfering with your login.php. Try deactivating it by renaming it via your ftp.

    Would be helpful if you can paste what line 633 says.

    In any case you should try to get your installation working with the default theme before uploading/using a new one and activating any plugins.

  8. s_ha_dum
    Member
    Posted 4 years ago #

    kalynna, something is weird with your stylesheet. I've tried three different ways to grab your stylesheet and I always get the home page in source. In other words, something is causing your front page to load as if it were the stylesheet. Your background image also redirects in the same weird way-- try it. Have you edited anything-- .htaccess maybe? Have you disabled all plugins?

  9. kalynna
    Member
    Posted 4 years ago #

    Actually, I deleted the whole installation for other reasons from my cPanel, and database via Fantastico. Now as I try to reinstall, you see what's happening.

    I haven't edited any files but maybe there is an edit that needs to happen to the .htaccess?

    Clearly, the way I deleted the blog the first time has affected reinstalling, but the why is beyond my WP knowledge.

  10. s_ha_dum
    Member
    Posted 4 years ago #

    Are you reinstalling via Fantastico? If so, search the forums. There is something weird you have to do when you do that-- delete some hidden file I think it is. (Sorry. I can't remember exactly.) I'd suggest not using a script though. Do it manually.

  11. bcarlson41
    Member
    Posted 4 years ago #

    mine is still not working. I tried http://www.carlsondesignco.com/wp-login.php?redirect_to=http://www.carlsondesignco.com/wp-admin/ and it took me to a login page and then after i log in it goes back to the unformatted CSS page. I did recopy over the wp-admin and wp-includes folders and it didnt do anything. Thanks to all of you who have given me suggestions! Should i just reinstall and if so, how do i do that?

    --frustrated--

    thanks,
    Billy

  12. bcarlson41
    Member
    Posted 4 years ago #

    okay, I reinstalled everything. Now, how do I "onfigure your default pages. (index.html or index.php - etc...)"

    I have no clue on how to make my site actually work? if i go to the index.php page, it works, but if i click on any link it takes me to that hosting temp page? WTF????

    any help will be much appreciated

  13. kalynna
    Member
    Posted 4 years ago #

    Yes I have been trying to reinstall via Fantastico. I'll look around some more but haven't had any luck yet. Thanks!

  14. kalynna
    Member
    Posted 4 years ago #

    Tried deleting and reinstalling manually as per the WP tutorials. Still have exact same problem.

    Any ideas as to a hidden file somewhere that needs to go?

  15. Zulfikar Nore
    Member
    Posted 4 years ago #

    @bcarlson41 and kalynna - I can take alook at your installation and try to get it working for you. Drop an email via the contact us on my site.

  16. kalynna
    Member
    Posted 4 years ago #

    Okay, I sent you something. Let me know if you need any particular information. Thanks

  17. tknass
    Member
    Posted 4 years ago #

    Hi everyone. Guess what I'm also facing the same thing that kalynna is going through. I tried reinstalling the entire WP from scratch(after deleting everything) but with no luck. There are no extra themes or plugins added. The website is in text form with no CSS. Even the login page is also in simple text!

    http://biz-mania.com/

    ZGani, I believe you responded to my last post and thanks for that, but I guess my explanation wasn't that great. Whatever kalynna is going through I going through the same. Here is the link for the my previous post http://wordpress.org/support/topic/301491?replies=6

    Do you thing it has anything to do with the database on MySQL? (P.S. I haven't touched anything there!)

    P.S.S. When I actually do try to login, it redirects me to http://biz-mania.com/index.php/wp-login.php.

    Many thanks!!!

  18. tknass
    Member
    Posted 4 years ago #

    The default site was installed along with the new re-installation of WP. There were no other themes uploaded when I tried to login.

  19. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 4 years ago #

    [quote: tknass] When I actually do try to login, it redirects me to http://biz-mania.com/index.php/wp-login.php.

    This can be caused by the setting for blog url being incorrectly set to http://biz-mania.com/index.php rather than http://biz-mania.com
    If this is the case, it will probably prevent you from being able to log in. You can check whether this is the case and correct it by connecting to the database using phpmyadmin and looking at the value for site_url in the wp_options table and correct it.

  20. Zulfikar Nore
    Member
    Posted 4 years ago #

    @tknass - check your .htaccess - fantastico's rewrite rules are inccorect.
    That was the problem with Kalynn's blog, renamed the .htaccess and all's working fine now.

    See the result here: http://healthwealthmatters.com/

    Rename your .htaccess then reset your permalinks and let wordpress write you a new one. If it doesnt due to permissions issue then creat one and add this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  21. tknass
    Member
    Posted 4 years ago #

    numeeja - I went to the phpmyadmin and there were no site_url in the wp_options.

    ZGani - Not sure if it matters but I have windows hosting plan. At any case I tried creating .htaccess through notepad and uploaded it through FTP as I don't have fantastico, changed it to .htaccess file and there was nothing. I'm currently using Filezilla.

    The hosting company is blacknight.com. Not too blog friendly unfortunately.

  22. tknass
    Member
    Posted 4 years ago #

    Mkamylink, sorry i didn't get back to you. I tried to change the default theme but couldn;t find how and where. Can you please let me know how? If there is a link I can read and follow the instructions (which goes to everyone) that would be great.

    Many thanks!

  23. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 4 years ago #

    tknass: numeeja - I went to the phpmyadmin and there were no site_url in the wp_options.

    Are you sure? There should be one & it should be set to your site address, ie http://www.carlsondesignco.com
    can you have another look?
    There's a guide here: http://www.tamba2.org.uk/wordpress/site-url/

  24. Zulfikar Nore
    Member
    Posted 4 years ago #

    Ah ok, windows server have their own way of handling rewrite rules. What OS are you on?

    There are modules you can add to handle the rules but am told they are only for Windows 2008, Vista and Windows 7 with IIS 7.0 running php under FastCGI mode.

    Do you have a web.config file in your installation folder?

  25. tknass
    Member
    Posted 4 years ago #

    RESOLVED!!!

    Hi... I thought I already replied to this issue!!! I guess the broadband wasn't very reliable where I was on holidays.

    Please note I managed to fix the issues I had above. I managed to find the site_url in phpmyadmin and changed all the urls to the right one. That fixed everything.

    many thanks to all the helped with their advice.

    Regards,

    tknass

Topic Closed

This topic has been closed to new replies.

About this Topic