WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin causes a 404 and only start page is reliably displayed (4 posts)

  1. sckoobs
    Member
    Posted 5 years ago #

    Hi there,

    I've been searching high and low for a solution to this and I've seen a lot of similar posts but none seem to exactly match my situation and a lot of the suggested fixes do not work.

    Basically, my wordpress blog will display nothing but the default start page. When I click on any categories, pages or archives it just redirects me back to the default page. The URL does change according to what I click on but the default page is always displayed.

    When I attempt to goto /wp-admin I get a redirect and ultimately an Error 404 - Not Found. So at the moment I cannot log in.

    I have tried the normal links for each post (i.e. http://www.freebiefacts.com/?p=3) but the pretty links don't work.

    I recently upgraded to wordpress 2.6. I'm experiencing this on a couple of blogs that I run, both exhibiting exactly the same symptoms.

    Any help would be much appreciated.

    Thanks,
    Andy

  2. weems
    Member
    Posted 5 years ago #

    Hi Andy,
    I am having the same sort of problem but there is nobody that can help us. Nobody has posted a reply yet. I have also posted this in a MySql forum, just in case it was a problem with that but no joy yet. If you find a solution please let me know.

    Good Luck

    Weems

  3. weems
    Member
    Posted 5 years ago #

    Hi Andy, I just seen this from another forum but relates to this forum. Not sure it will work for you but you can try. Who knew it was an index problem ? I haven't tried it as way past my bedtime but will try tomorrow but have a look.

    Many people have reported permalinks not working after upgrading to 2.6. In all cases, these people have permalink structures that contain "index.php". This is a bug, detailed here: http://trac.wordpress.org/ticket/7306

    Temporary fixes:

    1. If you're using Linux/Apache on your webserver, you don't really need the index.php anyway. Try removing it. The index.php thing was only meant for IIS servers, which don't support mod_rewrite.

    2. If you need/want the index.php to be there, then on the Settings->Permalinks screen, add some values in for the category and tag bases. The words "category" and "tag" will do just fine. As long as they are not blank, this should work around the bug.

    3. (For advanced users only) If you want to patch the problem yourself, there is a fix available in trac ticket 7306.

    The upcoming release of WordPress 2.6.1 will correct this issue.

    Regards

    Weems

  4. sckoobs
    Member
    Posted 5 years ago #

    I weems, did you have any luck with this?

    I followed the trac ticket and made the changes to the three files found in the changeset #8365. This has improved the situation, in that I can actully browse to other pages than the default main page, but I still can't get access to wp-admin - it still comes up with an Error 404 - Not Found message.

    Cheers,
    Andy

Topic Closed

This topic has been closed to new replies.

About this Topic