WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp-admin blank page problem (no updates done lately!) (7 posts)

  1. mpesgt01
    Member
    Posted 5 months ago #

    I am running a website with WP cms
    everything was going well.
    Then I realise trying to login this week that the wp-admin can't be access. Blank page.

    - i havent change a thing recently (no news plugins, no new themes, no mods, no updates, etc.)

    - the site (to visitors) in running good (except the text sometimes dont appear in the top nav bar)

    - i have try clearing my cache ++

    - i see that wp-login.php is accessible, but I am afraid of login in... can it be a bug/worm/hacker ? Maybe i am freaking...

    Help.

  2. mpesgt01
    Member
    Posted 5 months ago #

    update : i have try to login with the wp-login.pgp page, but it is not working, it gives me the error of the browser not supporting Cookies, which is false since it does! Chrome and Firefox, none can login. Again : everything was fine before !!

    HELP anyone ?

  3. mpesgt01
    Member
    Posted 5 months ago #

    Update #2 : I have found out that renaming my Plugin folder doesnt do anything...
    But renaming my child theme (child of twentytwelve) does fix it, i can see the /wp-admin that way... but how to fix this ?
    And also, why is this happening exactly ?

  4. mpesgt01
    Member
    Posted 5 months ago #

    update : i found that in my child theme, it the function.php file causing the problem... weird. But why is the real question ?

  5. mpesgt01
    Member
    Posted 5 months ago #

    What I have try so far...

      Renaming the functions.php = wp-admin appears again

      modifying what is in the functions.php = nothing worked, until I have remove everything, even the comments, even the opening/closing PHP tags... then once completely empty file = wp-admin appears again (otherwise not)

      try having the default child functions.php found in the codex (https://codex.wordpress.org/Child_Themes) = nothing appears in the wp-admin

    If any help, here is my child theme functions.php code

    <?php 
    
    // read more text change.
    function new_excerpt_more( $more ) {
    	return ' <a href="'. get_permalink($post->ID) . '" class="lasuite">Voici la suite &rarr;</a>';
    }
    add_filter('excerpt_more', 'new_excerpt_more');
    
    // remove any comments, in jetpack caroussel.
    function tweakjp_rm_comments_att( $open, $post_id ) {
        $post = get_post( $post_id );
        if( $post->post_type == 'attachment' ) {
            return false;
        }
        return $open;
    }
    add_filter( 'comments_open', 'tweakjp_rm_comments_att', 10 , 2 );
    
    // Removes from admin menu.
    add_action( 'admin_menu', 'my_remove_admin_menus' );
    function my_remove_admin_menus() {
        remove_menu_page( 'edit-comments.php' );
    }
    // Removes from post and pages.
    add_action('init', 'remove_comment_support', 100);
    
    function remove_comment_support() {
        remove_post_type_support( 'post', 'comments' );
        remove_post_type_support( 'page', 'comments' );
    }
    // Removes from admin bar.
    function mytheme_admin_bar_render() {
        global $wp_admin_bar;
        $wp_admin_bar->remove_menu('comments');
    }
    add_action( 'wp_before_admin_bar_render', 'mytheme_admin_bar_render' );
    
    ?>
  6. Which theme are you making a child theme of and what did you put into the child theme's function.php file?

  7. mpesgt01
    Member
    Posted 5 months ago #

    Hi Jan. I am using Twenty Twelve 1.2 + child theme on WP 3.8 with Jetpack 2.7. My code are just above your answer above. :-)

    PROBLEM SOLVED !!
    Here is the solution that worked for me... still makes no sense but...

      Open your child theme functions.php
      Select and copy everything
      Paste it in a brand new blank empty Textedit/Notepad file
      Save somewhere as functions.php
      Upload to server in the child theme

    That's it !!
    What a non sense problem... it just happen like that, without anything from my side (no changes or updates). So many people seems to have this same issue on the web with no answers, hope this post helps the Admin blank page of death, lol ! (Still love WP!)

Reply

You must log in to post.

About this Topic