WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP address and Blog address (5 posts)

  1. Nurice
    Member
    Posted 8 years ago #

    For a blog like:
    example.com/directory that is set up through cpanel as a subdomain:
    directory.example.com (no redirect)
    can I safely change it in Options/general tab of WP admin as:
    WP address -> http://example.com/directory
    Blog address -> http://directory.example.com

    I wanted to see if this would resolve some problems but don't want to do something that would prevent me from getting back into dashboard.

    I have changed it back and forth to troubleshoot, but always just using one of the addresses at a time. Since both addresses point to the same directory I thought I'd better ask before using two different addresses at same time.

  2. If you setup the subdomain through cPanel, then use http://directory.example.com for both URLs. If your problems continue, please create a separate thread for each one, and we will do our best to help you.

  3. Nurice
    Member
    Posted 8 years ago #

    Ok, thanks.

    I posted a thread for them but combined them. Following your advice I will do them in separate thread, hope no one considers it impatience that I repost 2 hours later.

  4. tanster
    Member
    Posted 8 years ago #

    Hi Nurice,

    If one of the problems you're encountering is broken images, you probably need to update Hotlink Protection by adding http://example.com/directory and http://directory.example.com to the Enabled list. (From cPanel, click the Hotlink Protection icon.)

    I have a similar setup to you -- I have my main domain http://www.maindomain.com, and my WP blog as a subdomain at sub.maindomain.com, which is actually an addon domain http://www.domain2.com.

    In Hotlink Protection, I've added http://www.maindomain.com, sub.maindomain.com, http://www.maindomain.com/sub, and http://www.domain2.com to the Enabled list.

    On the WP General Options page, I use http://www.domain2.com for both the WordPress address and the Blog address and it works fine.

    Probably more information than you needed, but if you're encountering the broken images problem, it might save your sanity. :)

  5. Nurice
    Member
    Posted 8 years ago #

    thanks for the input. I don't have any images on my site at this time. I checked cpanel hotlinks and it looks like it automatically added my domains.

    I've broken down the problems into 2 separate threads as advised earlier by macmax so will flag this one as resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic