WordPress.org

Ready to get started?Download WordPress

Forums

WP Adding Linebreaks: Not using Pages as a way out (11 posts)

  1. thirdpotato
    Member
    Posted 1 year ago #

    WordPress automatically adds linebreaks after every link and shortcode tag. Some people say to use that plugin that gets rid of all automatic linebreaks which is not possible since my site posts fiction and I don't want to manually insert a linebreak each time. Another solution is to use a different pages template for pages with links, but the problem is, the links I'm using aren't on just one specific page. It'll be on a customized text-based menubar that is specific per chapter.

    I'm using Phil's Easel theme. Please help!!! This seems to be one of the most prevalent problems on wordpress with no good solution to date! How can I keep it from automatically adding linebreaks after links and shortcode!?

  2. thirdpotato
    Member
    Posted 1 year ago #

    Update/Further description out of desperation:
    My G-d I'm seriously at my wit's end with this bloody problem. For the love of all things, is there ANYthing that can be done? I spent 3 hours researching every possible way to fix this. WPautop seems to be the problem. getting rid of that all together is just not an option for me since my site is 90% fiction and I require the automatic breaks for the short-story posts. But For instance the front page has images surrounded by shortcode. The images w/in the shortcode will not center no matter how many times I fix it in the html editor and/or visual editor!! It also adds linebreaks after each shortcode-surrounded image!! It's not the plugin's fault, I've checked that. It does this to hyperlinks I code with a Text-Widget! It adds linebreaks after every texts urrounded by a <a href= etc.

    I've tried EVERYthing. I've tried multiple plugins to stop and to modify wpautop, but it has 0 affect on my front page! It affects my fiction-posts and takes out all the linebreaks I NEED but nothing fixes the linebreaks and noncentering of content surrounded by shortcode! So I ran across this site: http://wordpress.stackexchange.com/ques ... -buffering And I've seen other people reference this same solution. Added it to easel's fuctions.php and NOTHING happened!

    I've tried this one: http://www.wprecipes.com/disable-wordpr ... -shortcode to NO avail. It does NOTHING.

    I'm tearing my hair out over this problem. Why is there not a legitimate solution to this on God's green earth!??

  3. Aaron
    Member
    Posted 1 year ago #

    I have been through this so I know how you feel. To fix the shortcode problem what worked for me is to put them next to each other instead of on a new line.

    So instead of doing this

    [myshortcode]
    [anotherone]

    I did this

    [myshortcode][anotherone]

    and it didn't add a paragraph. Your theme might be different and you might need to do some CSS stuff to get it done though.

  4. thirdpotato
    Member
    Posted 1 year ago #

    Well see, I'm trying to get it to look liek:
    [myshortcode][anotherone]

    But it's automaticall stacking it vertically like:
    [myshortcode]
    [anotherone]

    And it's doing that not just for shortcode, but for hyperlink html tags as well! And it's adjusting left even though I code and tell it to adjust center!

  5. Daiv Mowbray
    Member
    Posted 1 year ago #

    Post a sample page and I can probably write a css solution.

  6. Daiv Mowbray
    Member
    Posted 1 year ago #

    I was curious, about the link being added as a new line.

    after every link and shortcode tag

    So I just tested this:

    [reflect][image][/reflect]
    <div class="scrollbar" id="scroll"><a href="#scroll1">your link1</a><a href="#scroll2">your link2</a><a href="#scroll3">your link3</a></div>

    Which does not add a break to any of the links, nor are the shortcodes effected in any way.
    It's possible that you have a plugin issue.
    Have you disconnected all plugins, test re-activate each needed plugin one at a time.

  7. thirdpotato
    Member
    Posted 1 year ago #

    Howdy, Not sure if this will do it, but I've saved the webpage from firefox and uploaded it to dropbox:
    https://dl.dropbox.com/u/34224920/Pics%20Temp/To%20Bylo%20Tak%20%C2%BB%20The%20RP%20collections%20of%20Fyuvix%20and%20Haley.htm
    https://dl.dropbox.com/u/34224920/Pics%20Temp/To%20Bylo%20Tak%20%C2%BB%20The%20RP%20collections%20of%20Fyuvix%20and%20Haley_files.zip

    I've tested by disabling certain plugins. When I disable the plugin that allows me to do the fancy roll-over images, it fixes the centering and linebreak issue on the front page, but it doesn't fix the widget's hyperlink tags doing the linebreak problem.

  8. Daiv Mowbray
    Member
    Posted 1 year ago #

    I've tested by disabling certain plugins.

    read:

    Have you disconnected all plugins, test re-activate each needed plugin one at a time.

    Also read:

    Post a sample page

    I really can't help you without a sample page and knowing that you have done as suggested.

  9. thirdpotato
    Member
    Posted 1 year ago #

    Did you get the message above the one you just posted? It should have links from my dropbox to the files for a sample page.

    All plugins disabled and checked; Same results.

  10. Daiv Mowbray
    Member
    Posted 1 year ago #

    Yep,
    ok so what I don't know is what you are putting into your content.
    nor what you want it to look like.
    the images are wrapped in this:
    <div style="position:relative;"><a href="http://localhost/wordpress2/?latest=17">
    so, no sample due to local host.

    Personally I don't think the issue here is WP adding breaks, what you have is the images wrapped in divs, which are block objects, ie; not inline. If you want the image "New Beginnings" to the right of "Foxtrotting" you'll want to change the position:relative; to display:inline;
    except then your rollover image swap fails.
    float:left also causes a fail.

    How ever, I don't think your issues are actually with WordPress, so much as design and layout issues related to your content and the plugin you are using for rollovers.

    HTH

  11. thirdpotato
    Member
    Posted 1 year ago #

    Howdy thanks for the info; The link there that didn't work just goes to the latest post in that category, so is inconsequential.

    That is exactly the problem though; If I change that, the rollover doesn't work.

    Hopefully someone can find a resolution to this.

Topic Closed

This topic has been closed to new replies.

About this Topic