WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP 404 page in IE but not FF in nested/child pages (4 posts)

  1. OldeCrow
    Member
    Posted 6 years ago #

    OK again I apologize in advance if this has been answered 100 times over but I didn't find a solution that I understood or that worked in the search results so I'm back begging for help again.

    I have a very public domain with two installs of WP. One for the server root (installed in a subdirectory /wp) and another in a subdirectory /Oregon.

    I'm useing "Date and name based" permalinks for both installations.

    my htaccess files are as follows.

    server root:

    Options +ExecCGI +FollowSymLinks -Indexes -MultiViews
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Install in the /Oregon folder:

    Options +ExecCGI +FollowSymLinks -Indexes -MultiViews
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /Oregon/
    RewriteRule ^calendar/([^/\.]+)/([^/\.]+)/?$ wp-calendar.php?year=$1&month=$2 [QSA,L]
    RewriteRule ^calendar/?$ wp-calendar.php [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /Oregon/index.php [L]
    </IfModule>

    # END WordPress

    I have nested/child pages in /foundation which loads fine in FF and IE but there are five pages in /foundation that are marked hidden so they don't show up in the page list but you can click to them from the /foundation page

    /foundation
    --page one
    --page two
    --etc...
    none of the pages inside of /foundation will load in IE but load fine in FF. I get the blog 404 page in IE.
    all the other links I have checked in IE work fine.

    Maybe I've provided too much information, this seems to boil down to a WP 404 page in IE but not FF for nested/child pages.

    I really could use some suggestions here!!!

  2. OldeCrow
    Member
    Posted 6 years ago #

    Update:

    It seems that it is the page status as private that breaks it in IE. Also of note the pages don't display on a mac in FF or Safari.

  3. OldeCrow
    Member
    Posted 6 years ago #

    OK I am officially an IDIOT, so whats everyone else's excuse for not telling me I was an IDIOT!!!!

    Private pages are only disable when you are logged in, I'm guessing on a per user basis?... since I wasn't logged in in Explorer or on the mac I get a 404 error!

    This complicates the way I wanted to setup that site but I will figure something out.

    Thanks me for figuring it out on my own!

  4. OldeCrow
    Member
    Posted 6 years ago #

    I was useing the private page status to hide child pages from displaying on the site where wp_list_pages was being used.
    All I needed to do was find the depth=1& command to add to it so the child pages don't display.

    Trial by fire :)

    <?php wp_list_pages('depth=1&title_li=<h2>' . __('Pages') . '</h2>'); ?>

Topic Closed

This topic has been closed to new replies.

About this Topic