WordPress.org

Ready to get started?Download WordPress

Forums

WP 404 on permalinks (52 posts)

  1. rtatum
    Member
    Posted 8 years ago #

    I'm having similar problems. Some of my posts permalinks work fine. Others return a 404. Even editing the file, returning it to draft, and republishing it don't help.

    I went into the options and had WP update the permalink structure. No joy.

    I'm using the following permalink setup:

    /index.php/%year%/%monthnum%/%day%/%postname%/

    I went to my archives page and tried a few posts. Archives here:

    http://tatumweb.com/blog/index.php/archives/

    I do not have an /archives/ folder. This is a WP page.

    These permalinks, among others, do not work:

    http://tatumweb.com/blog/index.php/2005/12/09/blog-flux-complete/

    http://tatumweb.com/blog/index.php/2005/12/07/blog-flux-coming/

    http://tatumweb.com/blog/index.php/2005/11/15/blogrodents-car-crash/

    http://tatumweb.com/blog/index.php/2005/08/22/blog-tech-and-blog-updates/

    Any ideas?

    Rich.

  2. tsguitar
    Member
    Posted 8 years ago #

    This is all very strange.

    If my main index page is called anything other than "index.php" (I changed it to "index3.php" for testing), then that page gets a 404, but all the links work just fine, even though I've set WP to look for "index3.php" as the main page ("Options >> General >> Blog Address").

    My Blog Address is set to "index3.php." Check it out:
    http://www.nextvista.org/index.php/
    http://www.nextvista.org/index3.php/

    Though I've told WP to look for "index3.php," "index3.php" returns 404 while "index.php" works just fine.

    And it's just the home page ("index3.php") page that doesn't display properly. From that "index3.php" page (the one that returns 404), if you click on the December archives, this is what you get:
    http://www.nextvista.org/index3.php/2005/12/

    Notice the permalink structure; that's what I want. I don't see why the name of the index page would have anything to do with whether or not the permalinks work.

    If I change the permalink structure back to "default" via the dashboard, everything is fine and operational (but the permalinks are not very user friendly).

    Side Note
    In case it's important, no matter how I alter the permalink settings in the dashboard, here are the .htaccess rules I am told to create:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /index3.php/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index3.php/index.php
    </IfModule>

    No matter the permalink structure, those are the rules. Shouldn't those rules change if I change the structure? Maybe that's a different issue, but I thought I'd throw it out there in case WP is telling me the wrong rules to put into .htaccess. If this is unrelated, ignore it and I'll ask it later.

  3. moshu
    Member
    Posted 8 years ago #

    The two URIs in the Options cannot end with a filename, only a directory.

  4. tsguitar
    Member
    Posted 8 years ago #

    rtatum:

    Any chance that those particular posts have a different "Post slug" than the actual title of the entry? "Manage >> Posts" and choose to "Edit" one of them. On the edit screen, the 3rd thing down on the right side of the page should be "Post slug." Double check to make sure that's what it should be and that it's what's showing up in the links to each of the entries.

    I see those entries in your monthly and daily archive pages, so I think that there's just a disconnect with the titles. Let us know what you find out.

  5. tsguitar
    Member
    Posted 8 years ago #

    Moshu (thanks for the quick reply!):

    I've never run into this problem before. I didn't know that, so thanks.

    Ok, so how could I change the name of the main index page to something else if I wanted to? What if I want "index.php" to be some kind of welcome page and I want my WP blog to begin on "blog.php" instead?

  6. worldmaster0
    Member
    Posted 8 years ago #

    I don't think that is possible.

    By the way what is a permalink?

  7. rtatum
    Member
    Posted 8 years ago #

    Yes. Sometimes my titles are quite long, so I shorten the slug. This worked previously, and I assumed that's why the option is there to modify the slug.

    It does work on most articles, still. For example:

    Title: A teen, a plan, an essay: Hassan’s Chistmas in Baghdad.

    URL: http://tatumweb.com/blog/index.php/2005/12/30/hassans-xmas-in-baghdad/

    Rich.

  8. tsguitar
    Member
    Posted 8 years ago #

    worldmastero:
    Not possible. seems odd, but ok. And a permalink is a permanent ("perma") link to the article.

    rtatum:
    There's no problem with shortening the title via the post slug; that's what the post slug is there for. But I think that's creating the problem you're having. On "Blog Flux," for example, did you modify the post slug and it just didn't take effect in the link? Know what I mean? When you go to the dashboard and manage your posts, what happens when you click on the "view" link for any of the articles you're having trouble with?

  9. BillyG
    Member
    Posted 8 years ago #

    been trollin, same prob my end, sent dump to Ryan just now (before I realized there was a 2nd pg but no matter), I'm glad you cleared up that slug thing cause I've been editing them too (cause I figured that's what it was there for also), but then you mentioned the dashboard and I remembered that mine is white now. I didn't really get into it before anyway so I don't know what I'm missing but, other than the serp 404's (God, imagine the big blog's!), my internal links are working fine. I guess I won't be posting anymore 'til I hopefully hear back from Ryan. G/L.

  10. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    There are two permalink bugs that I know of in 2.0. If your blog is installed in a subdirectory (let's say "wordpress") and you have a permalink that has the string "wordpress" in it, WP will 404 for that permalink. Another is if your category base or permalink base is the same as a page name. If you have an "archives" page and have permalinks ancored off of "archives" you might get 404s. Fixes for both of these are available in this build (tar.gz format only right now). That build contains a handful of bugfixes to 2.0.

    If the server is generating 404s rather than WP itself, something else is going on. The Dump Env plugin is useless if the server is 404ing since WP is never loaded and the plugin is never run.

  11. BillyG
    Member
    Posted 8 years ago #

    Mine is in a WP sub-dir, yes that is in the date & name based permalink option, but if I attempt to go to the custom structure (like I used to use before 2.0), it reverts back when I submit the change, is that something my end only?

    So I guess you're saying to load your included WP build, is that right?

    EDIT: oh yeah, logoff/on gave me my dashboard screen back

  12. BillyG
    Member
    Posted 8 years ago #

    I uploaded the blog-header file and am editing the source-editor file now but how do I insert those starting null bytes?

    Also, am I supposed to do anything with the #, |, and rgb files that are in the .tar? Thx.

  13. rtatum
    Member
    Posted 8 years ago #

    TSGuitar,

    Regarding my permalinks, you asked:

    "On 'Blog Flux,' for example, did you modify the post slug and it just didn't take effect in the link? Know what I mean?"

    On that particular post, I don't think I modified the slug, at all. The title was "Blog Flux Complete!" and the slug naturally became blog-flux-complete. I didn't modify it. And prior to the upgrade to 2.0, it was working. The 404s came after the upgrade.

    You also asked:

    "When you go to the dashboard and manage your posts, what happens when you click on the 'view' link for any of the articles you're having trouble with?"

    When I'm editing the article, the preview displays the 404 page. After editing it, when I click on "view" from the management page, I get the 404 page. I tried editing the post slug so that it was <i>different</i> from before and no longer matched the title, and it was still broken.

    In short, the "Blog Flux Complete!" link slug was unmodified, and it is broken. After modifying it to something else, it remains broken.

    Rich.

    http://tatumweb.com/blog/index.php/2005/12/09/blog-flux-complete/

  14. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    rtatum, I can debug this with a little help. Download, install, and activate the Dump Env plugin. Visit the page that is giving a 404. Save the page source for that page. Forward the page source to ryan at boren dot nu. Deactivate the plugin when finished.

  15. mikae1
    Member
    Posted 8 years ago #

    I'm also having bigtime trouble with permalinks and WP2. See here: http://wordpress.org/support/topic/54340

  16. mikae1
    Member
    Posted 8 years ago #

    Ryan Boren solved the problem. Again, check out http://wordpress.org/support/topic/54340 for the solution. It might help you.

    Good luck.

  17. thelasian
    Member
    Posted 8 years ago #

    I QUIT
    I just wanted to let you WP developers to know that after reading everything about the permalinks issue and trying everything, I decided to go with MT.

    I'm not a programmer - I shouldn't have to be doing this. If you can't be bothered to fix this issue, then you have no busines offering this product. I wasted 4 hours trying to find the (useless) info on your convoluted and ill-conceived site, and had to read through your self-contradictory and poorly-written instructions (you MUST have FTP to make a .htaccess....or not) too. Not that MT is a heck of a lot better in that respect, but at least it works. Sheesh.

  18. Michael Bishop

    Posted 8 years ago #

    generic insults and lack of explanation of your problem does you and others in the community little good. Especially tacking it onto a thread that hasn't been touched in 4 months. Good luck with MT.

  19. Seadream
    Member
    Posted 8 years ago #

    I think I know why or how I am having this trouble, the only issue I've got at this moment with
    Word Press, but I don't know how to fix it. What happens is that when I post in any
    category, and I click on the link to that category to see the posts in that category, I get a 404
    error and a page cannot be found message from IE. I understand that the .htaccess has to
    be writeable and it is, to the user, and to the group. But that didn't fix it, so I went in and
    allowed it to be executed by the user of the account. The following ismy whole permalink
    option setup and the instructions in WordPress to fix .htaccess. But my permissions say it
    is writeable, so I am at a complete loss to know what to do next. I am unwilling to alter the
    file as WordPress seemingly wants me too. This has to be fixed though because once the
    blog gets past the number of posts that I allow to be shown on the front page, I am afraid I'm
    going to lose them.

    Regards,
    SeaDream

  20. pufaxx
    Member
    Posted 8 years ago #

  21. krushinfo
    Member
    Posted 8 years ago #

    Same problem here :(

  22. slsdoug
    Member
    Posted 8 years ago #

    I've had 2 blogs give me 404 errors. One of them,
    http://blog.mysecurepc.com/
    I deleted the htaccess in the blog's root dir then recreated permalinks by clicking on update permalinks in admin panel.
    The other blog still has the 404 problem (same versions 2.0.3). Deleting/creating htaccess did not fix it.

    Doug

Topic Closed

This topic has been closed to new replies.

About this Topic