WordPress.org

Ready to get started?Download WordPress

Forums

WP 404 on permalinks (52 posts)

  1. kensavage
    Member
    Posted 8 years ago #

    http://www.kensavage.com/index.php/archives/johnny-damon-agrees-to-sign-with-new-york-yankees/

    as you can see with this link you get the url and hit the page but it shows as a 404 within WP. The links haven't changed and my permalinks are stup as custom: /index.php/archives/%postname%/

    I don't have mod_rewrite and I've upgraded to WP2.0

  2. The permalink feature was slightly altered in WpPv2.0. As it is stated in the upgrade guides, you will need to re-generate your permalink structure.

  3. kensavage
    Member
    Posted 8 years ago #

    Yes I read that but how do I re-generate all my links?

  4. kensavage
    Member
    Posted 8 years ago #

    I ran the upgrade.php and not the install.php as the codex said to for wp2.0

    install.php said that my blog was already installed.

  5. moshu
    Member
    Posted 8 years ago #

    [[Upgrading_WordPress#Step_10:_Update_Permalinks_and_.htaccess]]
    Just go into Options >Permalinks and hit the Update button.

  6. kensavage
    Member
    Posted 8 years ago #

    Yes I've done this and I still get the same problem with the permalinks not working and giving me a 404.

    Although something I did find was if I switch to the default structure then all the links work ok. Switching back to my custom /index.php/archives/%postname%/ messes everything back up again.

  7. moshu
    Member
    Posted 8 years ago #

    Did it ever work with that permalinks structure?

  8. kensavage
    Member
    Posted 8 years ago #

    OK I found that using the word archives in my path for the permalink was the problem. I switched it to %category% and all my links have now changed but they are working.

    Any ideas why using archives won't work??

    I hope this doesn't mess with my search engine ranks.

  9. faxxy
    Member
    Posted 8 years ago #

    If you're on Apache earlier than 2.0, it sorta has something to do with this:
    http://isaacschlueter.com/plugins/i-made/lucky-13-rewrite/

  10. Kahil
    Member
    Posted 8 years ago #

    ok... i upgraded earlier tonight and the permalinks worked fine... now all of a sudden they are not...

    are you guys sure that this is a stable release of wordpress?

    anyone know how to fix this so that the 'date and namebase' option works again?

  11. Kahil
    Member
    Posted 8 years ago #

    ok...

    all of a sudden it started working again...

    i'm still confused with the new version...seems like its still a little too buggy to be considered a stable version...

    maybe someone could post instructions for people to revert back to 1.5? and then allow more time for 2.0 testing? Just an idea cause there seems to be a lot of people with problems using 2.0...

  12. kensav
    Member
    Posted 8 years ago #

    My problem is anything else besides archives works. Problem is that all my search engine links out there use archives in the link and the 1900+ click thrus a day from search engines They all go 404 right now.

  13. moshu
    Member
    Posted 8 years ago #

    Do you have a "physical" directory called "archives"?
    http://kensavage.com/archives/

  14. kensav
    Member
    Posted 8 years ago #

    No I don't and I haven't had it in the past.

  15. moshu
    Member
    Posted 8 years ago #

    If there wasn't - it should give you a 404 not found, not what you can see at the link I posted.

  16. kensav
    Member
    Posted 8 years ago #

    it's a permalink not a physical file/folder.

  17. citeewurkor
    Member
    Posted 8 years ago #

    kensav, that link you gave is an actual folder. Moshu is right. by the looks of it, the folder is empty. Maybe try to rename it temporarily and see what happens?

  18. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    To help us debug, download, install, and activate the Dump Env plugin. Visit a page that is giving a 404. Save the page source for that page. Forward the page source to ryan at boren dot nu. Deactivate the plugin when finished.

  19. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    As moshu and citeewurkor point out, if a file or directory exists that collides with part of the permalink, brokenness usually ensues.

  20. angsuman
    Member
    Posted 8 years ago #

    > I hope this doesn't mess with my search engine ranks.

    Unfortunately I think it will have some effect.

  21. kickass
    Member
    Posted 8 years ago #

    Um, Ryan? I've got a peculiar question. I installed your Dump_Env thingie and activated it, and the minute I did the permalinks worked fine, at least they do with the date and name based option, if not with a custom blend. Does it hurt anything to keep the plugin active?
    http://pcmike.com/2005/12/26/protopage-makes-for-a-fine-start-page/

  22. cre8d
    Member
    Posted 8 years ago #

    I just installed WordPress 2.0 for a new site. I did the following:

    touch .htaccess
    chmod a+rw .htaccess

    Then clicked on Options > Permalinks > and selected "Date and name based". I then get 404 errors on the home page.

    URL = http://ss75.shared.server-system.net/~admin204/

    (I have switched back to the ?p= permalinks in the meantime)

  23. dbasulto
    Member
    Posted 8 years ago #

    i'm getting the same problem with 2.0 final. moving back to default permalink structure fixes it... but cant change to other structure, even if .htaccess is writeable

  24. dbasulto
    Member
    Posted 8 years ago #


  25. Andreas Beer
    Member
    Posted 8 years ago #

    Seems to be a problem of 2.0. The new version only gives me endless trouble with permalinks. I think I revert to 1.5.2 with a brand new database made from the backup.

  26. Andreas Beer
    Member
    Posted 8 years ago #

    Found it ! Deactivated the plugin "german-permalinks" and everything is fine again.

  27. dbasulto
    Member
    Posted 8 years ago #

    uhm, i use a default install...
    i upgraded from 2.0RC2 to 2.0 final..without any extra plugins

  28. greatbananas
    Member
    Posted 8 years ago #

    I have a very similar problem. It does not work with custom: /%post_id%/%postname%/ . All the other options work fine. I upgraded it to 2.0 from 1.5.2.

  29. tsguitar
    Member
    Posted 8 years ago #

    If my permalink structure is anything other than "default," I get a 404 error on the home page, though the permalinks do work just fine.

    Working from a clean install (fresh database and installation of WP2.0), none of the permalink options seem to fix that problem. As soon as I delete the .htaccess (even a blank .htaccess is creating that 404 error) and change my permalink option back to default, the problem goes away, but of course I'm left with "/?p=3" or some such as the permalink structure. If I put an .htaccess in there, the permalinks work fine, but the home page gives me a 404. Make sense? Anyone else experiencing anything similar? Know how to fix it? Thanks for your time.

  30. moshu
    Member
    Posted 8 years ago #

    tsguitar,
    if this is about the blog linked to your name... everything seems to work fine.

Topic Closed

This topic has been closed to new replies.

About this Topic