WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] WP 3.5.1 Can't add featured image (18 posts)

  1. cjc1867
    Member
    Posted 1 year ago #

    Hi
    Since upgrading to WP 3.5 I have been having problems with the Media Library. If I click upload the page shows up but i'is blank and it won't close at all.

    Updated to WP 3.5.1 still the same. Trying to set a featured image and I can't upload or choose from the Media Library and most annoyingly can't close the window.

    What's happening and how can I fix it?

    Colin

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  3. cjc1867
    Member
    Posted 1 year ago #

    Hi WPyogi
    Thanks for posting, I have just read it and have disabled all the plugins and it is working as it should. I now need to reactivate each plugin to see which one is causing the problems.

    Again thanks for you comments.

    Colin

  4. Caroline
    Member
    Posted 1 year ago #

    Updated to 3.5.1.

    I was just going to edit a post and the "featured image" option was gone. Is it suppose to be there now? I thought maybe that WP removed it for 3.5.1?

  5. cjc1867
    Member
    Posted 1 year ago #

    Hi Caroline
    Is it unticked under Screen Options at the top of the page?

    Colin

  6. Caroline
    Member
    Posted 1 year ago #

    Hi cjc1867,

    It's not even there! I don't use english version though, but I can ensure it is not there.

  7. hash.tag
    Member
    Posted 1 year ago #

    same here... i can't find featured images option in WP 3.5.1

    not even in Screen Options.

    any recommendations?

  8. Caroline
    Member
    Posted 1 year ago #

    @hash.tag
    I found out :)
    Added this to my functions php and then it came back! =D

    if ( function_exists( 'add_theme_support' ) ) {
    add_theme_support( 'post-thumbnails' );
    set_post_thumbnail_size( 150, 150, true ); // default Post Thumbnail dimensions (cropped)
    
    // additional image sizes
    // delete the next line if you do not need additional image sizes
    add_image_size( 'category-thumb', 300, 9999 ); //300 pixels wide (and unlimited height)
    }
  9. hash.tag
    Member
    Posted 1 year ago #

    @Caroline

    thanks for you response. actually the "featured image" option in dashboard is missing since i upgraded the wordpress to 3.5.1

    the lines of code you mentioned are already in "functions.php" file. and the site is still showing older featured images. but i can't add new post with featured image as this option isn't available :(

  10. Cuts4th
    Member
    Posted 1 year ago #

    Yeah same problem with 3.5.1 here, are they moving away from the featured image function? I hope not because a lot of my favorite plugins make use of it. I'll check my functions.php but I don't think that's the issue here.

  11. Cuts4th
    Member
    Posted 1 year ago #

    Never mind, @Caroline is right once I added that code to the functions.php of my theme and the option reappeared. Thanks Caroline!

  12. Caroline
    Member
    Posted 1 year ago #

    @Cuts4th I'm glad to help =D

  13. hash.tag
    Member
    Posted 1 year ago #

    thanks @Caroline , thanks @Cuts4th it's started working ... i got confused with posts, pages and slider in functions.php

    thanks you guys

    kind regards

  14. alexwrld
    Member
    Posted 1 year ago #

    Hi Caroline,
    Could you please look into this issue which is a bit more weird:
    http://wordpress.org/support/topic/media-library-has-stopped-working-after-upgrading-to-wp-351

  15. primetime103
    Member
    Posted 1 year ago #

    @Caroline Where SPECIFICALLY in the php code did you add that specie of code to solve the Can't add Featured Image problem?

    I'm having the same issue.

    At the beginning, end? Your response would be greatly appreciated.

    I manage a few real estate sites and not being able to add featured images to the Listings is cause some major issues.

    Thank you.

    Kevin

  16. Caroline
    Member
    Posted 1 year ago #

    @primetime103

    This is strange because I can't find the code in my functions.php anymore. I checked my childtheme and parent — but it's GONE!

    I seriously don't know what happened here, because the featured image are working fine. If I found out, I'll post here again.

    So not sure where I added it, but don't think it matters?

  17. mloga94
    Member
    Posted 1 year ago #

    Caroline,
    i was missing the featured slider in WP 3.5 .1 and i decided to add the function php that i posted and now i cannot access to my admin site
    This is a syntax error:

    Parse error: syntax error, unexpected T_STRING in /home/mloga94/public_html/wp-content/themes/simple-catch/functions.php on line 135

    my site is http://www.logdeluxe.com

  18. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @mloga94 - this thread is long over and already marked resolved - please start your own thread per

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

Topic Closed

This topic has been closed to new replies.

About this Topic