WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP 3.5 Killed Dropdowns (9 posts)

  1. efpeterson
    Member
    Posted 1 year ago #

    Hi folks,

    After upgrading to 3.5 this morning, my client's dropdown menus have stopped working. I disabled all plugins and couldn't find a conflict so I'm wondering if it's a JQuery issue, but I don't know much about JQuery.

    The site is here: http://tinyurl.com/agmewto

    I also submitted a ticket to the theme creator, but they have disappeared. Others have been asking the same question for weeks without an answer so I'm wondering if anyone here had a similar problem with 3.5 and fixed it?

  2. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  3. efpeterson
    Member
    Posted 1 year ago #

    Worked through it and still no change unfortunately.

  4. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    You disabled all plugin and switched to the default theme?

    Firebug shows javascript errors. Any problems with javascripts will mess up the backend.

  5. efpeterson
    Member
    Posted 1 year ago #

    I switched it to the default theme and found that this is a specific theme issue, so I'm assuming that it's a JQuery issue. I'm using a Mac with Firebug Lite and when I check the JQuery I get this: Access to restricted URI denied.

  6. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Access to restricted URI denied.

    You get that when you are trying to load something that the browser thinks is not yours (I think). Sometimes it is just confusion on the script with http://www.site.com and site.com - it sees that as two different websites.

    I also submitted a ticket to the theme creator, but they have disappeared.

    They are a well known developer so you should hear from them. http://support.envato.com/

  7. efpeterson
    Member
    Posted 1 year ago #

    Thanks Kmessigner.

    I'll keep playing around with Firebug and see if I can find anything.

    I submitted that a few days ago and have heard nothing. I also contacted Envato support directly. Envato has been given those who are asking about this full refunds on the product because they can't get a hold of the author either.

  8. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    They are a go-between between developers and the public. Not a good place to be if the developer retires. Good luck!

  9. efpeterson
    Member
    Posted 1 year ago #

    I figured it out.

    In the functions.php file I had to change

    wp_register_script('jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js');
    to:
    wp_register_script('jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js');

    It was pulling an older version of the JQuery. I hope this helps someone else, even if it's different from the Cascadia theme.

Topic Closed

This topic has been closed to new replies.

About this Topic