WordPress.org

Ready to get started?Download WordPress

Forums

WP 3.5 causes blog to redirect to domain. (22 posts)

  1. cherylaspencer
    Member
    Posted 1 year ago #

    This is regardng install of latest version (3.5) of wordpress. After installing I can't however access the blog at mysite.com/blog. It redirects to mysite.com/ (This happened on all three blogs I host at this site).

    After much hair pulling, and research, I came across a few forum posts regarding similar issues with canonical redirects and older versions of WP. On a hunch, I changed the setting in the WP Admin Panel > Permalink Settings from "Month and Name" to "Default." This seems to have "fixed" the issue.

    But I am not happy about not being able to use this feature in order for my blog to function properly.

  2. cherylaspencer
    Member
    Posted 1 year ago #

    A follow-up is that changing the Permalink setting to "Default" makes the links to posts return a 404 error since the link to the page has now changed.

    I would like a response from someone at WP regarding this issue. I can't be the only person having this problem.

    There seems to be a related post titled "Permalinks not working (2 posts)"

  3. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  4. cherylaspencer
    Member
    Posted 1 year ago #

    Yes I did, and I didn't see anything in there relevant to my problem. I did try deactivating all plug-ins, and this didn't change anything. Still having the issues.

  5. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I didn't see anything in there relevant to my problem.

    Did you change themes?

    Did you use your browser to look for javascript efforts?
    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Did you try to change the permalinks back to your original settings? Sometimes changing/update and then going back corrects file problems.

    Can you post your site(s) url please?

  6. cherylaspencer
    Member
    Posted 1 year ago #

    I did not change themes. I did update the theme, because my old version was not compatible with WP 3.5. I am running Thesis 1.8.5. I first posted this issue on their help forum, and they weren't aware of it as a known issue.

    I did change the permalinks setting back to original (Day and Name), and that didn't fix it. I have left it set to the original setting as having the blog home redirect to my website is better than all blog post links returning a 404 error page.

    Site url is: 2spencers.com/veterans-disability-blog/

    Working through the JavaScript Errors page,
    I tried 2 other browsers, and am having the same issue.
    I enabled script_debug and these are the errors that displayed:

    Error: not well-formed
    Source File: file:///C:/Documents%20and%20Settings/Cheryl%20Spencer/Application%20Data/Mozilla/Firefox/Profiles/4t80udm5.default/mimeTypes.rdf
    Line: 5, Column: 102
    Source Code:
    <NC:possibleApplication RDF:resource="urn:handler:web:https://mail.google.com/mail/?extsrc=mailto&url=%s" />

    Error: Components.classes['@mozilla.org/extensions/manager;1'] is undefined
    Source File: chrome://jqs/content/overlay.js
    Line

  7. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I use Thesis 185 also with no problems. Used it thought 3.5 testing. I still think you might want to try the default. You can switch back and forth and check it in less of a minute. Although mine works there are so many ways to configure Thesis I think you should check.

    Also there are some validation error here. The DIV problems are the ones to try to fix. http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fwww.2spencers.com%2f

  8. cherylaspencer
    Member
    Posted 1 year ago #

    These errors look like they are all associated with the html portion of the website, not the WP blog. I've changed the permalinks back to default so you can see the actual WP blog homepage, rather being redirected than the html website. 2spencers.com/veterans-disability-blog/
    Like I said, when I tried the default setting for the permalinks, it resulted in all of the existing links returning error pages. Like this:

    http://2spencers.com/veterans-disability-blog/2012/06/18/lawyer-long-va-respond-appeal/

    Any other ideas?

  9. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    What does your .htaccess file have in it?

  10. cherylaspencer
    Member
    Posted 1 year ago #

    With the permalinks set to Day/Name, it looks like this:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /veterans-disability-blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /veterans-disability-blog/index.php [L]
    </IfModule>

    # END WordPress

    Otherwise, with them set to default, it looks like this:
    # BEGIN WordPress

    # END WordPress

  11. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    With day/name it should look like this

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  12. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  13. cherylaspencer
    Member
    Posted 1 year ago #

    Those look the same to me (except for the blog address).

    So, I'm guessing there isn't anything wrong with the .htaccess file.

  14. cherylaspencer
    Member
    Posted 1 year ago #

    Also, the http://2spencers.com/veterans-disability-blog/2012/06/18/lawyer-long-va-respond-appeal/ link is working because I've got permalinks set to "day/name." As soon as I change it to default, it returns an error.

  15. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Those look the same to me (except for the blog address).

    I don't know why the blog name is in there.

    Under settings/reading do you have your home page as the static page and veterans-disability-blog set as the blog page?

  16. cherylaspencer
    Member
    Posted 1 year ago #

    No. Both the WordPress Address (URL) and Site Address (URL)
    look like this: http://2spencers.com/veterans-disability-blog

    Should it be different?

  17. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Sorry, I mean under settings, reading.

  18. cherylaspencer
    Member
    Posted 1 year ago #

    No, I'm sorry. I didn't see that.

    Under settings/reading it is set like this:

    Front page displays Your Latest Posts. (Static page is not selected).

  19. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I think you want a static page. WordPress is built to resolve the differences between home and blog. You can't do it with a redirect.

    http://codex.wordpress.org/Creating_a_Static_Front_Page

  20. cherylaspencer
    Member
    Posted 1 year ago #

    Unfortunately, that didn't fix it. If I use a static homepage, and set the Permalinks to Day and Name I'm still getting redirected to the website home page.

    This seems to be a permalink setting issue.

  21. cherylaspencer
    Member
    Posted 1 year ago #

    I believe that I need some kind of a response from WordPress on this issue.

    I am by no means an expert level user. But I can't see any other reason that this is happening except there must be some kind of glitch with v. 3.5.

  22. RyanCoates89
    Member
    Posted 1 year ago #

    Hi has a solution been found for this issue, I am experiencing it too

Topic Closed

This topic has been closed to new replies.

About this Topic