WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
[resolved] WP 3.2.1. and backWPup 2.0.3 - broke AGAIN (18 posts)

  1. P3air
    Member
    Posted 2 years ago #

    it is frustrating - it was such a good, nice and nifty plugin until the whole UPGRADE frenzy started :(((

    plugin starts, creates a LOG file and a ZIP or TAR file in CGI-BIN folder, but doesn't move/copy it to the orignal destination folder

    LOG file is created, but obviously the execution time is exceeded? We don't have an error message in the log file. Log file states that everthing is fine ...

    We've changed the php.ini file several times to increase the EXEC time for scripts with no success. We've checked in SETTININGS the '3/5/30/300' settings - no success.

    Anyway. We've taken the plugin offline and look for alternate solutions. We hope that some of the code-buffs can figure this out - good luck

  2. Daniel Hüsken
    Member
    Plugin Author

    Posted 2 years ago #

    can u send me a log?

  3. P3air
    Member
    Posted 2 years ago #

    just send it to your email (mail@______.de) which we've found on your page.

    Thanks for the help

    Cheers

  4. Daniel Hüsken
    Member
    Plugin Author

    Posted 2 years ago #

    I have send the answere.

    I htink it was only the Backup to Folder setting.

  5. P3air
    Member
    Posted 2 years ago #

    Daniel, thanks for all the work!

    Ok, here's the clue:

    In former versions the folder for the backups was predetermined. Now you can choose your folder for every job individually.

    Obviously you MUST set the target-folder for every job in your job-settings. Otherwise the zip (tar, ...) file gets lost in the temp directory.

    Again, thanks to Daniel - it's up an running now! YEAH

  6. GOWPTG
    Member
    Posted 2 years ago #

    I am having this problem as well - with WordPress 3.2.1 and BackWPUP 2.0.3 when i setup a job, and hit 'run now', it just hangs forever. Here is a picture of what it looks like: http://screencast.com/t/xPnvH7CsnpL

  7. Daniel Hüsken
    Member
    Plugin Author

    Posted 2 years ago #

    can you tset the development version ?

  8. koroboru
    Member
    Posted 2 years ago #

    Now it says:
    Can not create temp folder: /var/lib/php5/.backwpup_796747168/
    Normally this folder is available only for root, others can't even read it's content.

  9. Daniel Hüsken
    Member
    Plugin Author

    Posted 2 years ago #

    but it is decleard as temp dir for the system.
    with version did you use? try dev sher i have made many changes.

  10. koroboru
    Member
    Posted 2 years ago #

    I use:
    Wordpress 3.2.1
    BackWPup 3.0.5
    @
    Ubuntu 10.04 with Apache 2.2.14 and php 5.3.1 (from repositories)

  11. koroboru
    Member
    Posted 2 years ago #

    Thanks a lot, now it works!

    I would like to say few other things, I think they doesn't require new forum thread.
    1. There are no backups in "backups" screen in situation when they are stored to FTP server and are not stored in local folder. Is this behavior expected?
    2. Can you add support for sending email using wp_mail() function? This can be useful because it makes possible customizations using tools like Configure SMTP plugin.
    3. There is a bit corrected description for option to use cron service of backwpup.com (original one contains few misprints):
    If you check this than the job schedule will submited to backwpup.com. Backwpup.com will call your blog wp-cron.php to execute jobs. Use this service only if your hoster doesn't provide a cron service or if your blog has few visitors. Please consider making a small donation for the plugin if you use this service. The service can be removed by me at any time without notification.
    4. May be I can help with Russian translations? Feel free to write me to koroboru [at] yandex [dot] ru. (replace at and dot with @ and .).

  12. Daniel Hüsken
    Member
    Plugin Author

    Posted 2 years ago #

    to 1. i will test it.
    to 2. No i can't, beacuse the backup working without wordpress in background. But i will look with var the plugins set and is it easy to read them. can you give my an example plugin ?
    to 3. thanks i have chend it.
    to 4. translations ever welcome. send it to mail [at] backwpup [dot] com

  13. Daniel Hüsken
    Member
    Plugin Author

    Posted 2 years ago #

    to 1. cant find a problem at moment.

  14. Ov3rfly
    Member
    Posted 2 years ago #

    I had the same problem as GOWPTG and after a few hours digging in code I think I found the reason.

    At some hosting companies, PHP can not access the own(!) host via the http:// filewrappers, even though allow_url_fopen is On and external hosts can be accessed.

    On such servers the plugin fails to internally continue to another page on the same server via a wp_remote_post() call with full http://yourserver.com/... url.

    Here a short php-testcase, note that display of php-warnings has to be switched on:
    [code]echo file_get_contents('http://'.$_SERVER['SERVER_NAME'].'/');[/code]
    If you see a warning like this, you can't use the plugin for now:
    Warning: file_get_contents(http://www.yourserver.com/) [function.file-get-contents]: failed to open stream: Connection refused in /var/www/yourserver/testcase.php on line 1

  15. Daniel Hüsken
    Member
    Plugin Author

    Posted 2 years ago #

    ahhh, nice to now can on that hosts connect with localhost ?

  16. Ov3rfly
    Member
    Posted 2 years ago #

    No. The result for 'localhost' is:
    Warning: file_get_contents(http://localhost/) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /var/www/qrcweb/htdocs/testcase.php on line 1

    Actually 'localhost' can't work, as with shared hosting the hostname is relevant to find the correct account.

    Seems to be a general configuration issue with firewalls/internal routing/whatever with some hosting companies, e.g. my company uses load balancers for the shared hosting.

    Maybe you can add an option in the plugin to use the "old way" without extra trigger (if I understand the changelog right), or did that cause too many problems? I only started to use your plugin 2 days ago...

  17. Daniel Hüsken
    Member
    Plugin Author

    Posted 2 years ago #

    th old way was a curl call. I have implemented wp_remote_post(), because it supports curl and the other way.

  18. Ov3rfly
    Member
    Posted 2 years ago #

    For the hangs at 0% problem, here is an enhanced testcase to test access to the own host also without php-warnings enabled:

    $rc = file_get_contents('http://'.$_SERVER['SERVER_NAME'].'/');
    echo ($rc !== FALSE) ? $rc : 'No data from own host '.$_SERVER['SERVER_NAME'];

    A big thanks to the author Daniel who, after getting the details via his own support-forum, worked day and night to get the problem fixed, latest dev-version has a work around for this already.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags