WordPress.org

Ready to get started?Download WordPress

Forums

WP 3.2 fresh linux install permalinks not working (9 posts)

  1. titush
    Member
    Posted 3 years ago #

    Hi, I have an issue that I have seen posted various times over the last few days already but I haven't found a solution yet.

    WP 3.2 fresh install
    PHP Version 5.2.6
    Linux 2.6.26-2-xen-amd64
    CGI/FastCGI
    This server is protected with the Suhosin Patch 0.9.6.2
    Apache2 mod_fcgid/2.3.6 mod_perl/2.0.4 Perl/v5.10.0

    PROBLEM: when I set the permalinks to anything but standard, I get a "forbidden" page (as soon as I delete the content of the .htaccess, everything is obviously fine again).

    I set permalinks to:

    Month and name http://XXXXX.com/2011/07/sample-post/

    I get:

    Forbidden
    You don't have permission to access /wp-admin/options-permalink.php on this server.

    My .htaccess contains:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Any idea what it could be? Mod_Rewrite usually works on all my other sites....

  2. dgilmour
    Member
    Posted 3 years ago #

    First thing to check is the permissions on /wp-admin/options-permalink.php. Is it readable by the web server?

  3. titush
    Member
    Posted 3 years ago #

    I checked the permissions of the file. It was 644 as are all files. Is that a problem? I would hate to have to 755 everything.. It's strange, I've set up multisites wit 3.1.x before and never ran into these problems...

    Any other idea?

  4. That sounds like a mom_rewrite problem actually.

  5. titush
    Member
    Posted 3 years ago #

    I guess you're right, I've written my host, it's really strange... Is there a way to check whether mod_rewrite is working, e.g. phpinfo or something?

    Titus

  6. I believe so, but I'm pre coffee.

  7. aioannidis
    Member
    Posted 3 years ago #

    Have the same problem on demo intallation of wp 3.2 on linux. Any ideas why mod_rewrite not working?

  8. titush
    Member
    Posted 3 years ago #

    I resolved it with my ISP. It was NOT related to WordPress, simply the fact that the ISP had deactivate mod_rewrite.... (no comment)...

    aioannidis: are you sure mod_rewrite is working? You might want to test is, for example with the script described here:

    http://www.wallpaperama.com/forums/how-to-test-check-if-mod-rewrite-is-enabled-t40.html

    Titus

  9. Usually it's in the httpd.conf file (set AllowOverride to ALL).

    Okay, in PHPinfo, look for the "apache2handler" section. mod_rewrite should be listed.

Topic Closed

This topic has been closed to new replies.

About this Topic