WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP 3.0 Permalinks are Broken (18 posts)

  1. Jack Reichert
    Member
    Posted 4 years ago #

    I'm playing with RC1 (the latest bleeding nightly) and every time I update a page (not posts, just pages) I have to go to the default permalink structure and then go back to the one i'm using (Day and name) or I get a 404 page not found for all my pages.

    Has anyone else been experiencing this?

  2. Jack Reichert
    Member
    Posted 4 years ago #

    I'm pretty sure that it has to do with custom post types. I've set up a custom type 'Newsletters'

    register_post_type('newsletters', array( 'label' => 'Newsletters','public' => true,'show_ui' => true,'capability_type' => 'post','hierarchical' => false,'can_export' => true,'rewrite' => array('slug' => 'newsletter'),'query_var' => true,'supports' => array('title','editor','excerpt','trackbacks','custom-fields','comments','revisions','thumbnail','author','page-attributes',)) );

    The permalinks to these posts don't work at all.

  3. Jack Reichert
    Member
    Posted 4 years ago #

    I had a page the same name. I think that there's a conflict with the slug, only after I changed them it still is coming up with 404...

  4. Jack Reichert
    Member
    Posted 4 years ago #

    The problem seems to be with the permalink structure. I was using "Day and Name"

    /%year%/%monthnum%/%day%/%postname%/

    it doesn't look like custom post types are working withh pretty permalinks...

  5. atracksler
    Member
    Posted 4 years ago #

    did you figure anything out on this? I have the same issue....

  6. learnthat
    Member
    Posted 4 years ago #

    I am having the same issue. With pretty permalinks, I cannot get to any custom posts. When I turn off pretty permalinks, the custom post is there with the non-pretty url. Any resolution?

  7. rafaelxy
    Member
    Posted 4 years ago #

    bump,

    same issue here

  8. nlauretano
    Member
    Posted 4 years ago #

    Same thing here. Deactivated all plugins, smae issue. Clean install, same problem.

  9. bsuneja
    Member
    Posted 4 years ago #

    I have the same issue, even with normal posts.
    http://wordpress.org/support/topic/410466?replies=1

  10. granulr
    Member
    Posted 4 years ago #

    Just go to the permalinks page in settings... No need to update, but going to the clears permalinks cache

  11. Dismankler
    Member
    Posted 3 years ago #

    i am also having a similar problem , as soon as i try to choose
    the Day and name option in permalinks, my site logs mi out and i get
    this error on all pages until i delete my .htaccess file and change it back to default

    Error :


    Server error!

    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

    If you think this is a server error, please contact the webmaster.
    Error 500

    I am using wp3.0.1 , so i dont know if its a bug or i am doing it wrong ? Please help

  12. phd38
    Member
    Posted 3 years ago #

    Same for me. I had to revert the permalinks to the default ugly format (?p=xxx), otherwise even the pages are not listed properly in the "page" widget. Instead, the root address is returned.

    I spent alreaady some time digging into the code ; this is really annoying.

  13. jeffocy
    Member
    Posted 3 years ago #

    I put " /index.php/ " in front and it seems to be kinda working. Here's what mine looks like /index.php/%category%/%postname%/.

    oops, looks like index.php is showing up in the url now

  14. Holidayrentalcentre
    Member
    Posted 3 years ago #

    I have the same problem and cn only use the default url structure. Has anyone found a solution? I get 404 error message on all other url options.

  15. edwardbeckett
    Member
    Posted 3 years ago #

    I'm having the same problem too ...

    Running Windows XP SP III ~ Apache 2.2 ~MySQL 5.1 ~ PHP 5.3.3

    I can reach all my posts-pages when using the default permalink setting. However, none of the other settings work. Any setting other than default displays a 404 page and my Apache log states

    ********************

    [error] [client 127.0.0.1] File does not exist:C:/vir_dir/dev/(foo)

    ********************

    I've noted that Apache is stating that a 'file' doesn't exist ... maybe a problem with handling '/index.php' in subdirectories. I dunno ;-/

    I'm just running the site locally under a hosts file mapped name (dev.XXX.com) and my site's named 'dev' ... under a virtual directory (c:\vir_dir\) so appropriately in my httpd-vhosts.conf file I have a directive for the virtual directory as well ...

    ****************************
    <VirtualHost *:80>
    ServerName localhost
    DocumentRoot "C:/vir_dir/"
    </VirtualHost>
    ****************************

    No problem there --- the site installed and runs fine ... all but the permalinks ... I'm not .htaccess wiz ... but I've done an install like this many times without any hitches ... anyone found a solution to this? Please help ... it's really annoying having to use the default permalink settings ...

  16. edwardbeckett
    Member
    Posted 3 years ago #

    Dohh !!!!

    Problem solved ...

    I forgot to uncomment #LoadModule rewrite_module modules/mod_rewrite.so
    in my httpd.conf file ... Argh

  17. jolim
    Member
    Posted 3 years ago #

    Thanks. I got it to work with the rewrite module.

    Don't forget FollowSymLinks and FileInfo in your httpd/apache2 configuration files. See the section under Using "Pretty" Permalinks on this page:

    http://codex.wordpress.org/Using_Permalinks

  18. swinhoe
    Member
    Posted 3 years ago #

    Just to add to the list for future reference.

    I was having the same issue, on a local dev environment setup using WAMPServer.

    By default the Rewrite Module is turned off.

    Be sure to check.. :)

Topic Closed

This topic has been closed to new replies.

About this Topic