WordPress.org

Ready to get started?Download WordPress

Forums

WP 3.0 Catchable fatal error (10 posts)

  1. ctecamp
    Member
    Posted 4 years ago #

    After upgrading to 3.0
    When logging into admin and at top of my site I get
    Catchable fatal error: Object of class stdClass could not be converted to string in /var/www/vhosts/wnsp.com/httpdocs/wordpress/wp-content/plugins/role-scoper/admin/admin_rs.php on line 118
    I also get this message at the top of admin page.
    Warning: Illegal offset type in isset or empty in /var/www/vhosts/wnsp.com/httpdocs/wordpress/wp-content/plugins/role-scoper/lib/agapetry_config_items.php on line 98

    I'm stuck dead in the water, cannot add or edit.

  2. katebutler
    Member
    Posted 4 years ago #

    I'm now getting a similar error:

    Catchable fatal error: Object of class WP Erro could not be converted to string in /home1/thisismo/public_html/deborahbutler/wp-content/themes/wpfolio/functions.php on line 539

    No idea what to do about it. I can't even log in now either as my password is not recognised even though I'm positive it's correct. Have requested a re-set but that seems to be taking forever to come through.

    I really hate to moan but I was so proud of my first ever WP site.

    Hope someone can help.
    Thank you!
    Kate

  3. esmi
    Forum Moderator
    Posted 4 years ago #

    @ctecamp: Deactivate the role-scoper plugin.

    @katebutler: Switch to the default theme by renaming your current theme's folder using FTP (or use whatever file management application your host provides)

  4. katebutler
    Member
    Posted 4 years ago #

    Thank you!

  5. katebutler
    Member
    Posted 4 years ago #

    Me again!

    I've done as @esmi kindly advises and things are looking better. Not quite there yet though.

    The site's url just gives a blank screen now: http://deborahbutler.net or http://deborahbutler.co.uk

    And my login is not recognised. I have requested a password reset but have not had one sent through yet.

    Any ideas what I should do next, when I eventually can get into wp-admin?

    I'm a bit worried that I've set the re-direct up wrongly in WP settings.
    .net is the original site with co.uk directed to it.

    Thanks again, everyone!
    Kate

  6. Azizur Rahman
    Member
    Posted 4 years ago #

    @katebutler: try Rename plugin dir.

  7. katebutler
    Member
    Posted 4 years ago #

    Thanks @azizur, will give that a go too :)

  8. katebutler
    Member
    Posted 4 years ago #

    Thanks Azizur - I've replied to you on the mwug group too.

    OK, I've done as you suggest. I'm not sure though how long it takes making changes this way to take effect but nothing has changed so far.

    I'm thinking that maybe I have made a mistake in General Settings and if so, would I be able to rectify this either via my ftp manager or via my host?
    Basically, in the WordPress address [URL] field and in the Site address [URL] field I *think* I entered the URL of the site I'm redirecting to.
    Stupid, I know, to fiddle with things I don't properly understand but I thought I'd be able to go back in and change it if it didn't work.

    I'm still completely locked out of the site altogether, by the way.

    Thanks for your help so far. I'm going to re-post this over at mwug. Bad practice, I know but I think I'm going to need all the help I can get!

  9. Azizur Rahman
    Member
    Posted 4 years ago #

    @katebutler:
    If you have messed up the wordpress url or the site address url, you can fix this by putting the two lines below in your http://deborahbutler.net/index.php file.

    define('WP_HOME',    'http://deborahbutler.net');
    define('WP_SITEURL', 'http://deborahbutler.net');

    This will override whatever value is set in database.

    If this does not resolve the issue you can always turn on debugging mode from your wp-config.php file.

    Look for something like this (if this does not exist on your wp-config you can add it there for testing):

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);

    Change the line define('WP_DEBUG', false); to define('WP_DEBUG', true); to see what error messages you get, if any.

  10. katebutler
    Member
    Posted 4 years ago #

    Wow, thanks again Azizur. I shall report back and whatever happens I most definitely owe you!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags