WordPress.org

Ready to get started?Download WordPress

Forums

WP 2.8 image uploader problam (21 posts)

  1. seisyuku
    Member
    Posted 5 years ago #

    I just up wordpress 2.7.1 to 2.8, in 2.8 "firefox + old image uploader + google gears = crash" is fix, sound good.
    but I see a new problam.

    When 2.8 user upload image by flash uploader, wp will ask username and password again, Though I have already logged in.
    http://rapidpik.com/photos/original/94462-sxbxs.jpg

    and I keyin right user/pw, wp always Respond "Are you sure you want to do this?", and cant continue
    http://rapidpik.com/photos/original/94461-zagw1.jpg

    When use Browser uploader is all OK.

    Any idea?

  2. seisyuku
    Member
    Posted 5 years ago #

    and I disable and uninstall gears ,still same problem...

  3. wildkyo
    Member
    Posted 5 years ago #

    I have the same problem. If I use the normal upload it works, but I need the flash uploader!! Maybe is a problem from the flash version?

  4. blued888
    Member
    Posted 5 years ago #

    I have the same problem. Will be using the browser uploader for now. Hopefully this gets fixed real quick!

  5. bh_WP_fan
    Member
    Posted 5 years ago #

    Just leave gears disabled and use whatever uploader works for you. Gears is a problem in the newer version of FireFox. Hopefully they'll have it fixed soon, but who knows.

  6. mrgtb
    Member
    Posted 5 years ago #

    When 2.8 user upload image by flash uploader, wp will ask username and password again, Though I have already logged in.

    I'm having the same problem also now with FireFox and the Flash uploader (IE is working fine).

    I think I know what it is, I was using FF earler and was having no problems uploading images with the flash uploader. I notice this morning my FF updated itself automaticly, and then this problem started.

    So I'm sure this is an FF problem with the new FF update that I recieved later on this morning is when it started happening with flash uploads asking me to log-in.

  7. mrgtb
    Member
    Posted 5 years ago #

    I think I've spotted the problem, are you using the Ads Blocker program with FF called AdBlock Plus? I just disabled it and now flash uploading is working fine in FF.

    Something must have happened when it was still activated when the FF update came through. Now I've just re-activated AdBlock Plus and flash uploading is working fine in FF. If your using it, try disabling it, then re-enabling it again. Then try flash uploading.

  8. blued888
    Member
    Posted 5 years ago #

    I'm not using both AdBlock Plus and Google Gears. Only the Alexa Toolbar is currently active on my Firefox but I'm still encountering the said, asking for username and password prompt after uploading an image.

  9. beisbolct
    Member
    Posted 5 years ago #

    I am having the same problem as well. Gears is disabled but still having the problem. I don't use Ad-block so that's not it either.

  10. seisyuku
    Member
    Posted 5 years ago #

    I don't use AdBlock Plus too, but thank you for help.

    I'll try disable my all FF plugin, maybe will solve it.

  11. seisyuku
    Member
    Posted 5 years ago #

    hmmm...problem is fix, flash uploader is working now.

    1.I disable all my Fx plugin. (say "need restart Fx")
    2.and my Fx say "The Ver3.0.11 has been able to download" and auto update itself.
    3.Fx restart, Upgrade to 3.0.11
    4.enable all Fx plugin. (say "need restart Fx")
    5.Fx restart, problem solved.

    So this is an (old-Ver.)Fx problem or some Fx plugin Incompatible...? I don't know.

    Anyway Thank you, mrgtb

  12. BigAl-DPNG
    Member
    Posted 5 years ago #

    Glad to see I'm not the only one. Really a pain in the butt when you need to upload 12 - 18 pictures. I'm using Google Chrome with Gears disabled. Worked fine before the upgrade.

    http://wordpress.org/support/topic/278446?replies=15

  13. blued888
    Member
    Posted 5 years ago #

    For those having problems with the login prompt popping up, I might've found a working solution.

    I re-downloaded WP 2.7.1, re-uploaded the /wp-includes/js/swfupload folder

    Please do backup before trying this.

  14. SoItsComeToThis
    Member
    Posted 5 years ago #

    There are a few reports of AJAX functions not working correctly in WP 2.8. This could be the issue. Its affecting Tags, Categories, (possibly) uploads. it could also cause the visual editor to go crazy (I haven't tested that, though since I use the HTML editor).

  15. Scarpace
    Member
    Posted 5 years ago #

    TRY THIS...
    If you are using a custom directory to upload your photos in 2.8, there is only one way I found out how to make it work. With a fresh install, in the "Setting/Miscellaneous" under "Store uploads in this folder", I put "uploads" (instead of the default 'wp-content/uploads') and for "Full URL path to files" I put "http://www.mywebsite.com/uploads" then clicked the "Save Changes" button. Then by using a FTP client, I had to CHMOD the Permissions settings for the newly created "uploads" directory to "777" before attempting to upload an new images while adding or updating any posts.

  16. Scarpace
    Member
    Posted 5 years ago #

  17. jahbman
    Member
    Posted 5 years ago #

    Hi, I finally got my image uploader to work in WP 2.8.

    1) login to your admin
    2) navigate to Setting > Miscellaneous
    3) make sure Store uploads in this folder input only has 'wp-content/uploads'

    For some reason when I upgraded to 2.8 the input in this field was /home/myfolder/public_html/wp-content/uploads/. I removed the /home/myfolder/public_html/ and voila.

    Hope this works for everyone else still suffering.
    JAB

  18. imikedesigns
    Member
    Posted 4 years ago #

    @jahbman-- Thanks Man! That fixed my problem perfectly! Many thanks!

  19. onlinemethod
    Member
    Posted 4 years ago #

    This has only just occurred for me (I used it yesterday and it worked fine). Using Google Chrome. Ive tried all the suggestions, but nothing is working.

  20. onlinemethod
    Member
    Posted 4 years ago #

    Looks like its a problem with Google Chrome (I guess it may have upgraded without me knowing). IE8 works fine.

  21. Frank3d
    Member
    Posted 4 years ago #

    I had the same issue in FF, IE and Chrome (different messages) This post actually corrected the issue in all browsers for me!

    http://www.kimwoodbridge.com/wordpress-flash-uploader-fix-for-the-http-error/

Topic Closed

This topic has been closed to new replies.

About this Topic