WordPress.org

Ready to get started?Download WordPress

Forums

HELP! WP 2.8 Front End Japanese, Back End English (8 posts)

  1. rennreece
    Member
    Posted 5 years ago #

    Could someone please solve this once and for all?

    I used Fantastico to create my WordPress installation. Everything was fine. I want to make the front end Japanese and keep the back end English.

    I got the Japanese language files from here: http://ja.wordpress.org/releases/

    I tried using the "Different Localization in Front- and Backend" plugin from here: http://wordpress.org/extend/plugins/fe-be-localization/ I followed the instructions and it didn't work. (this might be because the plugin is dated)

    I then deleted the plugin and tried the information I found here:
    http://codex.wordpress.org/Installing_WordPress_in_Your_Language

    My wp-config.php file was edited to look like this:

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    * language support.
    */
    define ('WPLANG', 'pt_JA');

    I have four files in my /public_html/wp-content/languages folder
    They are:
    continents-cities-ja.mo
    continents-cities-ja.po
    ja.mo
    ja.po

    Could someone please help? I would think this is a simple issue to take care of. This is a major block for me right now. Thanks in advance.

  2. rennreece
    Member
    Posted 5 years ago #

    Also, to make matters worse, I tried to type a test post using Japanese, and the result came out using ????. I can see the text correctly in Japanese before I publish the post, but afterward WordPress turns it to garbage.

    I have set the Settings > Reading Settings > Encoding for pages and feeds to UTF-8. I would think this is the correct setting. HELP!

    Sample Japanese text:
    テスト1,2,3 テスト1,2,3 テスト1,2,3 テスト1,2,3 テスト1,2,3 テスト1,2,3

  3. rennreece
    Member
    Posted 5 years ago #

    Why does it show up correctly here, but not when I try and make a post? On my site, it shows up as:

    ???1,2,3 ???1,2,3 ???1,2,3 ???1,2,3 ???1,2,3 ???1,2,3

  4. rennreece
    Member
    Posted 5 years ago #

    Update. I know can type Japanese into my site, however, I'm still struggling to find an answer to the interface front/back end problems. To solve the problem about being able to display Japanese, I found the following information:

    I followed this advice: http://www.japanitup.com/wordpress-japanese-english/

    and changed all the Collation from latin1_swedish_ci to utf8_unicode_ci

    Here is the breakdown japanitup.com gave:

    If this doesn’t make sense to you then I’ll give you a step by step break down.

    1. Back up your database. Not sure how? Check out this wordpress database plugin called WP-DBManager.
    2. Log into your phpMyAdmin
    3. Choose your database on the left
    4. Under your database on the left, click on wp_comments
    5. On the right you’ll see Field, Type, Collation, Attributes, etc.
    6. For the Fields that have Collation set as something other than utf8_unicode_ci you should tick the check box.
    7. After you ticked all check boxes in that table, click the pencil icon at the bottom. When you mouse over it there should be a tool tip that says “change”. When you click this you can edit those fields.
    8. Using the drop down box on each field you can now change the Collation from whatever it is (example latin1_swedish_ci) to the bottom selection in the drop down box which is utf8_unicode_ci.
    9. Hit Save
    10. Now click on the next table on the left hand side which should be called wp_links.
    11. Repeat these steps for each table.

    I went on to go down the list, through all the tables and where ever it had latin1_swedish_ci, I changed it to utf8_unicode_ci.

    I'm still hoping someone can provide me with more information on my original question.

  5. rennreece
    Member
    Posted 5 years ago #

    I recently tried changing the date format in the Dashboard > Settings > General > Date format > Custom > Y年 n月 j日. Even though these settings were accepted in the dashboard, this format didn't appear in the front end. Does anyone know why not?

  6. rennreece
    Member
    Posted 5 years ago #

    I tried something else. Basically, I downloaded the Japanese version of WordPress from here: http://ja.wordpress.org/releases/

    Then I FTPed the files and overwrote the files on my server with the Japanese version of WordPress. My installation continue to work in English. I then edited the wp-config.php file in CPanel and changed the following language code:

    define ('WPLANG', 'ja');

    Above I had:
    define ('WPLANG', 'pt_JA'); but this looks to have been a mistake.

    With uploding the Japanese wordpress files, and changing the define "code" I'm able to use all Japanese, both the front end and backend using define ('WPLANG', 'ja'); and change back to English both in the front end and the back end using define ('WPLANG', 'en');

    This is not what I want, but is better than what I had. Basically now I'm looking for some code that just switches the back end to English. Is there any code I can drop into the wp-config.php. Or a plugin that just switches between two different define codes on the fly? Any PHP programmers out there?

  7. Hi,

    I'm not sure if I'm fully following what you've done, but if I was to achieve what you're trying to do I would:

    1. Install Japanese package from scratch
    2. Use Bogo Plugin

    I hope it helps.

  8. rennreece
    Member
    Posted 5 years ago #

    Nao,

    Thank you so much! It did what I needed. However, the only flaw I found was when I change my profile to English, the dates show up in English on the front end. However, when I use another browser that's not logged in, the dates show up correctly in Japanese. That is minor. I'll have to donate to the author for writing the plugin.

    Thanks for taking the time to help and answer my question.

    Another person suggested on another forum to use this plugin.

    http://wordpress.org/extend/plugins/admin-in-english/

    It also does what I wanted it to do.

Topic Closed

This topic has been closed to new replies.

About this Topic