WordPress.org

Ready to get started?Download WordPress

Forums

WP 2.8 fresh install Fatal error: Call to undefined function wp_dashboard_setu (24 posts)

  1. Jarudin
    Member
    Posted 5 years ago #

    I have tried many many many different permutations of fresh installations, installations with old configs, with or without plugins, anything I could think of but to no avail.

    I now installed WP fresh from the latest .tar.gz file.
    I ran the install script succefully.
    Blog created successfully.
    When I login with admin it gives me a page with just this error on it:
    Fatal error: Call to undefined function wp_dashboard_setup() in /home/sites/blog.bakabt.com/web/wp-admin/index.php on line 15

    Up to this point I have already tried many many many many many, I can not overexpress, many many many things to get this working.

    Chown apache * -R, chmod 775 * -R both have no effect.
    Yes all files exist.

    The only solution that I know is to disable APC (why? no idea).
    Adding wp- to apc.filters does not work.

    One peculiarity that I find useful to mention is the following.
    The above error occurs on wp-admin/index.php
    When I alter the require_once on line 13 to a require. Then duplicate that same line. I now expect a function-name clash, but no. It just gives me a white page (wtf?).
    Then if I enable error_reporting(E_ALL&E_STRICT) I get this error instead:
    Fatal error: Call to undefined function wp_cache_init() in /home/sites/blog.bakabt.com/web/wp-settings.php on line 299

    Can someone please tell me how to fix this?
    I will repeat myself if I have been unclear:
    THIS IS A FRESH INSTALL. Yes, all files are present (checked with file_exists). No, require_once does not seem to do it's job. Yes, disabling APC works but is not an option for me.

    I must add that I am an experienced professional PHP programmer and I simply can not explain the above behaviour. It seems like somehow the cache is interfering. But the errors only appear when using require_once, when using require the behaviour changes radically.

    Help!

  2. Jarudin
    Member
    Posted 5 years ago #

    I should add that I have not been able to find a single successful solution using Google. All threads seems to mysteriously die whenever this problem is brought up.

    Most solutions include:
    - Remove all plugins. Does not work for me as I have no plugins, fresh install. Moving the plugins dir has no effect (just to be safe).
    - Require files are missing. Required files are present, apache owns the files, chmodded to be sure.

    None of these solutions work for me.
    The only solution that works is to disable APC. Which is not a solution at all.

    I should also mention that the same behaviour, but a different error, occurs on WP 2.8

  3. It's APC, what version is it? Going to the latest and greatest may improve the picture but you'll still (probably) need to filter some things in the [apc] section of php.ini.

    Here are some APC issues and solutions that all point to adding filters in the [apc] section.

    http://wordpress.org/support/topic/225573?replies=5#post-1033606

    See update 3 on Marks blog
    http://markjaquith.wordpress.com/2006/02/13/adventures-with-wp-cache2-apc/

    None of these solutions work for me.
    The only solution that works is to disable APC. Which is not a solution at all.

    Not a solution? I guess that depends on if you want WordPress to work or not. Personally I use XCache but it's your server.

  4. Jarudin
    Member
    Posted 5 years ago #

    I have tried Mark's solution already and it doesn't work for me.
    I am not experiencing the errors mentioned on that page. I do not get a white blank page. I get a page with an error on it.

    I can not disable APC because other websites running on my domain rely on APC. That being said, I think it's safe to assume that APC's caching, is, or should be, transparent.

    Like I said. I added apc.filters = wp- and it has no effect.

  5. Jarudin
    Member
    Posted 5 years ago #

    Still no solution ..

  6. chris_savage
    Member
    Posted 5 years ago #

    Definitley an APC issue. Upgraded mine on the server to latest 3.1.2 and started to get the same messages as described above. Everything was fine in 3.0.19 (the last stable build) so i'm going to try downgrading to that instead, or tweak the config values for 3.1.2. Will report on findings...

    Chris

  7. jagger2097
    Member
    Posted 5 years ago #

    I dont know if that solved your problem but I am still having this issue.

    I installed a brand new copy of wp2.8 and after I login as admin I am sent to a blank page. I also tried a copy of wp2.7 and it does the same thing.

    I checked and I do not have APC enabled.

  8. ErikLtz
    Member
    Posted 4 years ago #

    Had the same error message (Fatal error: Call to undefined function wp_dashboard_setup() in /www/.../wp-admin/index.php) on a more oldish WordPress 2.6.3 using APC but no WP-Cache. Somehow the line
    require_once(ABSPATH . 'wp-admin/includes/dashboard.php');
    in wp-admin/index.php seems to fool APC. It's simply not included?!? I changed it to:
    require_once('includes/dashboard.php');
    and then I can login without disabling APC. Seems to work so far - but I see a number of require_once with ABSPATH included so it's strange, really strange...

  9. jagger2097
    Member
    Posted 4 years ago #

    Making that change worked for me as well. Thanks a lot man. :)

  10. Phlux0r
    Member
    Posted 4 years ago #

    What worked for me on OS X Snow Leopard with PHP 5.3 and APC was:
    [apc]
    apc.include_once_override=0

    HTH

  11. starapple
    Member
    Posted 4 years ago #

    What is APC? How does this problem affect people on a hosted server?

  12. reyespoint
    Member
    Posted 4 years ago #

    I'll add to this that I got this same error out of the clear blue sky today. Replacing:

    require_once(ABSPATH . 'wp-admin/includes/dashboard.php');

    with

    require_once('includes/dashboard.php');

    Resolves the issue. Any ideas why?

  13. dayg
    Member
    Posted 4 years ago #

    I had the same problem as reyespoint, the error "just happened" this morning for two of our sites. Do you happen to also be hosted with a2hosting? I'm running WP v2.9.2. The changes to wp-admin/index.php did the trick. What could have caused this issue?

  14. theparallaxview
    Member
    Posted 4 years ago #

    Seeing the same error as per this morning & using A2 hosting!

  15. lmagnif
    Member
    Posted 4 years ago #

    HI - I had the same problem - started out of nowhere last night! My wordpress blog is also on A2Hosting.com. While making that change did fix my problem with getting to my Dashboard, it left another problem for me.... I can not get to my Widgets! GO click on Widgets and see if that works for you. Let me know what you did to fix it if you fixed it... THANKS!

  16. limitless86
    Member
    Posted 4 years ago #

    SNAP - Got the same issue this morning. Using reyespoint mod seems to have fixed it, I also noticed some downtime with another A2hosted site I run.

  17. lmagnif
    Member
    Posted 4 years ago #

    limitless86, did you notice though that the Widgets can't be accessed even with reyespoint's fix?

  18. Neilcm1450
    Member
    Posted 4 years ago #

    I'm with A2Hosting too.

    First of all, i rarely have any issues with them so it's not a big deal that this came up. I was still able to access my admin page by going to a post and clicking on "edit" then navigating to where i wanted.

    A2 Hosting upgraded their servers yesterday to allow a choice of php versions. Evidently the new default PHP version is not entirely compatible with WordPress.

    The new default PHP Version is 5.2.9 Cached, which is what caused the error message. After changing it to the second option: 5.2.9 Zend Optimizer" the error went away.

    To change your version, go here: CPanel -> Software/Services -> PHP Version -> 5.2.9 Zend Optimizer

  19. limitless86
    Member
    Posted 4 years ago #

    @lmagnif, Yeah I have the same issue, Looks like it's to do with "ABSPATH" If you go to the top of widgets.php and make a similar mod:

    /** WordPress Administration Widgets API */
    //require_once(ABSPATH . 'wp-admin/includes/widgets.php');
    require_once('includes/widgets.php');

    It will display the page.

    Not an ideal solution but it works.

  20. limitless86
    Member
    Posted 4 years ago #

    I followed Neilcm1450's steps and switched to "the second option: 5.2.9 Zend Optimizer" and backed out all my changes Everything running fine now. Thanks man!

  21. lmagnif
    Member
    Posted 4 years ago #

    Do you guys know how long term switching to 5.2.9 Zend will be a viable option? When will support for that be discontinued by our host? Will WordPress upgrade to support the more current version of php?

  22. rrijnders
    Member
    Posted 4 years ago #

    I am also on A2Hosting. I tried to switch PHP versions to the "5.2.9 Zend Optimizer" but then ALL of my sites stopped working with an "Internal Server Error".

    I opened a ticket on A2Hosting pointing to this thread. Hopefully they are on it.

  23. a2hosting
    Member
    Posted 4 years ago #

    Hi all,

    We wanted to stop by and let everyone know that we've received all of the tickets, and the links to this thread. Thank you for pointing our attention here. This is top priority right now.

    The team is currently crowded around our office meeting room attempting to resolve this precise issue.

    I'll try to provide updates here, while they continue to work. We'll be responding to individual tickets once the larger issue is resolved. Please keep in mind that you'll likely see a public update here before a responses to individual tickets.

    Again, many thanks to those who pointed here. We appreciate the opportunity to resolve these with a single fix.

    -Kylebot

  24. lmagnif
    Member
    Posted 4 years ago #

    A2Hosting, THANK YOU for acknowledging the issue and working on it - so many hosting companies just say "Well, that's WordPress - we don't support it." THANK YOU for being customer-focused!

Topic Closed

This topic has been closed to new replies.

About this Topic