WordPress.org

Ready to get started?Download WordPress

Forums

WP 2.8 Clicking on setting button( options-general.php) gives a blank page. (5 posts)

  1. jmwalters
    Member
    Posted 5 years ago #

    When I click settings and it goes to options-general.php it show the top and navigation, but where the content should be is blank. I have no error in php, the only thing that shows up are these

    PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /var/www/htdocs/wp-includes/functions.php on line 112

    Here a screen shot
    http://pinky.ratman.org/~evilx/wp_issue.jpg

  2. rogersnowden
    Member
    Posted 5 years ago #

    I have precisely the same problem. Surely we are not alone here.

    What dumb thing am I doing wrong? Or is this a bug? Any workaround?

  3. phoneticus
    Member
    Posted 5 years ago #

    I guess I'll stand in line as yet another confused newbie. I've spent two and a half days attempting to complete the "Famous 5-minute Install" from the ReadMe file. Most of this time was spent trying to get MySQL to cooperate with either WinXP or Vista. WinXP won.

    I get to this page in the installation of WordPress:

    http://localhost/mysite/wp-admin/install.php?step=2

    Here, the bewildering date time error about "not safe to rely on the system's timezone settings." I know this is a Windows box, but isn't this a tad extreme - even for a Microsoft product?

  4. phoneticus
    Member
    Posted 5 years ago #

    I'm back, and with a fix.

    Search the installation folder for PHP.ini. Open the file in a text editor.

    Search for date.timezone as a string.
    Remove the leading semi-colon.

    Edit the line like this: date.timezone = "America/New_York"

    The timezone is in the error message. See the posts about this one. If you can't find your timezone, check out the following link.

    http://www.php.net/manual/en/timezones.php

    Please let me know if this actually helps anyone. It's not you, it's me . . .

  5. conceptify
    Member
    Posted 5 years ago #

    Another option if you don't have access to your server's PHP.ini file:

    In /wp/wp-includes/functions.php

    Add the following before the first function:

    date_default_timezone_set('UTC');

    Not sure if this is the best place to put this but some of the other places I tried it didn't work or only worked for certain parts of WordPress

    Of course this will break every time you upgrade WP so be warned.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.