WordPress.org

Ready to get started?Download WordPress

Forums

wp 2.7 error: Failed to connect to FTP Server http:// (35 posts)

  1. Dwenaus
    Member
    Posted 5 years ago #

    hi,

    when I try to install plugins from the admin, it asks me for connection information and I always get this error:
    Failed to connect to FTP Server http://mydomain.com

    I know my ftp info is correct (it is my own server) but I cannot seem to find the problem. anyone else experience?

    I started the blog on a 2.7 beta, so not sure if that matters. I expected the problem to go away upon using the final release but it hasn't.

    also, not sure if it is related, but if I leave the domain field without an initial http:// or ftp:// with just the domain name. the next page shows me this:
    mydomain.com://www.mydomain.com in that field. very strange.

  2. conqrr
    Member
    Posted 5 years ago #

    even i got the very same problem usin 2.7 . someone please help...

  3. Drclohite
    Member
    Posted 5 years ago #

    Me too, it does all of the above, I have spent a while making sure that my login details were correct. SO for now, we cannot install any plugins

    I downloaded 2.7 from the front page two days ago. Here is my error:
    Error: There was an error connecting to the server, Please verify the settings are correct.

  4. rize
    Member
    Posted 5 years ago #

    when trying to install a plugin does it give you this:

    Connection Information

    To perform the requested action, connection information is required.

    if yes, have you tried using localhost on your hostname?

  5. Drclohite
    Member
    Posted 5 years ago #

    thanks for the top tip, but that does not work either. I tried 127.0.0.1 to see if it would take an IP number - but same as reported earlier:
    127.0.0.1://www.previouslyentereddomain.com

  6. Drclohite
    Member
    Posted 5 years ago #

    thanks for the top tip, but that does not work either. I tried 127.0.0.1 to see if it would take an IP number - but same as reported earlier:
    127.0.0.1://www.previouslyentereddomain.com

  7. chrishird
    Member
    Posted 5 years ago #

    I have the same problem and I just upgraded, looks like it does not work?

    Chris...

  8. bal0o
    Member
    Posted 5 years ago #

    Same problem here... guess its a bug!

  9. Drclohite
    Member
    Posted 5 years ago #

    This is pretty serious, holding me up, should it hold me up?

    This is my first time with wordpress I am very impressed with previous versions but I am not happy.

    Anyone have any idea about how long this could take till we have a resolution - is there somewhere else we should be posting 2.7 problems... Will investigate

  10. WheresMarco
    Member
    Posted 5 years ago #

    This never happened on 2.6. WordPress FIX THIS!

  11. calpernia
    Member
    Posted 5 years ago #

    Same problem.

  12. jrozsa
    Member
    Posted 5 years ago #

    Definitely a bug. I'm not able to auto update any plugins. Everything can manually be done, but very inconvenient to have lost this functionality.

  13. Michael A.
    Member
    Posted 5 years ago #

    Me, too.
    Please, please, please, address this.

  14. Rodeo98
    Member
    Posted 5 years ago #

    May be a bug but whats the big problem?
    Just continue using your FTP as you used to do previously..Doesn't take long.Does it?

  15. johncolumbo
    Member
    Posted 5 years ago #

    If you are using network solutions as a hosting service do [reset file permissions]. I just did it and both the auto install plugins and the upgrading of plugins is working perfectly.

  16. DanOestreich
    Member
    Posted 5 years ago #

    John, I'm not using network solutions. Can you be more specific about how to do [reset file permissions]? Thanks

  17. toban
    Member
    Posted 5 years ago #

    I had a similar problem, I kept getting this error when trying to upgrade plugins or wordpress itself:

    Error: There was an error connecting to the server, Please verify the settings are correct.

    I just figured out that it was a password problem. I had the password correct, but the wordpress automatic upgrader doesn't work if your password contains special characters (e.g. +,*,\). I tested with an alpha-numeric (letters and numbers only) password and it works just fine.

    Try creating an FTP user with a no-special-characters password. Also, for hostname I use: http://ftp.domainname.com

  18. sators
    Member
    Posted 5 years ago #

    Got the same error...although this is what I did to get it to work:

    For the host - instead of putting in my normal http://ftp.domain.com address, I put in "localhost" without the quotes. Same username/password as my FTP user and whala. Worked.

    Give it a try. Depending on your hosting server setup, this may not work, but worth a shot.

  19. kremdela
    Member
    Posted 5 years ago #

    Maybe this will be of use to someone. I've been running a few wordpress installs on a slicehost account and thought I was having weird port issues. But no, your wordpress directory needs to be owned by your webserver.

    cd /yourwordpress_dir/
    sudo chown -R www-data:www-data *

    Worked for me.

  20. postalservice14
    Member
    Posted 5 years ago #

    sators, that fixed it for me as well...I imagine this is the same problem for a lot of people.

    People, try using localhost instead of the ip address or the domain name. It could be that your server does not resolve the IP or domain properly.

    Thanks sators.

    John

  21. Sita
    Member
    Posted 5 years ago #

    sators - that worked for me too - thanks!

  22. The Sandman
    Member
    Posted 4 years ago #

    Thanks kremdela.
    I am using Mosso Cloud Server and your solution did it for me!

  23. lldanj
    Member
    Posted 4 years ago #

    i have tried the suggestions above to no avail. i tried localhost as the hostname. i used my ftp username as is, and with the username@domainname.com. neither worked. any other suggestions?

  24. dragonsjaw
    Member
    Posted 4 years ago #

    I tried all the above as well,
    and still get the error message.
    I can FTP through my computers client into server no problem.

    What info is supposed to go here, I am using 2.8 on a new install and all else seems to be working fine.

    thanks
    ~bobbi

  25. g33kg0dd3ss
    Member
    Posted 4 years ago #

    My boyfriend's WP site is now experiencing the same problem after working fine for ages, and none of the solutions put forth to date here have fixed it. My sites, however, running the same WP version and a lot of the same plugins, all update just fine.

    His site is hosted with One World Hosting, while mine are all with PowWeb. Maybe it's a host issue? lldanj and dragonsjaw, who hosts your websites?

  26. Mark / t31os
    Moderator
    Posted 4 years ago #

    See if anything here helps.
    http://wordpress.org/support/topic/223144?replies=12

    To add, i have no such problems with 2.8 (think 2.7 was just the same iirc)... I've been able to download and update plugins from the admin (if i so choose - i do most by FTP) without a problem..

    Read Otto's response in the thread above it may be key to finding the source of your problem.

  27. dragonsjaw
    Member
    Posted 4 years ago #

    I have fixed my issue with this ftp login from dashboard.
    I can now delete themes etc.
    My problem, was an inaccurate formed login name..
    my host helped sort it out for me.

  28. rbdeli
    Member
    Posted 4 years ago #

    I have a fix that will hopefully help quite a few people out. I, too, had this very same problem and none of the suggestions above worked. Finally, I noticed that I had a couple of third party WP Upgrade Plug-Ins. I deactivated and deleted them. I went back and tried again and it worked.

    IMPORTANT:
    I did have to use the localhost as the domain name instead of the ftp site.

    Hope this helps a few people.

  29. magicker
    Member
    Posted 4 years ago #

    hi all

    The use of 127.0.0.1 as the host address fixed this issue for me

    thanks

  30. pianoguy91
    Member
    Posted 4 years ago #

    I have been searching around the forums for a topic similar to this, but haven't found my answer.

    I am testing WP on my local machine. (Ubuntu 9.04) When I see this text:

    Connection Information
    
    To perform the requested action, connection information is required.
    Hostname
    Username
    Password

    I get these various errors:

    Failed to connect to FTP Server 127.0.0.1:21
    Failed to connect to FTP Server localhost:21

    I do not know how to solve this problem as I am new to the Linux thing, but I know that I don't know why it won't connect and I don't know why it continues to try to connect to port 21.

    Please help!

Topic Closed

This topic has been closed to new replies.

About this Topic