WordPress.org

Ready to get started?Download WordPress

Forums

WP 2.6 Upgrade issues - catgories, database connection, 404 errors (4 posts)

  1. julesmaas
    Member
    Posted 5 years ago #

    my website & blog is hosted through Yahoo! Small Business and since I upgraded to 2.6 last week I keep getting all these problems:
    (www.maaspublications.net/blog/)

    1. permalinks broken - switched to 'default' and they worked again, but I'd like to go back to month/postname (apparently, yahoo! doesn't allow .htsaccess files)
    2. all my categories went 'blank' and i'm in the process of retagging every single friggin' post
    3. yesterday my blog 'disappeared' with some sort of 404 error - all my files & database are on the server and I can access through Yahoo! but when I went to my blog, it was 404, as was my login/access to wordpress
    4. today, i was able to intermittently access wordpress & edit posts, but then I started continually losing it to "Error establishing a database connection" - and now my blog has 'disappeared' again.

    This is my first WP upgrade, so I used the long instructions & not the express mode. Is this just some dumb thing I'm not understanding, or is it Yahoo!?

    Thanks for the help, all!

  2. richarduk
    Member
    Posted 5 years ago #

    Yahoo doesn't allow htaccess?

    That's one reason to get a proper host. They also have Fantastico, which - once WP is installed using it - allows one click upgrades. Someitmes it takes a few weeks for Fantastico to catch up with an upgrade i.e. you have to wait a few weeks before it's ready, but it's sooo easy, I wouldn't do it any other way.

    hostingmatters.com is who I use, but there's millions out there. Price means nothing - it's reliablity that's everything, and communication, and nowadays for a few pounds a month it's small change to get a decent host.

    Next: try exporting, save to computer, as XML. This will allow you to import everything back to WP if it dies on you.

    Personally I'd try two things: if no one else can give you a better answer, I'd reinstall WP and import the XML; or I'd cut my losses, get a decent host, install WP and import XML

  3. wedge1082
    Member
    Posted 5 years ago #

    I'm in the exact same boat as you. My work around for the cats. was to create a new one using the same name as one I had before. Make it the default cat. Then delete the old cat. which moved those posts to the new default cat. Repeat for each cat.

    I started to have a bunch of problems this week with my old WordPress so I decided to upgrade yesterday. I lost the cat., the connection to the database comes in and out. I used the 3 step instructions.

    I read a few other posts in which people were complaining about some of the same issues that I was having, and they got fixed with a upgrade to the 2.6.1 version. I am doing that right now to see if things get better.

  4. cwestonr
    Member
    Posted 5 years ago #

    I just fixed my cats It The way I did it was simpler.
    1. add a new cat
    2. click on the name of the new cat note the url http://sitename/wp-admin/categories.php?action=edit&cat_ID=20
    change the =# to the Id if the cat name you lost and press return
    3. you then can type the category name etc and save it. no need to change posts or delete of cats ( if you have access to the db the old table category has all the id/name etc. in it)

    Chris Roberts Ph.D

Topic Closed

This topic has been closed to new replies.

About this Topic