WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP 2.5 - WYSIWIG Problem - TinyMCE does not start.. (23 posts)

  1. katte82
    Member
    Posted 6 years ago #

    I've upgraded my blog from 2.3.3 to 2.5 but I've a problem with tinyMCE editor. It does not start. Firebug show me two errors:

    Position:
    /wp-includes/js/tinymce/tiny_mce_config.php?ver=20080327
    Error:

    missing } after property list
    (no name)()tw-sack.js (line 43)
    sack("/blog/wp-content/plugins/polls/polls-admin-ajax.php")tw-sack.js (line 192)
    [Break on this error] ri);})();(function(){var DOM=tinymce.DOM,Element=tinymce.dom.Element,Event=tinym...

    Position:
    /wp-admin/js/editor.js?ver=20080325
    Error:

    tinyMCE is not defined
    go("content")editor.js (line 73)
    onclick(click clientX=0, clientY=0)post-new.php (line 1)
    [Break on this error] var ed = tinyMCE.get(id);

    The first error appear when i load the the page, the second appear when i click to HTML link.
    How can I solve this problem?
    Best regards.

  2. MQabbani
    Member
    Posted 6 years ago #

    I have the same problem ...

    I Deactivate most the plugins Re active it .. nothing happen , clear the cash .and same

    but it work fine on Localhost same theme and pulgins

  3. katte82
    Member
    Posted 6 years ago #

    Anyone have an idea on how to resolve this problem?
    Do you need more details?

  4. cybertron
    Member
    Posted 6 years ago #

    The visual editor worked fine for me at first but then stopped for no reason, I have 2 blogs and only one is affected. I tried doing a complete reinstall.. deleted DB... and imported posts/comments/etc and still it is broken :-( sounds like a wide spread problem though so hopefully the powers that be(smart people) will be able to fix it :-)

  5. katte82
    Member
    Posted 6 years ago #

    LOL... I can't believe in it... After I've read your post I've open my blog for write a post and now the visual editor work fine... LOL..
    Anything is changed from yesterday.. Same pc, same browser, same software installed.. LOL..

  6. hakre
    Member
    Posted 6 years ago #

    That sounds like a javascript caching issue. Those often can be hard to trace. Close the Browser, then empty it's cache completely (for Internet Explorer this requires a special tool and a reboot), then start the browser again.

    The cache is then totally cleared, even the one in memory and you can be shure, that nothing is from an older, cached version.

  7. katte82
    Member
    Posted 6 years ago #

    That sounds like a javascript caching issue

    Yes, it can be..
    I change to resolved the topic.. If the problem reappear I will repost the problem.
    Thanks for the response.

    Regards.

  8. Trân Minh-Quân
    Member
    Posted 6 years ago #

    I've got the same problem, and I have three wordpress on the same server, same plugin, same version, one works and two others don't. I even replace the wordpress folder which the tinyMCE does not work with the folder which it works.

    I can't find any reason for this issue.

  9. planbeta
    Member
    Posted 6 years ago #

    I've cleared my cache, and tried in three different browsers, still getting the error...

    tinyMCE is not defined
    go("content")editor.js (line 73)
    onclick(click clientX=0, clientY=0)post.php (line 1)
    [Break on this error] var ed = tinyMCE.get(id);

    ...and...

    missing name after . operator
    [Break on this error] '", "' . $mce_locale . '");' . "\n";\n
  10. hakre
    Member
    Posted 6 years ago #

    Folks, I'm pretty shure those are caching issues. I know it's hard to clear the cache sometimes and you can run really agressive against your browser. Anyway, wordpress devs did a lot in wp 2.5 sothat for the next updates this should not come again so easily.

    Cachgin issues tipps:

    • Foxy, Foxy

      • Take Firefox (no offence please and I am not in the marketing team but if you ask me, you should at least have it already installed on your system.)
      • Get a plugin called "Web Developer Toolbar" http://chrispederick.com/work/web-developer/
      • You can use it to disable cache completely. This makes loading a page longer but you can proof on your own if something is a cache issue / cache resistable.
      • Even if it takes longer you can imagine why it is good to have some thing like a cache even if in this case you understand the downside this can have.
      • This can even help you under other circumstances you update something etc.
      • It comes with many other nice tools to have while webdevin'.
      • (Did I mention that there are tons of more Firefox Extensions that will please you?)
    • I heard that safari comes with cache=off menu command in latest version as well.
    • Often it helps to SHIFT + RELOAD a page (that is pressing the SHIFT key on you keyboard and clicking the reload button). This commands the browser to not take the cached version of whatever file but to request the latest version from server instead (with signalling all proxies, routers etc. on the way to not take cached anthing). This works quite well in firefox but aswell in other browser.
    • Please delete wp-includes and wp-admin before upgrading. Not really a caching Issue but with the caching Issues I know of previous updates, this can create even more chaos.

    Have I forgotten something? Plase add your own 2 cents as well.

  11. planbeta
    Member
    Posted 6 years ago #

    I have disabled cache using that plugin... still no luck.

    When the edit post pages loads I get...

    missing name after . operator
    [Break on this error] '", "' . $mce_locale . '");' . "\n";\n

    When I press the "html" button I get...

    tinyMCE is not defined
    [Break on this error] var ed = tinyMCE.get(id);
  12. planbeta
    Member
    Posted 6 years ago #

    Hakre, thank you!!!

    I followed your last peice of advice...

    Please delete wp-includes and wp-admin before upgrading. Not really a caching Issue but with the caching Issues I know of previous updates, this can create even more chaos.

    I deleted and reuploaded the wp-includes folder, everything is fine and dandy now :)

    Cheers

  13. joebeitler
    Member
    Posted 6 years ago #

    No help here. I've tried a number of avenues to resolve this issue. It doesn't work in IE nor Fox. Error console reports:

    tinyMCEPreInit.start is not a function

    Anyone with ideas on this?

  14. hakre
    Member
    Posted 6 years ago #

    @joebeitler: Please close all Tabs. The last tab that stays open navigate to about:blank. Then clear the cache and close the browser, close all other applications and reboot your windows operating system. After Reboot try again. Your problem should be solved.

  15. joebeitler
    Member
    Posted 6 years ago #

    @hakre: Thanks for the advice. I pressed on and researched a few things to try. The solution to my problem was found here (another thread). It is related to a "cache", just not primarily the browser cache. Although, the browser cache played a role here, too.

    http://wordpress.org/support/topic/166212?replies=2

    Also, through my research I discovered a neat little tool bar to use.

    http://chrispederick.com/work/web-developer/

    Definitely a must have.

    I love the internet! Thank you, Sir! May I have another?

  16. calidro
    Member
    Posted 6 years ago #

    It happen to me the same way (the html link did not make the switch), I do not know if there an issue with the NextGen Gallery, but once I deactivated , it works for me ,what I did is to deactivaed all plugins and reactivated one by one then I found that did not work with the NetGen Gallery.
    I do not saying that the plugin is the culprit, but just check it !
    Regards

  17. hakre
    Member
    Posted 6 years ago #

    @joebeitler: thanks for the additional forum link, I was not aware that javascript is cached by tinymce as well!

  18. dezzigner
    Member
    Posted 6 years ago #

    My TinyMCE is now completely broken. Cannot see any text in WP 2.5.1.

    The only way I can enter/edit text is by using PHPmyAdmin.

    None of the suggestions (caching) I tried fixed the problem.

  19. AzzX
    Member
    Posted 6 years ago #

    Try changing themes and see how it goes.

  20. bcodding
    Member
    Posted 5 years ago #

    Error "tinyMCEPreInit.start not a function" in FF3, firebug. WordPress 2.6.2, fresh install, on php 4.4.8.

    My problem was a known bug with PHP's realpath() (bugs.php.net/bug.php?id=34552), called in wp-includes/js/tinymce/tiny_mce_config.php:20.

    Realpath will output a null string if any ancestor directory of the file is not readable -- so folks running out of home directories - this is likely your case.

    My fix - change tiny_mce_config.php:17

    function getFileContents($path) {
    
    //	if ( function_exists('realpath') )
    //		$path = realpath($path);
    	$path = dirname(__FILE__) . "/" . $path;
  21. gduke
    Member
    Posted 5 years ago #

    I reproduced the behavior from the PHP bug report, and then tried the code change. It has resolved the problem for me. Thanks, bcodding!

  22. kampaka
    Member
    Posted 5 years ago #

    I tried other methods, especially in gzip usage. But didn't work. Now with bcodding's solution, clealy fixed. Thanks a lot, bcodding.

  23. romerican
    Member
    Posted 5 years ago #

    I was optimistic that bodding's solution would fix the problem, but TinyMCE still does not work in the 2.5+ era. Technically, I am running 2.6.5 on PHP5, but the problem remains the same. I've done all the cache disabling and restarting. With and without web developer toolbar. Tried using other browsers which have never been to the admin directory before and they don't work either. Clearly it is not a caching issue.

Topic Closed

This topic has been closed to new replies.

About this Topic