WordPress.org

Ready to get started?Download WordPress

Forums

WP 2.5 widgets are broken (19 posts)

  1. boilr
    Member
    Posted 6 years ago #

    I successfully upgraded to wp 2.5 today. after messing with different themes, i decided to try and use the built in widgets.

    after setting the widgets and saving them, they showed as expected on the blog. HOWEVER, when i go back to change the sidebar, no sidebar of widgets appears any more on the widgets.php page. instead, i see all widgets - added and unadded, and no other place to add/edit/remove the existing widgets.

    now i cannot adjust the sidebar in any theme...please help!

  2. Tarasque
    Member
    Posted 6 years ago #

    I'm having a similar issue:

    On my wordpress installation I had 3 "text" widgets. After updating to 2.5 and saving the widgets, everything in the text widgets were gone.

    I tried putting the information back, but as soon as I saved one of the previous ones that I fixed already (the text fields) would go blank again.

  3. PlaneMadness
    Member
    Posted 6 years ago #

    Same problem for me. But, there's a little twist. I tried everything as it is first in:
    PHP 5.0.4
    MySQL 4.1.20
    An everything worked perfectly fine.

    Then I switched servers to the following setup:
    PHP 5.1.6
    MySQL 5.0.22
    and that's when this problem started for me.

    Any help is appreciated!!!

  4. PlaneMadness
    Member
    Posted 6 years ago #

    I should also say that ....

    - I disabled all my plugins
    - I changed to the WordPress Classic Theme

    And the same issue was there: On Design/Widgets under Current Widgets there is nothing listed. Change sidebars and problem still exists.

    Seems to perhaps be a "bleeding edge" problem with this version of PHP? and/or My SQL since everything worked fine in my previous set up??

    Tarasque & boilr perhaps you could list your versions of PHP and MySQL as well?

  5. valenfor
    Member
    Posted 6 years ago #

    Also the same problem. Upgraded and this is about the main issue I have. All widgets are not available though they show on my site. I cannot select them in the drop downs, they do not show on the sidebar list or the show all list.

    php5, mysql 5

    V.

  6. PlaneMadness
    Member
    Posted 6 years ago #

    Only some of my widgets show on the main page still...

  7. arbs
    Member
    Posted 6 years ago #

    Ya have the same problem. We need a fix :S

  8. PlaneMadness
    Member
    Posted 6 years ago #

    'I was walkin'.. after midnight...'

    HEEEELP~!!!

  9. PlaneMadness
    Member
    Posted 6 years ago #

    Well it's after midnight that's for sure, but I managed to get everything working and very simply. Seems the widget page loads for the first time after 2.5 installation with 'Show All Widgets' selected, no sidebars, and nothing at the bottom of the page.

    Change that to "Show unused widgets" and walla... changed everything for me ... almost like a ctrl - alt - del... it reset the page and now it's like the problem never was.

    Hope it works for you guys too :)
    Goodnight

  10. chrisdoth
    Member
    Posted 6 years ago #

    Just to add, I was having problems seeing widgets and so editing them but this turned out to be a display issue with IE6, in IE7 I can edit/see the Text Widget.

  11. mrphew
    Member
    Posted 6 years ago #

    I have the same problem as Boilr. Half of my sidebar widgets are gone. I am using 18 widgets. Please help. Please.

  12. franzxaviere
    Member
    Posted 6 years ago #

    i've upgraded to wp2.5 but when i try to use widgets it's say
    %BEG_OF_TITLE%%END_OF_TITLE%XML error: syntax error at line 1

    please help me....

  13. mrphew
    Member
    Posted 6 years ago #

    I purged my browser cache and disable javascript and the list of the widgets came back after i restarted Firefox. But the ones I added are still missing although it reflected on the list.

    This is so frustrating. Can someone help me please? :(

  14. mrphew
    Member
    Posted 6 years ago #

    At some point my blog seemed to go berserk and funny layouts start to appear. Even the admin page went blank. To add to my woes, I couldn't access the plugins or any other page.

    It had to be the plugins I installed not long ago. So I deleted the offending ones via my FTP. True enough everything normalized. My heart attack was cured. So this is what I did.

  15. ThinkingSkull
    Member
    Posted 6 years ago #

    Try switching to IE 7.0. Worked for me (sadly).

  16. starry1
    Member
    Posted 6 years ago #

    Change that to "Show unused widgets" and walla... changed everything for me ... almost like a ctrl - alt - del... it reset the page and now it's like the problem never was.

    That worked great thanks!

  17. dykewife
    Member
    Posted 6 years ago #

    i'm having a similar problem to this (but found it could be fixed by putting a title on it) but now i'm having something different.

    when i go to the design then into widgets i see the widgets i have there, i see the widgets i have to choose from.

    in the list of widgets that i've used, some of them have "edit" on the right hand side, two others do not. i can't edit them, i can't remove them. the only thing in them is the title and the code for a graphic and its locale. one i made the mistake of forgetting to close a link code with the /a, the second was done correctly with the tag closed.

    so, what can i do? where can i find a place to fix that? i really want to be able to edit them (one to get rid of, the other to add to) and can't.

    if you can help, please keep the answers as dumbed down as possible. this is only my second day playing around with wordpress.

    you can see my site here. on the sidebar you will see two canadian gif graphics that i can't get rid of.

    thanks
    naomi

  18. allotts
    Member
    Posted 6 years ago #

    I have a problem with using widgets in two sidebars. The setup started out fine, but now I find that the right sidebar will not accept any additional widgets (it has only 3). I can remove widgets from the right sidebar, but cannot add. In the dashboard, when I click to show the right sidebar widgets, that works fine. Then, when I click a widget to add it, the dashboard switches the box to the main sidebar and adds the widget to it. Help!!!!!

  19. testeplanta
    Member
    Posted 5 years ago #

    I Have probaly the same problem, when i choice a widgets an put in "Left Bar" dont appears. And i can not remove the calendar widget.
    My blog is here.
    What can i modify the widgets if the widgets don't work, what can I do?

Topic Closed

This topic has been closed to new replies.

About this Topic