WordPress.org

Ready to get started?Download WordPress

Forums

WP 2.5 Post Slugs (32 posts)

  1. MrsMicah
    Member
    Posted 6 years ago #

    One thing I really liked about WP 2.3.x was being able to rewrite post-slugs. I've put WP 2.5 on my test blog and I can't see a way to do it. The handy little box is gone. I haven't found another way to do it.

    As other people have mentioned, I also liked the flexibility of being able to move things around in the write-post section. Some things I never use, so they're at the bottom. It's a lot easier. It's like WP 2.5 went backwards here.

    I think there's a lot of good stuff in 2.5 and look forward to using it, but until the write page is fixed I'm not downgrading my blog.

  2. MichaelH
    Member
    Posted 6 years ago #

    The Post (or Page) slug is now displayed as the Permalink under the Title field in writing or editing a Post or Page. If you are using the "Default" Peramlink Settings you will not see and can't edit the Permalink. Only if you are using a 'pretty Permalink' (e.g. Month and name) in Settings->Permalinks will the Permalink be available for edit. When creating a new Post or Page, the Permalink field won't show up until you complete the Title.

  3. MrsMicah
    Member
    Posted 6 years ago #

    Ah, I hadn't set up the permalinks on my test blog. Good to know.

  4. marie-aude
    Member
    Posted 6 years ago #

    Unfortunatly, when you edit the post slug it does not change the value in the database. I hit "save" and it does not change the value in the database.
    I tried that with a post already saved, and while creating a post, and the result is the same, even if I edit my permalink, it stays to the standard value.

    My permalink structure /%postname%-%post_id% and it works perfectly fine on 2.3

  5. Kaambiz
    Member
    Posted 6 years ago #

    almost same problem here. I can't see the field to edit permalink!

  6. tibc
    Member
    Posted 6 years ago #

    Is it just me, or do Page slugs NOT appear until after you have published the Page in WP2.5?

    For Posts, the permalink line does appear after entering the title (as MichaelH notes above); but for my Pages, the permalink line will only appear after publishing--then I have to Manage/Edit the Page. Saving, or keeping private do not trigger the permalink line for me.

    Is this unique to my setup, or do others experience this, too?

  7. MichaelH
    Member
    Posted 6 years ago #

    @tibc
    In Write->Page, I titled page, "When does the page permalink become visible?". Then two seconds after I tabbed out of the Page Title the Permalink appeared ready for edit.

  8. MichaelH
    Member
    Posted 6 years ago #

    @Marie-Aude

    I am not seeing your problem. With your Permalink structure, saved a post, edited post, edited Permalink, saved the post, and the database had the edited Permalink in the post_name column.

  9. tibc
    Member
    Posted 6 years ago #

    @MichaelH, Thanks for checking. I'll look at plugin/theme compatibility issues.

  10. tibc
    Member
    Posted 6 years ago #

    @MichaelH, I have reconfirmed that the Page slug line does not appear until after publishing the page, and then returning via manage/edit page.

    I tested on a clean install, no plugins, default theme, with a new mysql database on a 1and1.com server.

    As before, the Post plugin line appears as expected.

    This does not work with either IE7 or Firefox.
    This does not work on two different pc's.
    This does not work on my local WAMP server or the 1and1.com server.

    For me it's a minor inconvenience; yet I'm curious what may be my problem.

  11. MichaelH
    Member
    Posted 6 years ago #

    @tibc
    Try this, set Permalinks to Default, save, logout.

    Set Permalinks to 'something pretty', such as by Month and Name, save, logout, then write the page.

  12. tibc
    Member
    Posted 6 years ago #

    @MichaelH, thanks for the tip, but still no joy.

    Since I have to publish with the default WP-generated permalink just so I can trigger display of the permalink display/edit line, will not the feeds already have distributed the default link before I can correct the problem?

    (and I am using the final 2.5 code)

  13. MichaelH
    Member
    Posted 6 years ago #

  14. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    tibc: Try disabling mod_security in your wp-admin directory.

    Make an .htaccess file in your wp-admin directory. Add this to it:

    <IfModule mod_security.c>
    SecFilterEngine Off
    </IfModule>

    See if that helps any.

  15. tibc
    Member
    Posted 6 years ago #

    @Otto42: The .htaccess file is in place, as you suggested; but there is no change in behavior.

  16. jakemc
    Member
    Posted 6 years ago #

    For my install of WP 2.5, the slug does not appear for editing if the page being edited is selected as Front Page in Reading Settings.

    Hope this helps.

  17. domramsey
    Member
    Posted 6 years ago #

    The other problem is that the preview of the permalink doesn't change if you change other things like the category (my URLs have the category name in them).

  18. Trân Minh-Quân
    Member
    Posted 6 years ago #

    I have WordPress 2.5 work on 3 servers, two work well with the Page slug (dedicated servers) and another is a hosting from 1and1 where the Page slug does not work.

    Same configuration and plugins!

  19. tibc
    Member
    Posted 6 years ago #

    @link2caro, thanks for pointing out this problem originally, and for following up here and on the tracker.

  20. Trân Minh-Quân
    Member
    Posted 6 years ago #

    tai: Reproduced with PHP 4.3.3, but not with 5.2.3. It may be specific to the PHP version.

    Me: Issue reproduced with 4.4.8 not with 5.2.5

    Could you guys who does not follow the tracker specify your version of PHP here? Thanks

  21. pariahdogww
    Member
    Posted 6 years ago #

    Hi,

    Working on my localhost, had to do the following:

    1. My localhost runs Windows Vista which is pretty restrictive with file permissions. Grant all users to write permission to the file:

    .htaccess

    which is located in your WordPress installation directory.

    2. modify httpd.conf to allow the directives in the .htaccess file to override global default server directives.

    AllowOverride All
    # the default was 'None'

    2.a - you'll also need to turn on mod_rewrite:

    LoadModule rewrite_module modules/mod_rewrite.so

    3. After you change the permalink settings, view the .htaccess file. It should contain something like the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wp25/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wp25/index.php [L]
    </IfModule>
    
    # END WordPress

    4. Restart your apache server

    Note: if you are working on a shared host and this doesn't work, contact your administrator and ask if mod_rewrite is loaded and if allow_overrides is 'All'.

  22. Clicknathan
    Member
    Posted 6 years ago #

    I've built about 10 sites in WP 2.5 & 2.5.1 now, on a large variety of servers and PHP setups and I can confirm that this is a definite issue which doesn't seem to have a whole lot of continuity as far as when it does or doesn't work.

    On most of them, it'll work once in a while and not other times.

    Until the feature has been sorted out, it'd be nice if it could just be down in the advanced options section. I suppose this isn't the place to mention that though....

  23. chowpay
    Member
    Posted 6 years ago #

    Anyone figure this out my slugs aren't saving / allowing me to edit either :( wp2.51

  24. Indojepang
    Member
    Posted 6 years ago #

    yup me too.. it's not saving after edit the slug

  25. marcow
    Member
    Posted 6 years ago #

    I have something similar with 2.51, I can change the slugs but it is not saving the period before .htm
    Also it reverts everything to lower case, I have some urls starting with an upper case that I would like to move over to WP.

  26. susb8383
    Member
    Posted 6 years ago #


  27. waynehatcher
    Member
    Posted 6 years ago #

    Is this the reason I am unable to assign in my style sheet custom header images to specific pages using the following css?

    #page_slug #header {
         background: url('custom_header.jpg');
         }

    (This scenario is assuming my image file was in the same directory as the style sheet.)
    I use to have a site using 2.3 and this worked. Now with a new site using 2.5 it's no go.

  28. pcmt
    Member
    Posted 6 years ago #

    yup me too.. it's not saving after edit the slug

    Me too. If the permalink for a Page can't be edited, I can't upgrade to WP 2.5.1

  29. pcmt
    Member
    Posted 6 years ago #

    What isn't very clear is that after you've edited the Page permalink (under the title), you then have to save the Page as well. Then it works.

  30. tibc
    Member
    Posted 6 years ago #

    Upgrading to PHP 5.x on my 1and1 hosted installations has solved the Page slug problem for me.
    And, yes, you must save the edited slug AND the Page.

Topic Closed

This topic has been closed to new replies.

About this Topic