WordPress.org

Ready to get started?Download WordPress

Forums

WP 2.3 and scribefire not working together anymore ... (17 posts)

  1. fistofpeanuts
    Member
    Posted 6 years ago #

    Hey guys ..

    I can't use scribefire or blogdesk anymore to post to me WP 2.3 blog. It used to give me no problems with earlier versions but now both softwares will not even let me login.

    Scribefire tells me there's something wrong with my user name and password, while they are fine and blogdesk gives me an XML parsing error as well ...

    Anyone know what the problem is here ?

    -FOP-

  2. fistofpeanuts
    Member
    Posted 6 years ago #

    Ok.... Am I really the only one having this problem ???

    It seems to have to do with xmlrpc.php ... I've written the exact error that blogdesk gives me below .... And by the way, I no other blog editor works either. Maybe it could be something on my shared host ? The point is that it worked fine with 2.2 and nothing has chanced in the setup...

    An error occured while uploading the post.
    Error transfering the post to the server.
    XML Parsing Error : Malformed comment,'--' no allowed inside comment starting at position 546

    -FOP-

  3. jkslouth
    Member
    Posted 6 years ago #

    I'm having the same problem.

  4. imarrieddanville
    Member
    Posted 6 years ago #

    Same problem here, inexplicable login error at the end of setting up ScribeFire, with a self-hosted WordPress blog. It sure does seem like something's up with xmlrpc.php.....

  5. kaptkaos
    Member
    Posted 6 years ago #

    Yep, I have the same problem. Just installed Scribefire. I get the following:

    Please add (or change) your API URL:
    Server AIP URL:
    http://thecheernews.com/xmlrpc.php

    then I get:

    Login Error
    Please check your username and password for errors and try again

    I know the login/password are correct.

  6. popwireless
    Member
    Posted 6 years ago #

    Me too, with Windows Live Writer.

  7. brasscupcakes
    Member
    Posted 6 years ago #

    WordPress no longer works with:

    post2blog

    scribefire

    blogdesk

    Even if there's some incredibly obvious solution that all of us are missing, can't somebody who knows the answer at least give us dimwitted souls some clues?

    I mean come on, this thread has been hanging around for months and months, please help already!

    Thank you.

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I'm sorry, but you're mistaken. WordPress does indeed work with ScribeFire, as I use it all the time. I just recently found ScribeFire and began using it with my WordPress 2.3.3 setup a month or so ago. I have had no issues.

    Whatever error you're having is not a bug in WordPress. It may be a problem with your setup in some fashion. Or possibly a problem with your server. mod_security may be interfering, that would be the first thing I would check.

  9. Len Kutchma
    Member
    Posted 6 years ago #

    I hadn't even heard of ScribeFire until this thread so I installed the add-on, works without a hitch for me.

  10. dtateii
    Member
    Posted 6 years ago #

    Had this same problem with ScribeFire 1.4.7. and WordPress 2.3.3. I uninstalled SF and reinstalled an older version, 1.4.2 and it seems to work fine now. Heres a link for the version that worked for me: http://www.brothersoft.com/scribefire-download-64941.html

    Hope this helps!

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I didn't know what version I had, so I checked and it was indeed 1.4.7. So I just tried on a test blog I have. WP 2.3.3, SF 1.4.7. Post showed up immediately. Works great here.

  12. nicerobot
    Member
    Posted 6 years ago #

    It isn't just scribefire. Everything I've tried to use (digg, scribefire and trying perl now to try and diagnose more) to post to my WP 2.3.3 blog produces an access error similar to the following:

    XXX.XXX.XXX.XXX - - [28/Mar/2008:15:44:09 -0400] "POST /blog/xmlrpc.php HTTP/1.1" 406 344 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4"

    The issue is the http code, 406. It should be 200 if the post was successful.

    Oddly, I reverted my xmlrpc.php to 2.3.2 and that worked for about a week, until today. I've changed nothing (can't speak for my ISP) but now I can only post to my site using the WP dashboard. No other option works.

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    WordPress does not have the ability to send a 406 error code as a response. Your server is causing the problem.

    Googling, I notice that Drupal has seen this same issue before when hosts modify their servers to disable "xmlrpc" calls. Sometimes this can be worked around by renaming the xmlrpc.php file to something else. Although, frankly, I'd simply switch hosts. Life is to short to work around bad hosting service's idiotic solutions to non-existent problems.

  14. nicerobot
    Member
    Posted 6 years ago #

    Thanks Otoo. You were exactly right. My hosting provider implemented this "security" against xmlrpc.

  15. jeff.thomas
    Member
    Posted 5 years ago #

    We're updating to WP Mu 1.3.3.
    Does it support scribefire?

  16. rhowell
    Member
    Posted 5 years ago #

    I had the login problem, and I found the workaround for me was to change my xmlrpc.php file. (I owe thanks to Otto42 for his suggestion above.) About halfway down, there is a script that says $xlmrpc logging = 0;
    I changed 0 to 1, and now all seems dandy.

  17. Anonymous
    Unregistered
    Posted 5 years ago #

    Found the solution - in my case it was a theme issue - but I show how to debug it here to find the problem - good luck.

    http://www.benshoemate.com/2008/07/26/scribefire-error-solved-server-returned-malformed-response/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.