WordPress.org

Ready to get started?Download WordPress

Forums

WP 2.0 Writing Posts in HTML (11 posts)

  1. jaredkc
    Member
    Posted 8 years ago #

    WP 2.0 alters my HTML tags when I am writing a post. If I have a few paragraphs I want tags on each of them. I start my post with and image that that I do not want tags on. WP 2.0 keeps putting tags around my whole post and I do not want it to.

    Is there anyway I can write my post in HTML without WP altering it at all?

  2. Austin Matzko
    Member
    Posted 8 years ago #

    I use the Text Control plugin to turn off all that extra formatting.

  3. lisavollrath
    Member
    Posted 8 years ago #

    Thanks for posting this. I'm HORRIFIED at the amount of useless code the editor is dumping into my pages---and despite my going in a stripping it out, it reappears again. It's wrong, wrong, WRONG.

  4. jaredkc
    Member
    Posted 8 years ago #

    Thanks Filosofo, That plugin helped.
    It does not do exactly what I want but it will do for now, I am tired of messing with it.

    I used the nl2br option that used "br" tags in place of "p" tags. It would be nice to use "p" tags without WP adding one at the beginning of the post. I can adjust the spacing on "p" tags and not on "br" tags.

  5. lisavollrath
    Member
    Posted 8 years ago #

    After playing with this for a couple of hours, I've discovered that theres NO setting that doesn't add extra code to my posts, no matter which settings I use.

    Why can't I just write my own damned pages in this thing? I've done perfectly fine generating my own HTML without stupid WYSIWYG editors for years.

    I'm frustrated. I have hundreds of pages to move into WordPress---but if I can't get it to understand a simple table, and not put dozens of line feeds into a page, I'll have to abandon it completely, and stick with my stupid HTML static pages.

  6. Nicki Faulk
    Member
    Posted 8 years ago #

    Are you using the visual rich editor or the old plain text editor?

  7. moshu
    Member
    Posted 8 years ago #

    Go admin > Users > your profile and in the left bottom corner disable the RTE editor. You'll get back the "old-style" text input area.

  8. Austin Matzko
    Member
    Posted 8 years ago #

    Have you tried just turning off the WYSIWYG editor (under Users > Your Profile)? With it off and the Text Control Plugin, there shouldn't be any unwanted markup.

  9. lisavollrath
    Member
    Posted 8 years ago #

    THANK YOU! I missed the checkbox on my profile page---I never thought to look there for settings for writing posts! I have the plain text editor back again, and am removing buckets of extra linefeeds from my posts that the WYSIWYG editor dumped in.

  10. lisavollrath
    Member
    Posted 8 years ago #

    (and on the plus side, this also fixed my JavaScript problems)

  11. auxillary
    Member
    Posted 8 years ago #

    Is there any information on what the different settings mean?
    Like the textile 1 and 2, nl2br, fancypants, etc. settings.

    And playing around with them, ... several settings didn't work. I got an php parse error.

    Note: I am on WP 2.0!

    TIA,

    Eric

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags