WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP 2.0 messed up my permalinks (53 posts)

  1. dbasulto
    Member
    Posted 8 years ago #

    are the fixes that ryan posted included on the 2.0 build that you download from wordpress.org?

  2. webseo
    Member
    Posted 8 years ago #

    My problem is fixed (see post 2 before this one).

    I found out the mod_rewrite was not loaded in my httpd.conf file.

    Thanks to all the people that posted suggestions in all the threads on this problem. I assume that I still needed to have the Ryan updated files (which I do). If I get time, I will go back to the old ones and see what happens and post back here.

    martin

  3. webseo
    Member
    Posted 8 years ago #

    I went back to the original classes.php and functions.post.php files that came in the WP 2.0 download (on 01/24/05 wordpress-2[1].0.zip)and all is still well, so either that download has been updated or whatever bug Ryan fixed hasn't shown itself on my site.

    Thanks again to everyone.

    martin

  4. superberri
    Member
    Posted 8 years ago #

    I've used Ryan's fixes and I no longer get 404s on the main blog page with the most recent 10 or whatever posts showing. However, when clicking for individual posts I get a 404. Numeric permalinks work but the customs do not.

  5. davidterrar
    Member
    Posted 8 years ago #

    Hi,
    I had this permalink 404 problem, but only with posts that had an apostrophe in the title! I used Ryan's suggested fix of the new classes.php and functions-post.php and it cured the problem. Excellent! Thanks.

  6. muskie
    Member
    Posted 8 years ago #

    I've tried all the stuff in the posting and other suggestions and my permalinks don't work. I was using option 2 under WordPress 1.5.2 I guess. I also use a subdirectory http://blog.muschamp.ca

    I often linked to my old posts from my newer posts, none of these links work. I don't get a 404, I just get the default front page with a different URI in the browser window.

    Any suggestions?

    Muskie

  7. sonria
    Member
    Posted 8 years ago #

    Hi folks,

    I've got the permalinks working but my paging is still borked. Unfortunately, every time I try to download the new classes.php, Firefox has a seizure. Is the classes.php the problem or is it something else?

    Thanks.

  8. djchuang
    Member
    Posted 8 years ago #

    In case your web host is not compatible with the new WP 2.0.x abbreviated 9-liner htaccess file, you might find the older WP 1.5.x lenthy htaccess to work. This was the case for numeric permalinks and Fatcow web hosting. I've detailed the instructions at http://www.djchuang.com/2006/02/d1249

  9. atobias
    Member
    Posted 8 years ago #

    Hi, I have experienced a similar problem since upgrading to WP 2.0.

    I have the permalink options set to Date and name based: http://www.lekkerhapje.nl/2006/03/13/bifteki/

    When I create a new post, I have no problems, all permalinks still work fine. I am guessing that is beacause WP doesn’t touch the .htaccess in that case.

    The problems come when I try to create (or update) a page. WP then tries to update .htaccess file. In the past it would add several lines to rewrite the page title in the url, but since WP 2.0 it changes the .htaccess into the new 9 line format. This causes all the permalinks to break, all of them leading to the home page when clicked.

    I have replaced the classes.php and functions-post.php files as detailed in the thread, but that doesn;t solve anything.

    Is there any way to get the “old? way of generating .htaccess back? Right now the only thing I can do is revert to my old .htaccess file and manually add the rules for the new page evrytime I want to create one.

  10. pressureword
    Member
    Posted 8 years ago #

    I'm new to WP. Installed the latest version and permalinks doesn't work. Tried the fix, didn't work. :(

    Where can I get the previous version? I really need permalinks to work correctly.

  11. ihad
    Member
    Posted 8 years ago #

    it seems there is still some error with the permalinks structure or maybe with ELA? as soon as I choose anything but the default setting under "permalinks" it breaks ELA and it will show nothing on the Archives page of my K2 install.

  12. adriand
    Member
    Posted 8 years ago #

    I also have a problem with WP 2.0 and the .htaccess file. It's odd but all my permalinks work fine, even though WP is not generating an .htaccess file. I have looked all over the place for it and it doesn't exist.

    It's great that my permalinks work, the problem is that my main page returns an internal 404 when it's accessed with a trailing slash. E.g.:

    myblog.com/index.php

    works fine, but

    myblog.com/index.php/

    gives me an internal 404. This mystifies me. Can anyone give me some tips?

  13. miriam_catira
    Member
    Posted 8 years ago #

    I tried the two files from Ryan. No such luck. Please help! I started a new post... please help! It's called
    "permalinks, .htaccess, and broken everything!"

  14. joshray
    Member
    Posted 7 years ago #


  15. marianiello
    Member
    Posted 7 years ago #

    I have similar problem as outlined here: http://www.djchuang.com/2006/02/d1249 but on netfirms hosting

    I tried implementing the suggested changes but afterwards I too got a non-wp 404 error. So far I have tried every solution given in these forums and nothing seems to work. This must be a wp2x problem and I hope they fix it in future builds. For now I guess permalinks are not possible.

  16. Chris_K
    Member
    Posted 7 years ago #

    Click around on my blog and tell me again how permalinks aren't possible! :-)

    In the meantime, check out:
    http://codex.wordpress.org/Permalinks#Fixing_Permalink_Problems

    There's a lot there to read and try.

    In particular: Make sure your host not only has mod_rewrite turned on, but also has "AllowOverrides" turned on too.

  17. marianiello
    Member
    Posted 7 years ago #

    Are you and I using the same hosting HandySolo? Because the post I linked to had to do with different hosting companies. I'm glad they work for you and I know how to read.

  18. Chris_K
    Member
    Posted 7 years ago #

    Me too! :-)

    This must be a wp2x problem and I hope they fix it in future builds. For now I guess permalinks are not possible.

    I disagreed.

  19. marianiello
    Member
    Posted 7 years ago #

    Okay, point taken. what I meant was: there is a problem with the new way wp2x makes permalinks that is incompatable with some hosts. From what i understand there is a different, more complicated method used for writing to the .htaccess file. My host doesn't seem to like this method so they block it.

    So, yeah. I'm switching hosts. Didn't meant to sound rude, just frustrated.

  20. pufaxx
    Member
    Posted 7 years ago #

    I also had problems, after I had an upgrade from WP 1.52 to WP 2.03 on a test-site ...

    The permalinks just did not work.

    But I've found a quite simple solution:

    1) open "wp-includes/classes.php"
    2) find line 880: var $use_verbose_rules = false;
    3) change it into: var $use_verbose_rules = true;
    4) save your data
    5) go to your permalink-options and update your permalink structure

  21. gaster
    Member
    Posted 7 years ago #

    I think I tried all tips wirtten here by you all.
    first ryan tip, then fixing htaccess from this site http://codex.wordpress.org/Permalinks#Fixing_Permalink_Problems and pufaxx method from yesterday.

    I've updated my scipt to wp. 2.0.3 and still can't run other cgi scripts from cgi-bin when permalinks are set up
    If I disable peramlinks everythink works alright...
    please help, I would like to keep permalinks and have some cgi scripts workin...

  22. vogelap
    Member
    Posted 7 years ago #

    I am having the same issue. I've replaced the classes.php and functions_post.php files with the latest copies in this thread and done all the steps here: http://codex.wordpress.org/Permalinks#Fixing_Permalink_Problems . As long as I do not visit Options->Permalinks, my site functions as expected. However, if I even visit Options->Permalinks, my site's permalinks stop functioning unless I set them to the default (I don't even have to click "Update Permalinks Settings"; just visiting the page breaks it), which breaks internal links in my site.

    I've followed all the steps on http://codex.wordpress.org/Permalinks#Fixing_Permalink_Problems , but my .htaccess is still never updated.

    Please help!

  23. bgaspers
    Member
    Posted 7 years ago #

    I am having the same problem as well. Followed all the suggestions in this thread with none of them working. .htaccess is definitely writable and AllowOverrides is set to All.

    My installation is WP 2.0.4 running locally on a laptop (Mac OS X 10.4.7, Apache 1.3.33, PHP5).

    Setting permalinks to the Date and name based option causes the 404 behavior for Pages (haven't tried categories), resetting to default makes everything run again.

    Obviously a bug somewhere still in v2 between the WP rewrite rules and mod_rewrite.

Topic Closed

This topic has been closed to new replies.

About this Topic