WordPress.org

Ready to get started?Download WordPress

Forums

WP 1.2.1: Formatting borked again (10 posts)

  1. Sphyr
    Member
    Posted 9 years ago #

    I had this problem at http://www.chasingthewind.net before when I tried an August nightly of 1.3. With Podz help, I reverted back to 1.2.
    Last night I upgraded to 1.2.1. I uploaded everything, ran upgrade.php. An hour later, all the formatting on my blog is borked. When you try to comment, you're sent to a login page where you can't login.
    Clicking on the "Login" button redirects you to this bizarre link:
    http://chasingthewind.net/wordpress/wp-login.php?redirect_to=/wordpress/wp-images/smilies/wp-style/Blue%20Swirly/wp-images/smilies/wp-images/smilies/wp-images/smilies/wp-images/smilies/wp-images/smilies/wp-images/smilies/wp-login.php
    And before somebody tells me to delete "Blue%20Swirly", that's not the problem. Even with a complete default WordPress install, I have this munged formatting problem.

  2. Dave Kaufman
    Member
    Posted 9 years ago #

    I think I am in the same boat. I was happily making some changes (of course finishing touches) to an install and playing with the template editor on my wp-layout.css file when the site choked. It is my only explanation. I hit update and instead of showing me the file it jumped to a "view site" version. But the site lost all the formatting.
    I then hit login and the URL I was sent to was:
    http://publicwatchdog.org/wp-login.php/wp-admin/wp-admin/wp-admin/wp-admin/wp-admin/wp-login.php instead of the normal one.
    I have attempted to copy over a clean version of all the install files and even renamed the index.php and wp-layout.css files to keep my changes. Nothing works. I can not restore formatting no matter what I try. Since the content appears I thought the error might be in the reference to the .css file, but I cross-checked it with another index.php install of WordPress and found them to be identical.
    Any help would be greatly appreciated.

  3. Dave Kaufman
    Member
    Posted 9 years ago #

    alpahoide - did you see my comment? I would think the fact that URL's were both so close in format would be "something". I am racking my brain trying to figure out how to get back my formatting.

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Get your formatting back by using phpmyadmin, and reseting the 'site_url' and 'home' values in the table 'wp_options'
    This is a relatively rare occurence, and is to do with the www part of your address.
    Turnip's workround helps apparently:
    http://turnipspatch.com/archives/2004/10/19/killing-the-word-wide-web/

  5. Joshua Sigar
    Member
    Posted 9 years ago #

    This comment?
    I think it’s more of a miracle than a test.
    Is it all sorted out or it's working from my side but not yours?
    Or am I completely misunderstood your problem?

  6. Sphyr
    Member
    Posted 9 years ago #

    Alphaoide - ah, so you were "test". I wondered what that was all about.
    I'm hoping they track this down for 1.3. I'm using 1.2.1, and approximately once a day I have to reset my options to remove the "www" that keeps creeping back in there.
    Podz suggestion will work if you can't login. The symptoms seem to vary from host to host; when I was on GoDaddy.com, I'd often have trouble logging in (though I was redirected to wp-smilies\wp-smilies\wp-smilies instead). I switched to blogs-about.com and I get a less severe set of symptoms. I simply go to the option page and remove the "www."
    Accessing my blog using http://www.chasingthewind.net seems to cause the problem more often; going to chasingthewind.net keeps my blog running longer without having to fix that "www" in the options.

  7. Dave Kaufman
    Member
    Posted 9 years ago #

    WOW! I am in awe. Thank you so much podz! First off I am in awe of you for figuring out from my gibberish what the problem was. I read over Turnip's column and was still pretty lost. Then I entered the hazy world of phpmyadmin for newbie that is like the jungle. Dark and eerie. I found the table, and made the change back. (not including the www) I could not find the 'home' value you spoke of but the changing the 'site_url' seemed to do the trick. Once again, thank you very much!

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    :)
    The 'home' link is further in that table... I will get round to some screenshots for this. Promise !

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Done:
    Using phpmyadmin to alter the site_url and home values in the database:
    http://www.tamba2.org.uk/wordpress/site-url/
    One day I'll be famous for my screenshots :D

  10. Anonymous
    Unregistered
    Posted 9 years ago #

    Could this be related to the problem with wp_login.php updating the site-url?
    it sounds an awful lot like this thread?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.