WordPress.org

Ready to get started?Download WordPress

Forums

WOW Slider
[resolved] WowSlider causing Jquery Error after WP 3.5.1 update (9 posts)

  1. klogan2
    Member
    Posted 1 year ago #

    After updating WP to 3.5.1, I've found that WowSlider is throwing a JS error. I think I found the issue, and it seems to be deprecated JS code. Here's the code:

    if ((D.browser.msie && parseInt(D.browser.version, 10) < 8) || (/Safari/.test(t))) {
            var P = Math.pow(10, Math.ceil(Math.LOG10E * Math.log(B)));
            I.css({
                width: P + "00%"
            });
            i.css({
                width: 100 / P + "%"
            })
        } else {
            I.css({
                width: B + "00%",
                display: "table"
            });
            i.css({
                display: "table-cell",
                "float": "none",
                width: "auto"
            })
        }

    The deprecated code seems to be right at the top, D.browser.msie.
    For now, I've just commented out the whole block, and WowSlider is working again, and not throwing an error. Just a temp fix though. I've tried a few googles & code changes, but with no luck so far. I've also updated my WowSlider slider creator to v2.8, but it's still generating the same JS. SO, the answer seems to know the right code. Assuming I am correct, anyone know the correct code, so what I think is a MS IE fix, works again?
    Cheers, Kevin Logan

    http://wordpress.org/extend/plugins/wowslider/

  2. WOWSlider.com
    Member
    Plugin Author

    Posted 1 year ago #

    WOWSlider won't work with jquery 1.9.
    To fix it you may:
    1. use jQuery Migration plugin for WordPress:
    http://www.herdboy.com/all-free-stuff/item/jquery-migration-plugin-for-wordpress
    2. if the problem still persists, add the content of http://code.jquery.com/jquery-migrate-1.0.0.min.js in the beginning of WOWSlider script:
    http://www.bestofhomecare.com/wp-content/uploads/wow-slider-plugin/10/script.js

    Our developer team will try to make support for jquery 1.9 in the near future.

  3. klogan2
    Member
    Posted 1 year ago #

    Thanks for the quick reply. I've looked at the jQuery Migration plugin (haven't tested it yet admittedly) and my gut reaction is to avoid it. It's an issue of "what exactly is it doing" and not knowing what ramifications it may have elsewhere in my site.
    That said, any ETA of when Wowslider might be updated to deal with jQuery 1.9, even ballpark, days?, weeks?, months?
    Cheers, Kevin Logan

  4. WOWSlider.com
    Member
    Plugin Author

    Posted 1 year ago #

    New version 2.9 is ready. Please, try it.

  5. klogan2
    Member
    Posted 1 year ago #

    That's fabulous. Will try in 1/2 hour or so & report back. Cheers

  6. klogan2
    Member
    Posted 1 year ago #

    pretty sure I am getting an error (Chrome so far), ~line 886 unminified,
    jQuery("#wowslider-container%ID%").wowSlider({ unrecognized expression

    But it's WORKING :)

    Edit,,, sorry, it's not completely working I think. If I mouseover the slides I don't get the forward/back buttons/icons
    Yes?

  7. klogan2
    Member
    Posted 1 year ago #

    Sorry to take so long checking this in FireFox, but got same error:
    Error: Error: Syntax error, unrecognized expression: #wowslider-container%ID%
    Source File: http://code.jquery.com/jquery-1.9.0.min.js?ver=1.9.0
    Line: 2

  8. WOWSlider.com
    Member
    Plugin Author

    Posted 1 year ago #

    Probably WOWSlider plugin was installed incorrectly.

    Please see instruction "How to Create WordPress jQuery Slider" on our website:
    http://www.wowslider.com/wordpress-jquery-slider.html

  9. klogan2
    Member
    Posted 1 year ago #

    You're right. SOrry. It's working perfectly.
    Thanks much, Kevin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.