WordPress.org

Ready to get started?Download WordPress

Forums

WOW Slider
[resolved] wow slider not working in HTTPS site (3 posts)

  1. franclin
    Member
    Posted 7 months ago #

    I have Wow slider 4.1 installed and it runs perfectly on my site using http BUT it does not work when you type in httpS

    Why would the secure page break the slider? ps this is also affecting my shadow box. -don't know if the two are related.

    the site:
    https://odr-gear.com/product/hotshot-s3/
    &
    http://odr-gear.com/product/hotshot-s3/

    http://wordpress.org/plugins/wowslider/

  2. WOWSlider.com
    Member
    Plugin Author

    Posted 7 months ago #

    WOWSlider generates paths to files according to your WordPress settings. So, if your site is "https", all paths in HTML code should be "https" too. It's not so in your case. There are many links begin from "http". For example:

    ...
    <script type='text/javascript' src='http://odr-gear.com/wp-content/plugins/lightbox-2/lightbox-resize.js?ver=1.8'></script>
    ...
    <link rel='shortlink' href='http://wp.me/p1qcpx-i5' />
    ...
    <meta property="og:image" content="http://odr-gear.com/wp-content/uploads/2011/10/hotShotS3_featuredImage.jpg" />
    ...
    <div id="topmenu">
    <ul id="menu-odr-thin" class="superfish nav"><li id="menu-item-582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-582"><a href="http://odr-gear.com/">Home</a></li>
    ...
    <p>Hot­Shot youth is avail­able in the <a title="HotShot Series2" href="http://odr-gear.com/product/hotshot-s2/">Series-​​2</a> style only.</p>
    ...

    etc.

    It means that something is wrong with your settings. Please try to follow this instruction:
    http://make.wordpress.org/support/user-manual/web-publishing/https-for-wordpress/

  3. franclin
    Member
    Posted 7 months ago #

    Thank you. Changing the URL address under the 'General' tab fixed all of the relative image links on the site. After that it was a simple process of searching for non relevant links and replacing them with https.

Reply

You must log in to post.

About this Plugin

About this Topic