WordPress.org

Ready to get started?Download WordPress

Forums

WOW Slider
[resolved] WOW Slider not sliding (14 posts)

  1. vanguardbookkeeping
    Member
    Posted 7 months ago #

    I use WOW Slider 4.1 for a rotating banner on home page vanguardbookkeeping.com.au

    I has been working just fine until recently.
    Now the home page doesnt format right, and shows all five images underneath each other - no rotating on one image.

    I enforce SSL for everything, also have plugins -
    All in one SEO Version 2.1.4.1
    Better WP Security Version 3.5.6
    BackupBuddy Version 4.1.2.2

    On suggestion, I added the following code to header.php

    <html><head> <script> function fnCreateStyleSheets() { for (i=1 ; i <= 32; i++) { document.createStyleSheet() StyleSheetCount.innerText = "Total Style Sheets = " + i } } </script> </head><body onLoad="fnCreateStyleSheets()"> <div id="StyleSheetCount"></div> </body></html>

    Now in Explorer if I select "Show all Content" (not only secure content), then it works just fine.
    Maxthon browser works just fine
    But Firefox and Chrome browsers doesnt format right, and shows all five images underneath each other - no rotating of one image.

    header.php as below. Any insights would be appreciated.

    <div id="top">
    
    <div id="blogname">
    <div class="logo">/" title="Vanguard Logo"><img alt="Vanguard Logo" src="<?php bloginfo('stylesheet_directory'); ?>/images/logo.png" /></div>
    </div>
    <div class="webutation">
    <div id="webutation-badge">
    <script type="text/javascript">
    (function() {
    window.domain = 'vanguardbookkeeping.com.au';
    function async_load(){
    var s = document.createElement('script'); s.type = 'text/javascript'; s.async = true;
    var p = ('https:' == document.location.protocol ? 'https://' : 'http://');
    s.src = p+'www.webutation.net/js/load_badge.js';
    var x = document.getElementById('webutation-link'); x.parentNode.insertBefore(s, x); }
    if (window.attachEvent) window.attachEvent('onload', async_load); else window.addEventListener('load', async_load, false);
    })();
    </script>
    
    </div>
    </div>
    <div class="contact_no"></div>
    
    </div>
    
    <div id="botmenu">
    <?php wp_nav_menu( array( 'container_id' => 'submenu', 'theme_location' => 'primary','menu_class'=>'sfmenu','fallback_cb'=> 'fallbackmenu' ) ); ?>
    
    </div>
    
    </div><!--end masthead-->
    
    <div id="casing">
    <?php if (is_front_page()){ ?>
    <div id="pslider">
    
    <?php wowslider(2); ?>
    
    </div>
    <?php } ?>

    http://wordpress.org/plugins/wowslider/

  2. WOWSlider.com
    Member
    Plugin Author

    Posted 7 months ago #

    I have just checked your page. The reason of problem is a conflict between "https" and "http". Your site uses "https", but paths to all files in HTML code begin from "http". Protocol "https" means that browser will block all content that tries to use "http" protocol.
    WOWSlider plugin (and other plugins too) generates URLs according to WordPress settings. So, your settings are incompatible with HTTPS. Please follow the instruction:
    http://make.wordpress.org/support/user-manual/web-publishing/https-for-wordpress/

  3. vanguardbookkeeping
    Member
    Posted 7 months ago #

    Thank you for your reply.

    The General settings WordPress Address (URL)and Site Address (URL) are both pointing to https.

    Could it be something to do with Better WP Security Plugin and SSL Option Enforce Front end SSL set to whole site?

  4. WOWSlider.com
    Member
    Plugin Author

    Posted 7 months ago #

    Some links in your HTML code are "http" and others are "https". Except WOWSlider links, you have "http" here:
    <a href="http://vanguardbookkeeping.com.au/contact-us/">Contact us</a>
    and here:

    <div class="inner_box" style="width:700px;" >
            <a href="http://www.icb.org.au/About%20Us/The%20Institute%20and%20its%20objectives" title="ICB Crest" target="_blank" class="footer_aimg" style="margin-right:60px;">

    I can repeat this situation, only if Site Address (URL) is "https" and WordPress Address (URL) is "http". So, make sure that you use "https" for BOTH parameters and send us the screenshot.

  5. vanguardbookkeeping
    Member
    Posted 7 months ago #

    Slider as it appears in Chrome and Firefox - but appears good in Maxthon, but also in Explorer 11 if also select "Show all Content"
    https://dl.dropboxusercontent.com/u/2050259/Slider.JPG

    General Settings
    https://dl.dropboxusercontent.com/u/2050259/general%20settings.JPG

    Really there is no reason for my entire site to be https - just the contact us page. Somehow I thought it would be simpler to run the whole site https

  6. vanguardbookkeeping
    Member
    Posted 7 months ago #

    how do you post piccies?

    I am now looking for where to edit the quick contact button and footer

  7. WOWSlider.com
    Member
    Plugin Author

    Posted 7 months ago #

    Your general settings are correct, so paths to WOWSlider files should be "https".
    If you select "Show all Content" in IE browser, it means that you allow to load content from both "https" and "http" URLs manually. It's not correct behaviour: this dialog shouldn't appear and WOWSlider should be uploaded automatically.
    Our developers have only on suggestion: you use a special "caching module". So, if you used incorrect settings initially, they stay in the cache and don't change. Please check it.
    If problem will persist, please give us the access to your WordPress and we'll try to fix this problem. You can send us this info via email. It'll not be shared, and you can change the password after that.
    Thanks for your patience.

    Regarding your second post... I'm not sure that understand you correctly... But "quick contact button and footer " don't related with WOWSlider.

  8. vanguardbookkeeping
    Member
    Posted 7 months ago #

    I created an admin user login for you - login details emailed to your support@wowslider.com

  9. WOWSlider.com
    Member
    Plugin Author

    Posted 7 months ago #

    Unfortunately, we have not received your information. Please re-send it.

  10. vanguardbookkeeping
    Member
    Posted 7 months ago #

    I have emailed your support@wowslider.com again.

    Alternately, try logging into my site with email support@wowslider.com or username WOWSlider and generate a password reminder.

  11. vanguardbookkeeping
    Member
    Posted 7 months ago #

    Could the problem be here?

    <link rel='stylesheet' href='http://vanguardbookkeeping.com.au/vanguard-content/uploads/wow-slider-plugin/2/style.css' type='text/css' media='all' />
    <!-- Name: WOWSlider -->

    <!-- Start WOWSlider.com BODY section -->
    <div id="wowslider-container2">
    <div class="ws_images">

    • <img src="http://vanguardbookkeeping.com.au/vanguard-content/uploads/wow-slider-plugin/2/images/banner1.jpg" alt="banner1" title="banner1" id="wows2_0"/>
    • <img src="http://vanguardbookkeeping.com.au/vanguard-content/uploads/wow-slider-plugin/2/images/banner2.jpg" alt="banner2" title="banner2" id="wows2_1"/>
    • <img src="http://vanguardbookkeeping.com.au/vanguard-content/uploads/wow-slider-plugin/2/images/banner3.jpg" alt="banner3" title="banner3" id="wows2_2"/>
    • <img src="http://vanguardbookkeeping.com.au/vanguard-content/uploads/wow-slider-plugin/2/images/banner4.jpg" alt="banner4" title="banner4" id="wows2_3"/>
    • <img src="http://vanguardbookkeeping.com.au/vanguard-content/uploads/wow-slider-plugin/2/images/banner5.jpg" alt="banner5" title="banner5" id="wows2_4"/>
    </div>
    </div>
    <!-- End WOWSlider.com BODY section -->

  12. WOWSlider.com
    Member
    Plugin Author

    Posted 7 months ago #

    Yes, links to WOWSlider files should begin from "https", not from "http". You changed paths for "WordPress Address (URL)" and "Site Address (URL)" parameters at Settings-General page, so paths to WOWSlider files should be updated automatically. It's so on our test server.

    WOWSlider uses "wp_upload_dir()" function of WordPress to generate paths to files. For unknown reasons, "WP_CONTENT_URL" constant returned paths with "http", although your settings (Settings->General) are correct. Unfortunately, our developers didn't find the reason of this strange behavior. So, they made changes in the "functions.php" file. The following code was added:

    /** Fix bug with https for wowslider */
    function https_on_for_wp_upload_dir($upload_dir) {
    $https_on = false;
    if ( isset($_SERVER['HTTPS']) && 'on' === $_SERVER['HTTPS'] ) $https_on = true;
    else if ( $url = get_option( 'siteurl' ) ){
    $url = @parse_url( $url );
    if ( isset($url['scheme']) && 'https' == $url['scheme'] )
    $https_on = true;
    }
    if ( $https_on && is_array( $upload_dir ) ) {
    foreach( array('url', 'baseurl') as $k ) {
    if ( ! isset($upload_dir[$k]) ) continue;
    if ( substr( strtolower( $upload_dir[$k] ), 0, 5 ) == 'http:')
    $upload_dir[$k] = 'https' . substr( $upload_dir[$k], 4 );
    }
    
    }
    return $upload_dir;
    }
    add_filter( 'upload_dir', 'https_on_for_wp_upload_dir' );

    Now your slider works correctly.

    Thanks for your patience.

  13. vanguardbookkeeping
    Member
    Posted 7 months ago #

    Thank you for your help with this...

    Awesome :-)

  14. WOWSlider.com
    Member
    Plugin Author

    Posted 7 months ago #

    You're welcome!

Reply

You must log in to post.

About this Plugin

About this Topic