WordPress.org

Ready to get started?Download WordPress

Forums

Advanced AJAX Page Loader
Works with pages but not posts (2 posts)

  1. SpaciousMind
    Member
    Posted 1 year ago #

    Hi I have a site with several pages (static) then 2 blog categories linked from the menu, News and Press. The static pages all load in fine with AJAX and work great, but the ones for News and Press do not -- just get the "Loading... Please Wait..." forever.

    I tried debug mode and only got the message about the search form, but am not using the search and get the message on the pages that do work also. Other threads on Advanced AJAX Page Loader say that's not a problem.

    Using Responsive -- and it seems to be ok when I switch to TwentyTwelve, so am wondering if there's something I can look for/change/fix where Responsive is concerned.

    Thanks for any help.

    Site (in development):
    http://www.wednesdayrecords.com/southsideamerican

    http://wordpress.org/extend/plugins/advanced-ajax-page-loader/

  2. SpaciousMind
    Member
    Posted 1 year ago #

    OK I figured it out, if anyone else runs into this problem:

    archive.php in Responsive has the content div with an id of "content-archive" instead of just "content". Changed that to "content" in my child theme and it works great now.

    This leads to a follow up question for the plugin developer:

    Is there a way to designate more than one div id for the plugin to swap out, or can there be in future versions? I'm not sure yet if changing "content-archive" to "content" will lead to any repercussions down the line -- I'd rather leave the id that the theme developers used if possible.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.