WordPress.org

Ready to get started?Download WordPress

Forums

Tweeple
[resolved] Works and then doesnt (16 posts)

  1. WordPress783
    Member
    Posted 11 months ago #

    Hi,

    I just set this up, and it worked fine for 5 minutes... then it just started showing:

    a

    Any ideas?
    thanks
    Michael.

    http://wordpress.org/plugins/tweeple/

  2. ariane1001
    Member
    Posted 11 months ago #

    Hi

    Same problem here...
    Anybody any idear?

    Thanks, Ariane

  3. Larryhir
    Member
    Posted 10 months ago #

    Have had the same issue. It will load once, then I get the "a" on subsequent page loads.

  4. Jason (Theme Blvd)
    Member
    Plugin Author

    Posted 10 months ago #

    Is there anything more specific you guys can tell me about how you're setting up your Twitter feeds? Anything that could lead me to duplicate the issue? Obviously if all three of you are getting the same thing, there's something to it. But I'm not quite sure how you guys are getting this.

  5. Niels van Renselaar
    Member
    Posted 7 months ago #

    I have the same issue! I noticed it was a tweet with a ' in the text, which messes up your transient cache (serialized array) I guess!

  6. Niels van Renselaar
    Member
    Posted 7 months ago #

    Example serialized array which gives an error from the option '_transient_tweeple_81';

    a:3:{s:4:"info";a:3:{s:2:"id";i:81;s:4:"type";s:13:"user_timeline";s:4:"name";s:17:"Worldmapping Feed";}s:7:"options";a:9:{s:11:"screen_name";s:12:"worldmapping";s:4:"slug";s:0:"";s:17:"owner_screen_name";s:0:"";s:6:"search";s:0:"";s:11:"result_type";s:5:"mixed";s:16:"exclude_retweets";s:3:"yes";s:15:"exclude_replies";s:3:"yes";s:4:"time";s:2:"no";s:5:"count";s:1:"3";}s:6:"tweets";a:3:{i:0;a:10:{s:6:"id_str";s:18:"425599655368728576";s:4:"text";s:140:"'Because something small to me can mean the world to others'.
    Wauw Emmy, wat een prachtige video van jouw expeditie! https://t.co/T3U3VtAHjq";s:4:"time";s:30:"Tue Jan 21 12:03:59 +0000 2014";s:6:"author";s:12:"worldmapping";s:17:"profile_image_url";s:75:"http://pbs.twimg.com/profile_images/1221690724/Logo-Worldmapping_normal.jpg";s:23:"profile_image_url_https";s:76:"https://pbs.twimg.com/profile_images/1221690724/Logo-Worldmapping_normal.jpg";s:13:"retweet_count";i:1;s:14:"favorite_count";i:0;s:6:"source";s:83:"<a href="https://about.twitter.com/products/tweetdeck" rel="nofollow">TweetDeck</a>";s:4:"lang";s:2:"nl";}i:1;a:10:{s:6:"id_str";s:18:"425325625474568193";s:4:"text";s:136:"Spannend :) RT @AnneReneetje: Nog maar één maandje tot ik naar #Uganda ga! Vandaag het reisprogramma binnengekregen van @worldmapping.";s:4:"time";s:30:"Mon Jan 20 17:55:05 +0000 2014";s:6:"author";s:12:"worldmapping";s:17:"profile_image_url";s:75:"http://pbs.twimg.com/profile_images/1221690724/Logo-Worldmapping_normal.jpg";s:23:"profile_image_url_https";s:76:"https://pbs.twimg.com/profile_images/1221690724/Logo-Worldmapping_normal.jpg";s:13:"retweet_count";i:0;s:14:"favorite_count";i:0;s:6:"source";s:82:"<a href="http://twitter.com/download/iphone" rel="nofollow">Twitter for iPhone</a>";s:4:"lang";s:2:"nl";}i:2;a:10:{s:6:"id_str";s:18:"425325490036289536";s:4:"text";s:141:"Leuk! RT @lilianwinter: Vanmiddag een voorlichting gehad over het project #Uganda2015 door @worldmapping! Jaaa, ik wil er zo graag heen!
  7. Niels van Renselaar
    Member
    Posted 7 months ago #

    Hmm, it could also be a non-unicode character, which is also in one of the tweets...

  8. Niels van Renselaar
    Member
    Posted 7 months ago #

  9. Jason (Theme Blvd)
    Member
    Plugin Author

    Posted 7 months ago #

    Thanks! I'll get this in the next update on wordpress.org repository.

  10. piermelatto
    Member
    Posted 2 months ago #

    I Still have the same issue. My feed is based on a Brazilian Guy, who speaks portuguese, so it has many different characters. If i select "Yes" on the "UTF-8 Text Encoding", my feed appears, but with a lot of wrong characters. If I do choose "No", the feed doesn`t shows up, and instead I get an "a" letter.

    My plugin is in the Version 0.9.1 , and WordPress on 3.9.

    Any suggestion?

    Thanks!

  11. Jason (Theme Blvd)
    Member
    Plugin Author

    Posted 2 months ago #

    This topic is very challenging to me because I do not speak any languages other than English, and so I've been trying to learn about how encoding works with different characters of different languages.

    Would it be possible for you to provide more specific feedback? Maybe an example of the specific Twitter account? And with UTF-8 encoding on, examples of tweets with characters that do not display correctly?

  12. Jason (Theme Blvd)
    Member
    Plugin Author

    Posted 2 months ago #

    I was just playing with a couple of Portuguese Twitter accounts, and with UTF-8 encoding turned off, everything is working. So, it would be nice to find out specifically what characters cause this break to happen.

  13. piermelatto
    Member
    Posted 1 month ago #

    Hi Jason

    The account i`m trying to replicate is http://www.twitter.com/allamkhodair.

    And this is how the tweets appears on the website (inside the parenthesis I`ll put the original text that should appear)

    👆👆👆👍 Vitória!!!! Bomdemais... Vice liderança do campeonato. Corrida da 1a a ultima volta disputando… http://t.co/e8txUCmWPi
    (Vitória!!!! Bomdemais... Vice liderança do campeonato. Corrida da 1a a ultima volta disputando… )

    UHuhhuHUHu##Poleeeeee para etapa de Curitiba de brdemarcas !!! Carro perfeito da equipe rzmotorsport… http://t.co/sC3yTXX9ym
    (UHuhhuHUHu##Poleeeeee para etapa de Curitiba de brdemarcas !!! Carro perfeito da equipe rzmotorsport… )

    From what I see, all the characters with some kind of accents are displaying with problems. At the first moment they are allgood, but on a second load of the page, all the tweets turn on single "a" character.

    Thanks for your help,
    Piercarlo

  14. Jason (Theme Blvd)
    Member
    Plugin Author

    Posted 1 month ago #

    All right, so I think I've got it figured out. Can you please try it out and let me know?

    Steps:

    1) Update to Tweeple 0.9.2.
    2) Go back to the feed and make sure UTF8 Encoding is turned ON.
    3) Clear your Feed's cache under Manage Feeds (although re-saving the options for your feed would have done this automatically)

  15. piermelatto
    Member
    Posted 1 month ago #

    Thank you very much Jason! It`s working like a charm =)

  16. Jason (Theme Blvd)
    Member
    Plugin Author

    Posted 1 month ago #

    Great, glad to hear it!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.