WordPress.org

Ready to get started?Download WordPress

Forums

WP External Links (nofollow new window seo)
[resolved] Working in reverse. Marks internal links only! (9 posts)

  1. mpmchugh
    Member
    Posted 1 year ago #

    I turned it on just for the blog on a site I'm working on and it's doing the inverse of what it should. All the internal links (like "Continue Reading ->" links) are marked with the icon, but external links are not.

    When I set it to "All Content" as a test, all my menu links had the icons. Very Odd.

    Any idea what could be causing this inverse behavior?

    http://wordpress.org/extend/plugins/wp-external-links/

    I should note I used it on another site recently without a problem, so I'm baffled.

  2. freelancephp
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have the page of your site where it occured?
    Then I can take a look at the html and try to reproduce the problem on my machine.

  3. mpmchugh
    Member
    Posted 1 year ago #

    Sure, you can look here. I only have it set to show in "post contents" which I thought would be limited to the blog, but it seems this also is for pages too. Nevertheless, here's the blog page and you can see that it's behaving in reverse and inconsistently.

    http://dev.growinggenerations.com/about-us/blog/

    Thanks!

  4. freelancephp
    Member
    Plugin Author

    Posted 1 year ago #

    Had a quick look and it seems that it was applied to external links, but also to a few internal links. Those internal links that contain a hash tag # at the end, like: {url}/#more-1172

    I will try to figure out why these links are also threaded as external links. Thanks so far.

  5. mpmchugh
    Member
    Posted 1 year ago #

    Odd. But did you see that the external ones that don't have it applied too? Like the links int he first two stories to abcnews.com?

    Does it not work if you've already got a target="_blank" set on the link?

  6. mpmchugh
    Member
    Posted 1 year ago #

    Here's another thing it's doing odd. The links on this page link to FancyBox overlays, and they are showing the external icon, and it breaks the FancyBox links:

    http://dev.growinggenerations.com/surrogacy-program/surrogates/surrogate-stories/

    Could the problem be a conflict with FancyBox?

  7. mpmchugh
    Member
    Posted 1 year ago #

    I unfortunately will have to disable it for now, as it's conflicting with other things and making it difficult for us to finish testing. If you have any ideas, I can give it a try another time. Thanks!

  8. freelancephp
    Member
    Plugin Author

    Posted 1 year ago #

    I already saved the html of your page. Hopefully I can take a further look at it end of the week. Thanks so far.

  9. freelancephp
    Member
    Plugin Author

    Posted 1 year ago #

    mpmchugh, please check the new version. When I test on my local machine your code works fine. So I think it should be fixed...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.