WordPress.org

Ready to get started?Download WordPress

Forums

Featured Video Plus
[resolved] Worked great... then.... (9 posts)

  1. jamesdonegan
    Member
    Posted 1 year ago #

    Love the plugin, and it was working fabulously, but then when I tried adding videos today, I'm getting an error message that says "Featured Image: For automatically displaying the Featured Video a Featured Image is required." And clicking "Set as Featured Image" isn't doing anything.

    This is after four other posts have worked perfectly.

    What's happening?!

    http://wordpress.org/extend/plugins/featured-video-plus/

  2. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin tries to automatically pull video thumbnails via the platforms api, which fails for some videos. Did you already try to manually add a featured image? A featured image is required to automatically display the video, because most themes check for featured images before calling the function the plugin hooks into.

  3. jamesdonegan
    Member
    Posted 1 year ago #

    I did try to manually set it. To no avail.

  4. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    So the post has a featured image? Do not try using "Set as Featured Image", just use a random picture - it won't be displayed anyways.

    If you did so already: Which video are you using? And which theme? Self-coded?

  5. jamesdonegan
    Member
    Posted 1 year ago #

    I'll try again later, but I am unable to add any featured image. The wheels spin for a second, then nothing happens.

  6. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    FVP does not change anything about the process of adding Featured Images - just about displaying them on the front page. But the problem that your video is not being displayed on the front page is about the missing image, for sure.

    The Featured Image is set using an AJAX Request to the server. Maybe try disabling JavaScript in your browser, WordPress then completely refreshes the page for setting the image and does not try to do it in the background.

    Hope it helps,
    Alex

  7. jwinters
    Member
    Posted 1 year ago #

    Very similar problem here. Tried adding videos, but getting an error message that says "Featured Image: For automatically displaying the Featured Video a Featured Image is required." And clicking "Set as Featured Image" isn't doing anything. So I added a Featured Image. But nothing happens. The Featured Image displays, but not the Featured Video (vimeo).

    Suggestions?

  8. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    jwinters: Which theme are you using? The plugin relies on WordPress core functions (get_the_post_thumbnail) to hook into; the problem is many themes implement their own functions.
    If your theme is freely available (not premium) or you can provide me with the source I can look into integrating featured videos.
    Regards, Alex

  9. jwinters
    Member
    Posted 1 year ago #

    Using the Metro Child Theme, and Genesis is the parent theme.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.