WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Importer
Work with WP 3.5? (14 posts)

  1. jockoe
    Member
    Posted 1 year ago #

    Does anyone know if the importer works with WordPress 3.5?

    http://wordpress.org/extend/plugins/wordpress-importer/

  2. tomontoast
    Member
    Posted 1 year ago #

    Why don't you try it?

  3. jockoe
    Member
    Posted 1 year ago #

    nervous. it's a clients live site that i'll be using it on.

  4. tomontoast
    Member
    Posted 1 year ago #

    Well then try it on a test site. If you have clients you should probably have a test site.

  5. shaunbent
    Member
    Posted 1 year ago #

    I can confirm this is not working with WordPress 3.5 - content imports fine but it is not able to import images or attachments. The document attachements option doesn't work.

  6. annamundi
    Member
    Posted 1 year ago #

    Yes, it's not working with WP 3.5 :(

    Any idea if there is a way to work around the problem? Cause I really need to import images and attachments to continue the site.
    Thanks

  7. jef3000
    Member
    Posted 1 year ago #

    An 'All content' export still works.
    It's just when you export only posts or custom taxonomy, the attachments don't get fetched.

    Is there an update or workaround coming?

  8. giantseattle
    Member
    Posted 1 year ago #

    This is my issue. I can see the posts in the MySQL DB... and the media is in the library... but the posts don't show up in the control panel at all... I think I'll wait for the server to refresh and see if that works.. I'll report back in 24 hours.

  9. CouponCodePlugin
    Member
    Posted 1 year ago #

    I have just imported posts, pages and contact forms separately. All attachments failed to be downloaded and imported. Instead, it just imported the images without downloading them, so the images are still located on the old website.

    I saw what jef3000 said, so I performed an import for all content at once. The image import worked correctly. Thanks jef3000.

  10. jef3000
    Member
    Posted 1 year ago #

    No problem, I hope they get a fix out soon, cause I don't want my new database to be bloated with unused entries.

    CouponCodePlugin, the images get a database entry, so when you just upload the image folder to the new location and change the media library path it should work?

  11. funsail
    Member
    Posted 1 year ago #

    Imports images, but aren't attached back to your posts.

  12. jef3000
    Member
    Posted 1 year ago #

    So the database entries are present?

  13. seedsca
    Member
    Posted 1 year ago #

    OK, bare with me. I saved my old WP install to my computer and also exported everything to an xml file. I switched hosts, installed WP through SimpleScripts, uploaded my original wp-content folder overriding the new one, and imported everything with the download and import file attachments selected.

    It all seemed to work well except my images are not linked right.
    I have a link to an image in a post named roadtripA1931-266x400.jpg
    But when I look in the FTP there is the original and four other sizes, but not that particular size. There is another image link that has a 1 at the end of the file name there for does not work.

    Should I take this up somewhere else? I think it pertinent to here, but if not sorry.

  14. funsail
    Member
    Posted 1 year ago #

    you need to split the export file

    I had to split by post, so eg post1 and post1's pics are all in same file, so the import can link the images

    the other just splits by size so nothing is re-attached.

    it's so annoying I end up having to split a 1mb file into 100kb imports, splitting by keywords using a program.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.