WordPress.org

Ready to get started?Download WordPress

Forums

Wordspew live shoutbox caching user name (2 posts)

  1. ronhaha108
    Member
    Posted 6 years ago #

    I use the wordspew live shoutbox as a widget in my sidebar, I've noticed that with wp-super-cache enabled, my username is cached so that anyone using the shoutbox will be posting as my user name. I've tested by turning on and off wp-super-cache, off, works correctly (shows a text box where u can type in a name) -- on, shows my username no matter if it's guest or not. Not sure how to fix this problem.

    Thanks!
    Ron

  2. Donncha O Caoimh
    Member
    Posted 6 years ago #

    ronhaha108 - does that widget set a cookie? Look in your .htaccess and add a rule for that cookie. The super cache will be disabled.

    You could also look in plugins/ and write a similar plugin to searchengine.php to examine the cookie and change the cache key.

Topic Closed

This topic has been closed to new replies.

About this Topic