WordPress.org

Ready to get started?Download WordPress

Forums

Words with accents deletes the rest of the post (4 posts)

  1. ItaloFM
    Member
    Posted 3 years ago #

    I just finished installing WP and came across this weird issue.

    When I create a new post or try setting up a new page, I cannot put accent on any of the words. (as my page is in Brazilian portuguese, this will be a must on 3 out of 6 words.)

    I can edit the post, type with accents and all, but as soon as I click preview, I only see the words prior to the accent, the rest of the content is blank. If I take the accent out, the content loads up just fine. If I save I get the same results. It also makes me lose all the data after the word with accent.

    i.e: a post with the title: Hoje é dia de ler.
    I would only see: "Hoje"

    If I type a post without accents, I can post anything I want with as many characters as I want to. My issue is only with the crazy, á,é,ç,ã,ô and so on...

    I've tried everything:
    Before, I had WP-English installed, uninstalled completely and installed it in Brazilian portuguese.
    I tried to install a patch called UTF-8 Database Converter, but also did not help.

    I tried changing themes, nothing seems to work.

    Has anyone had this problem?

    I appreciate the attention and help as this is a dead end to me, unless I want to write everything wrong on my blog, which is not what I'm looking forward to.

    here is a quick example of what happens:

    http://www.ohlokomeu.com/wordpress/

    The body should say:

    Hoje e dia de ler

    Hoje é dia de ler

    ================

    But as u can see, after the accent, everything gets deleted for some reason.

  2. flamenco
    Member
    Posted 3 years ago #

    Oi,
    The "test acentua" looks great to me. I checked it in Firefox, Chrome, and IE, and I can see the palavras just fine. I even tried entering accents like "música brasileira" in my own blog, and I was able to preview just fine, even though my setup is entirely in English. I do my editing in Firefox.

    I'm really not sure why. The following line in your code does refer to English, and that might be hard-coded in the theme.
    <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US">
    But mine looks something that, and it works fine with accents.

    I was going to ask if you pasted text from MS Word or something, that causes problems, but you said you typed it in.

    If you go to Settings...Reading... and look at Encoding for pages and feeds, does it say UTF-8? If so, I'm stumped. Maybe your browser or your computer keyboard is funny?

    Good luck,
    Dave

  3. ItaloFM
    Member
    Posted 3 years ago #

    Thanks for the reply Dave.

    I did check prior for the settings and the encoding is set as UTF-8.

    As per the theme and WP language. I had previously installed in EN, then I removed it and re-installed it in PT, but the problem persist.

    What is weird is that only when I go and edit the post in the SQL DB and save it in there, that works.

    as you mentioned. the "test Acentua" is fine, but the top one, "teste de post com acentua", that one had a much bigger text input, but got deleted after the accent. "vamos ver se t".

    I'm stuck here too, not sure what else to do.
    And being editing blog posts in my SQL DB every time I post something is not fun. =( can't see that as a solution.

    Thanks again for y'alls time on this.

  4. flamenco
    Member
    Posted 3 years ago #

    I wondered if that was the case ("vamos ver..."). My last idea would be that maybe the database itself needs to be deleted and re-created; possibly the "database converter" is insufficient. Maybe that's not too hard to do since the site is only in testing.

    You could watch very closely what parameters are offered when you are making the database.

    Good luck,
    Tchau

Topic Closed

This topic has been closed to new replies.

About this Topic