WordPress.org

Ready to get started?Download WordPress

Forums

WordPress.com stats showing incorrect counts (7 posts)

  1. swaroopch
    Member
    Posted 5 years ago #

    WordPress.com stats plugin was working for me in my old installation. However, I started a fresh new WP db installation as well as upgraded to WP2.6 (from 2.3) and I transferred the content using the "Export/Import as WordPress eXtended RSS (WXR)" option.

    Immediately after that, the stats plugin is showing incorrect results. My usual top page is now suddenly not appearing anywhere and a random blog post is showing as having top hits, even though the top referrers remains as before. So I'm 100% sure that the stats counts are wrong.

    Can anybody please help on how this can be resolved?

    Regards,
    Swaroop

  2. Lester Chan
    Member
    Posted 5 years ago #

    Any proof to show that you are 100% sure?

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    I transferred the content using the "Export/Import as WordPress eXtended RSS (WXR)" option

    When you did that, all the ID numbers of your posts changed. So now the stats are wrong because the ID's aren't what they used to be any more.

  4. swaroopch
    Member
    Posted 5 years ago #

    @GamerZ The proof is that the referrers are the same and the top hits page is not the same which doesn't make any sense.

    @Otto42 Thanks for the quick reply. I kind of suspected that, but do not know how to fix it. Any suggestions?

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    No, no, you can't fix it. It'll fix itself, eventually.

  6. swaroopch
    Member
    Posted 5 years ago #

    Thanks Otto42 , I really hope so :)

  7. dehay
    Member
    Posted 5 years ago #

    I upgraded to 2.6 when it came out and WP.stats was working fine until three weeks ago. I had to deactivate the WP.Stats because it kept telling me I had Zero visitors for two weeks. Amazing! I run 3 other stats not including my cPanel and they were all showing 500+ per day.

    Also, for some reason WP.stats suddenly had two URL's listed for my blog. One with www. and one without www. That was never there before my 2.6 upgrade. The stats were screwed up, the www. had my best every day correct and the one without "www." had no info for that area.

    Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic