WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress.com Stats is unable to work properly... (9 posts)

  1. brown-rug
    Member
    Posted 4 years ago #

    Hey guys, when I installed the new WordPress.com stats plugin, this error came up:

    WordPress.com Stats is unable to work properly because your theme seems to lack the necessary footer code. Usually this can be fixed by adding the following code just before </body> in footer.php:

    <?php wp_footer(); ?>

    I added that last bit of code at the end of footer.php before </body> but the problem still doesn't seem to go away. Any suggestions on how to make this work? If it's at all helpful this is what is in footer.php as of right now:

    </div>
    </div>
    
    <?php do_action('wp_footer'); ?>
    
    <?php wp_footer(); ?>
    </body>
    </html>

    Thanks in advance for any help you guys are able to provide!

  2. the-kit
    Member
    Posted 4 years ago #

    Just met the same problem.

    The plugin still works and it should be a matter of time before someone on the plugin's development team is able to find a solution to the warning/error.

    Does the plugin work for you? If so, then the superficiality of the error can be disregarded until its eventual update.

  3. westondeboer
    Member
    Posted 4 years ago #

    nice

    To make sure, there has to be no spaces or returns after wp_footer. Just like you have above.

  4. eric1985
    Member
    Posted 4 years ago #

    I just upgraded to the newest version of the plugin and have the same error as above. I also checked to make sure the footer file is correct.

  5. 23ji
    Member
    Posted 4 years ago #

    I ran across the same thing, and the code was already present in footer.php. I took all the blank lines out and the error disappeared. Not sure if that had anything to do with it, or if clicking "save" a few times will clear it, but it might be worth a shot.

  6. diymaker
    Member
    Posted 4 years ago #

    i have the same problem, i turn off the WP-super cache and turn it on again, then it disappear, i think something not update on cache files

  7. kandrei
    Member
    Posted 4 years ago #

    I had the same problem now and got rid of it by disabling W3 Total Cache and enabling it again.

  8. d3a1i0
    Member
    Posted 4 years ago #

    I am also seeing this message after upgrading Akismet, WP Stats, WP Super Cache, and WP Minify in that order. I noticed the error between updating WP Stats and WP Super Cache.

    My theme file does have <?php wp_footer(); ?> right before the </body>

    I disabled and re-enabled both WP Super Cache and WP Minify and then had to set up WP Super Cache all over again.

    I also went into the theme's footer.php and both deleted the whitespace before and after <?php wp_footer(); ?> and then copied and pasted <?php wp_footer(); ?> from the error into the theme file just to make sure it was exact.

    I still have the error showing. I thought I would just document my experience and hope they have another update to fix it soon.

    Update: Even though I was clicking around the admin panel all over I went back in and refreshed my browser (Chrome) and it went away.

  9. iridiax
    Member
    Posted 4 years ago #

    Update: Even though I was clicking around the admin panel all over I went back in and refreshed my browser (Chrome) and it went away.

    A browser refresh got rid of it for me too.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags