WordPress.org

Ready to get started?Download WordPress

Forums

WordPress.com Stats
WordPress.com Stats: Stopped working (11 posts)

  1. gambalunga
    Member
    Posted 3 years ago #

    My WordPress.com Stats stats have suddenly stopped working on two of the sites that I manage (one being my own designcredo.co.uk . I am getting the error below where apikey is obviously my API key.

    The URL you requested has been blocked. URL = dashboard.wordpress.com/wp-admin/index.php?noheader=true&proxy&page=stats&key=apikey&blog=11200852&charset=UTF-8

    All my sites use the same API key, the sites that don't work now use different themes

    Any suggestions?

  2. Andy Skelton
    Member
    Plugin Author

    Posted 3 years ago #

    Contact your host and ask them why they are blocking that URL.

  3. gambalunga
    Member
    Posted 3 years ago #

    After posting I reverted to 1.7.5 (the problem is with 1.8.1).

    Everything works ok with 1.7.5 so I guess I will have to trawl through and see what has changed.

    Is it just me but have the API keys become harder to retrieve now?

  4. Andy Skelton
    Member
    Plugin Author

    Posted 3 years ago #

    In versions 1.8 and 1.8.1, that URL is only slightly different from version 1.7.5. One important difference: it is http in 1.8 and https in 1.7. (This change was made to accommodate users on hosts which do not provide SSL for encrypting outbound connections.)

    I suspect that your host has an overly strict firewall that prevents you (and your software, including the stats plugin) from connecting to other services on the internet. That is why I suggested you contact your host. It is still my advice to you.

    I hope you see that your host's firewall (if my suspicion is correct) is a naive design for naive users. You are using powerful software and should not be restricted in this manner.

    Please post here when you get an answer from your host. I'm interested to learn who they are and why they do this.

  5. raymer
    Member
    Posted 3 years ago #

    I have the same problem. wp-stats works great for me through 1.7.5 but when I update to 1.8.x I get the error that stats needs attention. When I click the link it doesn't show the API key field, it simply says "you must connect this blog with your wp account" or something similar.

    I am using pair.com as my hosting service. They are respected in the business and don't have overly restrictive firewall rules. I use svn:externals to pull your plugin from http://plugins.svn.wordpress.org/stats/trunk/ so I can rollback easily. What kind of debug info would you like?

    Thanks for the great plugin,
    Ray

  6. raymer
    Member
    Posted 3 years ago #

    Exact error message with 1.8.1 is:
    WordPress.com Stats needs attention: please connect your blog to WordPress.com or disable the plugin.

    And I notice that "connect your blog to WordPress.com" links to this URL:
    http://www.mydomain.com/wp/wp-admin/options-general.php?page=wpstats
    Which is the link for the current page so it doesn't actually take you anywhere except to a page refresh...
    (yes, I am running wp in a subdir called "wp")

    Running 1.7.5 for now...

  7. petercliff
    Member
    Posted 3 years ago #

    I upgraded recently and my stats stopped five days ago, having worked perfectly before. I unistalled the plug-in and re-installed it with the same API as before, which it recognised and put back all the old data - BUT CURRENT DATA FEED IS STILL DEAD! Most frustrating.

    I have contacted Coolhandle, my host, but as yet no solution.

    Can Automattic please find one otherwise this plug-in is on no use.

    Many thanks.

  8. gambalunga
    Member
    Posted 3 years ago #

    I reverted to 1.7.5, probably get you a copy

    I know it's the long term answer but saves time

    The problem (to appear negative sometimes) is that unless one is paying a lot for hosting there is only so much support to reasonably expect from hosts.

    Mine are pretty helpful but...
    http://designcredo.co.uk/

  9. petercliff
    Member
    Posted 3 years ago #

    Thanks gambalunga, that may be the only solution i.e. revert to an earlier version.

    I ran the htttp/https stuff by my host Coolhandle but they didn't want to know. It's a third party problem as far as they are concerned "over which they have no control". So dead end there. Automattic needs to start an education programme with hosting companies, otherwise its plug-in cannot progress further.

  10. raymer
    Member
    Posted 3 years ago #

    I don't think that (firewall) is the problem. I suspect it is more like any host that doesn't support PHP with SSL support will have problems. I don7t have a second class hosting service but they don7t support SSL Don't know whay they can't fallback to http which worked fine until 1.7.5...

    :-(

    -Ray

  11. archon810
    Member
    Posted 3 years ago #

    Same problem for a few months now on one of my blogs after upgrading to the latest version of the plugin. The other blog hosted on the same server is fine though.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags