WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress3.4 upgraded now hangs on Database Upgrading Page (16 posts)

  1. bazhawkeye
    Member
    Posted 1 year ago #

    Hi, I've upgraded 3.3 to 3.4 via the dashboard and everything went well until the Database Needs Upgrading page appeared. I clicked on the Upgrade Database icon and all I have had for the past 4 hours is a white page with the WordPress logo on it.

    I have flushed my browser's cache and can get the site up by typing in it's www address, but I cannot log into the dashboard.

  2. bazhawkeye
    Member
    Posted 1 year ago #

  3. White page usually (almost always) means 500 Internal Error.

    Give this a try:

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    That Codex article will provide you with a method to deactivate the plugins even when you cannot login via the WordPress dashboard. You will need file level access to your server (FTP or whatever file management tools your host provides you with) or mysql database access.

  4. bazhawkeye
    Member
    Posted 1 year ago #

    I have done all of this, and more. I have checked the database and that is OK.

    I have deleted the wp-admin and wp-includes folders and uploaded new versions.

    I have deleted all the files in the root folder, uploaded all new files and placed a new wp-config.php file there.

    I have copied the new items in wp-content into the correct folders.

    I have re-named plugins to plugins-hold.

    I still cannot get the system to work, just a blank white screen.

    I have tried running wp-admin/install.php but that just takes me to my host servers advertising page.

    I even re-installed an earlier version of WordPress and that will not work.

    HELP>>>>>>>>>>>>>>>>>>>>>> PLEASE

  5. lillyk
    Member
    Posted 1 year ago #

    I have 5 of these across my website and can not get into my wp-admin site it has the same thing...How can i go back to the last version....This version 3.4 is not working for me...Really need help. Thanks

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/home/kojorepo/public_html/wp-content/themes/google-news/google_news.php/style.css) is not within the allowed path(s): (/home/kojorepo/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/kojorepo/public_html/wp-includes/theme.php on line 386

  6. jparkton
    Member
    Posted 1 year ago #

    src="http://img.sedoparking.com/registrar/dopark.js">

    this is where your domain name is pointing according to the DNS settings. Do you have hosting with sedoparking.com? Check your DNS settings in your registrar control panel.

  7. MatWitts
    Member
    Posted 1 year ago #

    GO HERE:-

    http://www.clickonf5.org/2247/solution-database-upgrade-required/

    if that doesn't work also check your memory_limit in your hosting PHP config.

  8. bazhawkeye
    Member
    Posted 1 year ago #

    Done the above. version in version.php was 20596. On db options it was 19470. I have changed it but still no luck. I have downloaded a further download of 3.4, uploaded it etc. and the thing still shows a white page. I am very, very, very frustrated now having spent hours trying to sort this out. Can anyone help me PLEEEEEEEESE?

  9. A white screen like that almost always is a 500 web server error.

    Do you have access to your webserver's error_log file? That should tell you where it is tossing the error. If you don't have access then you may need to ask your host for assistance.

  10. Avi Jit (skyhitblog)
    Member
    Posted 1 year ago #

    Problem when I search for any plugin from inside the Admin area:

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

  11. @skyhitblog? Please start your own thread. What you've described is completely different from this issue.

    It's considered impolite to interrupt someone else's thread like that.

    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

  12. bazhawkeye
    Member
    Posted 1 year ago #

    I have altered the htaccess file to show errors messages when I try to access the site. Below are what I have got. I don't know what they mean, can any help please?

    I have disabled all the plugins by er-naming the plugins dir to plugins_hold

    Errors

    Warning: require_once(/vhost/vhost10/s/s/-/ss-thomas-stephen.org.uk/www/wp-content/plugins/db-cache-reloaded-fix/db-module.php) [function.require-once]: failed to open stream: No such file or directory in /vhost/vhost10/s/s/-/ss-thomas-stephen.org.uk/www/wp-content/db.php on line 94

    Fatal error: require_once() [function.require]: Failed opening required '/vhost/vhost10/s/s/-/ss-thomas-stephen.org.uk/www/wp-content/plugins/db-cache-reloaded-fix/db-module.php' (include_path='.:/usr/share/pear:/usr/share/php') in /vhost/vhost10/s/s/-/ss-thomas-stephen.org.uk/www/wp-content/db.php on line 94

  13. I'm pretty sure that wp-content/db.php is the tell, you hit a bug with this plugin

    http://wordpress.org/extend/plugins/db-cache-reloaded/

    Give the master list a read.

    http://wordpress.org/support/topic/troubleshooting-wordpress-34-master-list?replies=4#post-2888909

    From the plugin page:

    How do I uninstall DB Cache Reloaded?

    1. Disable it at Settings->DB Cache Reloaded page. The plugin will automatically delete all cache files. If something went wrong - delete /wp-content/db.php, /wp-content/db-config.ini and /wp-content/tmp folder manually. When wp-content/db.php file exists, WordPress will use our optimised DB class instead of its own.
    2. Deactivate it at plugins page.

    See if that fixes it for you.

    Edit: Yes, I know you can't get to the dashboard, it's the files listed there that you should delete...

  14. bazhawkeye
    Member
    Posted 1 year ago #

    That Fixed it. Thank you so so much.

  15. That Fixed it. Thank you so so much.

    SCORE!

    I mean, I'm glad that worked out for you. ;)

  16. bazhawkeye
    Member
    Posted 1 year ago #

    SCORE 20 out of 10. I have just spent 3 days tearing my white hair out!! You don't know how grateful I am Jan. Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic