WordPress.org

Ready to get started?Download WordPress

Forums

WordPress working with my external IP address but nut FQDN? (6 posts)

  1. rokh4rd
    Member
    Posted 1 year ago #

    I have a domain name forwarding from godaddy to my home network IP address.

    I have LAMP setup on Ubuntu machine, and the home network router setup forward http ports to my Ubuntu machine.

    When I visit the domain name that I am forwarding it only shows text on the site, the graphics are blank, the layout is not there (CSS stylesheets not loading im assuming), etc.

    When I visit the external IP address of my home network everything works fine.

    I have tried 3 variations of the config file in /etc/wordpress:
    config-IP-Address.php
    config-www.domainname.com
    config-domainname.com

    My WordPress install IS IN the main /var/www directory, and NOT in a sub-directory like /var/www/wordpress

    I have tried all variations of the site url, and home url in the Mysql database wp_options folder:

    http://IP-Address.php
    http://www.domainname.com
    http://domainname.com

    What am I missing? This is driving me nuts!

    Thanks!

  2. rokh4rd
    Member
    Posted 1 year ago #

    I edited the httpd.conf file, hosts file, and /etc/apache2/conf.d/name file to all contain entires for:

    ServerName domainname.com

    Now when I visit the domain name from my Ubuntu machines browser the FQDN works fine.

    However, when I try it from my laptop or mobile phone or tablet, it is still show the blank graphics and messed up layout.

    What gives?

  3. rokh4rd
    Member
    Posted 1 year ago #

    bump

  4. ClaytonJames
    Member
    Posted 1 year ago #

    Bumping is usually enthusiastically discouraged here.

    I have tried 3 variations of the config file in /etc/wordpress

    Installing WordPress manually (correctly) in /var/www (the default Apache web root directory) doesn't place a config file in /etc. I think installing WordPress using apt-get usually does that.

    See if any of the information in this thread is any help: http://wordpress.org/support/topic/removing-wordpress-from-site-url?replies=6#post-3527951

    You may want to do some quick reading on host configuration for Apache on Ubuntu. Your key points for Google searching might include /etc/apache2/sites-enabled/ and /etc/apache2/sites-available/

    [edit] I did see this:

    My WordPress install IS IN the main /var/www directory, and NOT in a sub-directory like /var/www/wordpress

    But your details provide some conflicting / counter-intuitive information.

  5. rokh4rd
    Member
    Posted 1 year ago #

    Bumping is usually enthusiastically discouraged here.

    I apologize!

    Installing WordPress manually (correctly) in /var/www (the default Apache web root directory) doesn't place a config file in /etc. I think installing WordPress using apt-get usually does that.

    I uninstalled WP using apt purge, and I removed the associated database manually using DROP command.

    I downloaded the WP tar.gz, and placed all the files in the "/var/www" directory.

    I manually configured the "wp-config" file.

    I visited my "domain" from my laptop and proceeded to setup the install, and everything went fine.

    However, after the install, I tried visiting the "login" page, and it came up blank.

    I looked at the "wp-options" table through phpMyAdmin, and I noticed that both the "siteurl" and "home" fields were populated with my "external" IP address during the install.

    I tried changing the "siteurl" and "home" to my domain name, and after doing that when visiting the site it shows the site with blank graphics, and no layout.

    Why is the install script grabbing my external IP address, and why when I change the "siteurl" and "home" fields in the "wp-options" table does it not work?

    Thanks!

  6. ClaytonJames
    Member
    Posted 1 year ago #

    I edited the httpd.conf file, hosts file, and /etc/apache2/conf.d/name file to all contain entires for:

    This is just a guess mind you, but I would probably start by taking a look at those files, and reversing any edits you may have made in them.

    I tried changing the "siteurl" and "home" to my domain name, and after doing that when visiting the site it shows the site with blank graphics, and no layout.

    Why is the install script grabbing my external IP address, and why when I change the "siteurl" and "home" fields in the "wp-options" table does it not work?

    Another guess on this one, but if the install happened with your ip address in the url rather than your domain name, all references in the database would be numeric instead of the domain name. That may or may not be causing the issue with no style. Search and replace on the database may be required - or just a quick reinstall from another computer, using the domain name during the install process, once you sort out the config file errors and fill in the domain name and domain alias information in /etc/apache2/sites-enabled/000-default. I should think that would do it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.