WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Won't Install (8 posts)

  1. ranger6350
    Member
    Posted 8 years ago #

    Hi-
    I get to the 2nd screen in install.php and there's a lockup. I get the second screen info but nothing further happens. Have re-upped the files and talked to tech support for server . They say it's an error with the WordPress files, in that the server is set up right and the error message is:

    The error message is :
    [error] PHP Fatal error: Call to undefined function: make_db_current_silent() in /home/world/domains/worldsweeper.com/public_html/editorblog/wp-admin/install.php on line 139

    Any ideas anyone? Thanks!

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Who is your host ?

  3. ranger6350
    Member
    Posted 8 years ago #

    It's called esecuresite2.com, run by proweb. I have several php bulletin boards, phpmydirectory, etc., set up on this and other sites with them and have had no trouble.

  4. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Did everything upload as 4 folders and some files ? Or one big folder with many files ?

    Have you checked that all files have fully uploaded and none have a filesize of zero ?

    Were all files uploaded in ASCII mode ?

  5. ranger6350
    Member
    Posted 8 years ago #

    4 folders and the files. No zeros, all there. All in Transmit ftp's default, but it doesn't typically make mistakes in that regard. I'm wondering if it's permissions, though. I see that index.php is all zeros, for example. So was wp-admin folder, but I changed it to 755 and that didn't make any difference. install.php is set at 755. Any idea what those should be or is there a listing somewhere? (BTW, thanks for taking a look at this for me!)

    The wp-config file is pasted below. I have tried it with WPLANG left blank the way it came and with 'en.mo' in that spot and it hasn't seemed to matter. Here's the code (except for the bottom that is supposed to stay the way it is), and I'm sure it's right in terms of correct paths/username, etc.

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'world_wordpress'); // The name of the database
    define('DB_USER', 'world_wordpress'); // Your MySQL username
    define('DB_PASSWORD', 'songbirdworld'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'en.mo');

  6. James
    Happiness Engineer
    Posted 8 years ago #

    It may be the permissions. Try setting all of the directories to 755 and all of the files to 644.

  7. ranger6350
    Member
    Posted 8 years ago #

    I changed all the permissions, re-uploaded all the files 'just in case.' Still no go. Do I have to change anything in the wp-config.php after the DB_HOST info? I.e., change the prefix or change to localize WordPress (see above code)? I tried it with no changes to that and with 'WPLANG', 'en.mo' as shown above, neither of which worked.

  8. brunod
    Member
    Posted 8 years ago #

    To make a short story, I had the same exact error message on step 2 of installation, I checked and some files had 0 bytes in size on my ftp directory. I cleared the directory, re-uploaded and voila! Blame it on my ftp client...

    To make a longer story, this happened because I was having trouble uploading due to my ftp client / hosting being slow (was using Cute FTP). I downloaded Filezilla which I'm using often at work, re-uploaded the files, but with the option to overwrite only if newer. Maybe that's a bug in Filezilla, because the files having 0 bytes are not overwritten (it probably checks only for the timestamp and doesnt compare file sizes). Anyhow, I deleted all the files to make sure, re-uploaded and now it works.

    Another open-source success story :) Thanks for this great blogging tool, I have 3 blogs up using WordPress for different topics :p

Topic Closed

This topic has been closed to new replies.

About this Topic