WordPress.org

Ready to get started?Download WordPress

Forums

WordPress visual/html editor stripping out links (10 posts)

  1. patrickhealy
    Member
    Posted 2 years ago #

    I have just had something very strange start to happen. Whenever I access a page or post and I want to edit/update it WordPress automatically strips out any URLs or image links in the code. This is infuriating. It means I have to take the code into Dreamweaver and make my edits there and throw it in the html editor. If something is wrong I have to continue to edit in dreamweaver until it's correct. The other alternative would be to redo all the work after every time I update the page. This is driving me nuts. Any recommendations?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Are you switching between editing tabs?

  3. patrickhealy
    Member
    Posted 2 years ago #

    nah, I stopped doing that years ago when I found the pitfalls of it stripping out the paragraph tags.

    I installed Advanced TinyMCE which has an option to keep it from doing that and it all stopped working just recently.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Try posting in the plugin's forum.

  5. patrickhealy
    Member
    Posted 2 years ago #

    I don't think it's the plugin. WP's editor has been a problem for quite some time. Many of my friends have long left it behind. I just installed Live Writer and I don't think I will ever look back.

  6. mephron
    Member
    Posted 2 years ago #

    I'm having the same issue - editing a page and all the URLs are gone. I am not switching between editing tabs, nor am I using any editor-related plugins other than the "After The Deadline" addon that comes with Jetpack.

    I have to edit in a text editor and paste it in, to insure I keep everything properly in place. That seems inefficient at best.

  7. patrickhealy
    Member
    Posted 2 years ago #

    The weird thing is, it's so inconsistent across all of my sites. Some are just fine and others will wipe out tons of code just by me accessing the page/post. I don't even have to update it and it go all crazy. I am really really surprised by this as WP in it's own right is so darn stable and well thought out. Like I said before, I have started using Live Writer and I doubt I will ever go back but it makes for limitations when it comes to not working on one of my own machines....

  8. mephron
    Member
    Posted 2 years ago #

    Do you use Chrome? I'm testing something, and it seems frequently that this happens in Chrome.

  9. patrickhealy
    Member
    Posted 2 years ago #

    yes but it happened in Firefox too.

  10. Rob
    Member
    Posted 2 years ago #

    I have a fresh install using the Twenty Eleven theme, with all plugins deactivated and it's stripping out my link URLs too.

    It must be a browser issue as...
    Latest Chrome doesn't work
    Latest Safari doesn't work

    Latest Firefox works fine
    IE9 works fine

    That's all I tested. Bloody annoying. Guess I'll be editing posts with image links in either of those two. I bet I forget!

Topic Closed

This topic has been closed to new replies.

About this Topic