WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Visual editor breaking internal hyperlinks (4 posts)

  1. sabinou
    Member
    Posted 5 years ago #

    Hello,

    On my WP 2.8.4 blog, I observed a very annoying problem, however I can't trace back to when it precisely started, maybe with the 2.8 branch, maybe before.

    To say it simply : my blog contains "summary" pages, and I usuall paste the same chapter with an hyperlink to a summary page into several blog posts.
    I proceed that way : I write my blog post with the visual editor, I open a former blog post with the chapter pointing to the summary page, I copy that chapter (control-c, control-v) into my new post, and I click to save or post it.
    And at this point, 50% of the time, the visual editor will save a broken hyperlink.

    I'm sorry I can't communicate my blog's adress, but let us imagine a summary page is located on
    http://www.my-blog.com/2008/05/12/summary (this is my permalinks structure)
    I create a post located on
    http://www.my-blog.com/2009/08/20/newpost
    - well, 50% of the time, the chapter where I write "don't forget to refer to <i>my summary page</i> for a detailed list of the similar messages, the "<i>my summary page</i>" will incorrectly point to http://www.my-blog.com/2009/08/20/2008/05/12/summary

    I searched a long time, but I can't find any logical reason, nor any person having had that problem before...

    My best bet, for the moment, is that the Visual editor is wrong to paste links starting with ../ instead of absolute hyperlinks, but at this point, I don't know either how to change that setting and force him to go absolute :-/

    Please, if you can help with a suggestion, or a recommendation, that will be most appreciated, I'll be very grateful :)
    Of course, if you request more information, I'm willing to help too :)

    Thanks a lot,
    Sabinou

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    WordPress doesn't deal with relative links very well. Try to post full (absolute) urls instead.

  3. sabinou
    Member
    Posted 4 years ago #

    (thanks for the reply !)
    Well, Esmi, this is what I am doing when I manually insert an hyperlink.

    However, when I copy and paste texts from my other blog notes into a new post, then the links automatically become relative links.

    This is precisely what I'm trying to avoid.

    Would you know of a way of forcing wordpress to keep URLs as absolute, instead of rewriting them ?

  4. robanna
    Member
    Posted 4 years ago #

    Sorry to reopen such an old topic but does anyone have an answer to this issue?

    When I copy/paste text with a link, the url always ends up relative (../link) even if the original is absolute (htt://site.com/link). Many times that causes the link to be incorrect. I end up with something like http://site.com/news/category/news/link instead of http://site.com/news/link.

    Can anyone tell me how to fix this?

    Thanks-
    Rob

Topic Closed

This topic has been closed to new replies.

About this Topic