WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress + Varnish + Nginx (for SSL) error (4 posts)

  1. humansky
    Member
    Posted 3 years ago #

    I'm running a load balanced WordPress infrastructure with Varnish as my caching solution and load balancer and Nginx to handle my SSL traffic (which only forwards to varnish on port 80). Everything works fine when I go to the site through HTTP, but as soon as I got to the site with HTTPS, I get an error:

    Multisite only works without the port number in the URL.

    Any idea what could be wrong? Here is the sample URL:

    http://blogs-qa.princeton.edu (WORKS)

    https://blogs-qa.princeton.edu (ERROR)

    Thank you,
    Henry

  2. humansky
    Member
    Posted 3 years ago #

    Here is my nginx ssl.conf settings:

    location / {
      proxy_set_header "Host:" $host;
      proxy_set_header "X-Forwarded-For" $proxy_add_x_forwarded_for;
      proxy_pass        http://localhost:80;
    }
  3. humansky
    Member
    Posted 3 years ago #

    Silly me....I had a syntax error. Here is my updated conf file on nginx:

    location / {
      proxy_set_header Host $host;
      proxy_set_header X-Real-IP $remote_addr;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    
      proxy_pass        http://localhost;
    }
  4. Multisite only works without the port number in the URL.

    Well ... that's the problem :) MultiSite only works without the port number in the URL. Though it seems to work now?

Topic Closed

This topic has been closed to new replies.

About this Topic